Kvantum and kvantum-qt5-git are in conflict

Heya,

when trying to update it fails due kvantum and kvantum-qt5-git are in conflict. From garuda-update I get:

:: Synchronizing package databases...
core is up to date
extra is up to date
community is up to date
multilib is up to date
chaotic-aur                          1887.4 KiB  1481 KiB/s 00:01 [------------------------------------] 100%

--> Refreshing mirrorlists using reflector, please be patient..
################################################################################
################# Arch Linux mirrorlist generated by Reflector #################
################################################################################

# With:       reflector --latest 5 --age 2 --fastest 5 --protocol https --sort rate --save /etc/pacman.d/mirrorlist
# When:       2022-06-01 15:19:25 UTC
# From:       https://archlinux.org/mirrors/status/json/
# Retrieved:  2022-06-01 15:19:19 UTC
# Last Check: 2022-06-01 14:01:14 UTC

Server = https://archlinux.thaller.ws/$repo/os/$arch
Server = https://mirror.ubrco.de/archlinux/$repo/os/$arch
Server = https://geo.mirror.pkgbuild.com/$repo/os/$arch
Server = https://archlinux.mailtunnel.eu/$repo/os/$arch
Server = https://mirror.telepoint.bg/archlinux/$repo/os/$arch

:: Synchronizing package databases...
core                                  155.5 KiB  1296 KiB/s 00:00 [------------------------------------] 100%
extra                                1731.6 KiB  3.08 MiB/s 00:01 [------------------------------------] 100%
community                               6.6 MiB  6.68 MiB/s 00:01 [------------------------------------] 100%
multilib                              172.6 KiB  1182 KiB/s 00:00 [------------------------------------] 100%
chaotic-aur                          1887.4 KiB  1444 KiB/s 00:01 [------------------------------------] 100%
spawn pacman -Su sweet-theme-full-git --ignore sweet-kde-git,sweet-cursor-theme-git,kvantum-theme-sweet-git,sweet-gtk-theme-dark,plasma5-theme-sweet-git
:: Starting full system upgrade...
warning: kvantum-theme-sweet-git: ignoring package upgrade (r253.243f018-1 => r269.6e058fc-1)
:: Replace lib32-sdl with multilib/lib32-sdl12-compat? [Y/n] y
:: Replace qemu with extra/qemu-desktop? [Y/n] y
:: Replace qemu-arch-extra with extra/qemu-emulators-full? [Y/n] y
:: Replace sdl with community/sdl12-compat? [Y/n] y
warning: sweet-cursor-theme-git: ignoring package upgrade (r253.243f018-1 => r269.6e058fc-1)
warning: sweet-kde-git: ignoring package upgrade (r253.243f018-1 => r269.6e058fc-1)
resolving dependencies...
looking for conflicting packages...
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: kvantum and kvantum-qt5-git are in conflict

I tried to uninstalling either to solve this issue, but neither pacman, yay nor paru are able to find kvantum (error: target not found: kvantum) and kvantum-qt5-git is a dependency of kvantum-theme-sweet-git which intern is a dependency of garuda-dr460nized.

I tried to find solutions online and in this forum and the commonly suggested solutions in this case do either not work or are not applicable here. I'm simply out of my depth on how to solve this.

Thanks in advanced for your help

Welcome to the Forums! :slight_smile:

For better information we would need you to post the output of garuda-inxi.

3 Likes
Depends On      : beautyline  garuda-icons  garuda-fish-config  garuda-wallpapers  ksysguard  kvantum-qt5  nerd-fonts-fira-code
plasma5-applets-eventcalendar  plasma5-applets-netspeed  plasma5-applets-window-appmenu  plasma5-applets-window-buttons
plasma5-applets-window-title  sweet-theme-full-git  ttf-fira-sans

Try installing kvantum-qt5 before doing garuda-update. Inxi would indeed by helpful here to determine system age.

5 Likes

Precisely my point. :slight_smile:

2 Likes

Yes, thank you that indeed fixed it. I'll remember to post the inxl next time. Thank you very much ^^

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.