Konsole echoed root password


First time user of Garuda, although I've been on/off the linux scene for over a decade now. I was wondering if I might have come across a bug in Konsole and wanted to know your thoughts as to whether I should log a bug with Konsole/Garuda.

I just set up a new system, and although I managed to correctly input the root password one time, I was unable to reproduce it during the post installation wizard in konsole. I tried three times, and it did not work, so I opened a new konsole instance and ran

sudo passwd root

to try out possible typo variations on my password. I ran out of my three attempts, and when I pushed the up arrow and ran the command again, it ran:

sudo passwd root"thisisnotmypassword"

I felt this was very unusual behavour. A fish notification also appeared saying

Failed (1) after 5m 2s
~/ sudo passwd root"thisisnotmypassword"

(Edit: Now I realise it's probably because I exited it by pressing enter three times, and since rootpluspassword is not a user, it failed.)

I haven't been able to reproduce this behaviour after it happened the first time. Do you think this is worth pursuing?

I'm going to do a clean install soon because I was unable to guess my root password typo, so if you do think this is worth reporting, please let me know what I should retrieve from the system e.g. systemlogs to shed further light on this issue.

I have linked my results for inxi -Fxxxza to this post in a pastebin.

Edit: I am running:

  • Konsole v21.04.3
  • KDE Frameworks 5.84.0
  • Qt 5.15.2 (built against 5.15.20)
  • ISO: garuda-dr460nized-linux-zen-210720.iso

Did you explicitly set a root password during installation?

Normal settings in calamares is the user password = root password.


Yes I did.

1 Like

Thank you very much for your welcome (: Glad to be here. Garuda looks great!

Garuda uses this educative(?) funny directive. :rofl:
man sudoers

If set, sudo will insult users when they enter an incorrect password. This flag is off by default.


Eastereggs helps keeping it interesting and provide some funny moments :wink: had to enable :stuck_out_tongue_winking_eye:


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.