Konsole could not be run by the Operating System

Launching Konsole produces the following error

exec: Failed to execute process: '/usr/bin/konsole' the file could not be run by the operating system.

System:
  Kernel: 6.1.1-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=59a5503e-fcee-4e1c-8787-e3f6172b5eaa rw [email protected]
    quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    systemd.unified_cgroup_hierarchy=1 loglevel=3 ibt=off
  Desktop: KDE Plasma v: 5.26.5 tk: Qt v: 5.15.8 info: latte-dock
    wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: LENOVO product: 80XH v: Lenovo ideapad 320-15ISK
    serial: <superuser required> Chassis: type: 10 v: Lenovo ideapad 320-15ISK
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: NO DPK serial: <superuser required>
    UEFI-[Legacy]: LENOVO v: 4WCN37WW date: 12/04/2017
Battery:
  ID-1: BAT0 charge: 7.0 Wh (43.5%) condition: 16.1/30.0 Wh (53.6%) volts: 7.8
    min: 7.4 model: LGC L16L2PB2 type: Li-poly serial: <filter> status: charging
CPU:
  Info: model: Intel Core i3-6006U bits: 64 type: MT MCP arch: Skylake
    gen: core 6 level: v3 note: check built: 2015 process: Intel 14nm family: 6
    model-id: 0x4E (78) stepping: 3 microcode: 0xF0
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 2000 min/max: 400/2000 scaling: driver: intel_pstate
    governor: powersave cores: 1: 2000 2: 2000 3: 2000 4: 2000 bogomips: 15999
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
  Vulnerabilities: <filter>
Graphics:
  Device-1: Intel HD Graphics 520 vendor: Lenovo driver: i915 v: kernel
    arch: Gen-9 process: Intel 14n built: 2015-16 ports: active: eDP-1
    empty: HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:1921 class-ID: 0300
  Device-2: Syntek EasyCamera type: USB driver: uvcvideo bus-ID: 1-8:4
    chip-ID: 174f:241a class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.6 with: Xwayland v: 22.1.7
    compositor: kwin_x11 driver: X: loaded: intel unloaded: modesetting
    alternate: fbdev,vesa dri: i965 gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 506x285mm (19.92x11.22")
    s-diag: 581mm (22.86")
  Monitor-1: eDP-1 mapped: eDP1 model: BOE Display 0x0729 built: 2017
    res: 1920x1080 hz: 60 dpi: 143 gamma: 1.2 size: 340x190mm (13.39x7.48")
    diag: 394mm (15.5") ratio: 16:9 modes: 1920x1080
  API: OpenGL v: 4.6 Mesa 22.3.2 renderer: Mesa Intel HD Graphics 520 (SKL
    GT2) direct render: Yes
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_soc_avs
    bus-ID: 00:1f.3 chip-ID: 8086:9d70 class-ID: 0403
  Sound API: ALSA v: k6.1.1-zen1-1-zen running: yes
  Sound Interface: sndio v: N/A running: no
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.63 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Lenovo driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    port: 3000 bus-ID: 01:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp1s0 state: down mac: <filter>
  Device-2: Intel Dual Band Wireless-AC 3165 Plus Bluetooth driver: iwlwifi
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 02:00.0
    chip-ID: 8086:3166 class-ID: 0280
  IF: wlp2s0 state: up mac: <filter>
  IF-ID-1: docker0 state: down mac: <filter>
Bluetooth:
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
    bus-ID: 1-7:3 chip-ID: 8087:0a2a class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 7 state: down
    bt-service: enabled,running rfk-block: hardware: no software: yes
    address: <filter>
Drives:
  Local Storage: total: 931.51 GiB used: 566.26 GiB (60.8%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
    model: WD10SPZX-24Z10T0 size: 931.51 GiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter>
    rev: 1A01 scheme: MBR
Partition:
  ID-1: / raw-size: 589.23 GiB size: 589.23 GiB (100.00%)
    used: 566.26 GiB (96.1%) fs: btrfs dev: /dev/sda4 maj-min: 8:4
  ID-2: /home raw-size: 589.23 GiB size: 589.23 GiB (100.00%)
    used: 566.26 GiB (96.1%) fs: btrfs dev: /dev/sda4 maj-min: 8:4
  ID-3: /var/log raw-size: 589.23 GiB size: 589.23 GiB (100.00%)
    used: 566.26 GiB (96.1%) fs: btrfs dev: /dev/sda4 maj-min: 8:4
  ID-4: /var/tmp raw-size: 589.23 GiB size: 589.23 GiB (100.00%)
    used: 566.26 GiB (96.1%) fs: btrfs dev: /dev/sda4 maj-min: 8:4
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 11.47 GiB used: 1.81 GiB (15.8%)
    priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 46.0 C pch: 47.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 270 Uptime: 4d 16h 17m wakeups: 25098 Memory: 11.47 GiB
  used: 3.96 GiB (34.6%) Init: systemd v: 252 default: graphical
  tool: systemctl Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: pm: pacman
  pkgs: 2260 libs: 543 tools: pamac,paru Shell: fish v: 3.5.1
  running-in: termius-app inxi: 3.3.24
Garuda (2.6.14-1):
  System install date:     2021-05-31
  Last full system update: 2023-01-07 ↻
  Is partially upgraded:   No
  Relevant software:       timeshift NetworkManager mkinitcpio
  Windows dual boot:       Yes/Detected
  Failed units:            [email protected] systemd-vconsole-setup.service

It's working over here. What is the output of pacman -Sii konsole ?

1 Like

The output of pacman -Sii konsole is as follows

Repository      : extra
Name            : konsole
Version         : 22.12.1-1
Description     : KDE terminal emulator
Architecture    : x86_64
URL             : https://apps.kde.org/konsole/
Licenses        : GPL  LGPL  FDL
Groups          : kde-applications  kde-utilities
Provides        : None
Depends On      : knotifyconfig  kpty  kparts  knewstuff
Optional Deps   : keditbookmarks: to manage bookmarks
Required By     : kde-utilities-meta  yakuake
Optional For    : dolphin  dolphin-git  garuda-assistant-git  garuda-libs  kate  kdevelop  kile  konsole-dracula-git  krusader
Conflicts With  : None
Replaces        : None
Download Size   : 1798.90 KiB
Installed Size  : 7709.44 KiB
Packager        : Antonio Rojas <[email protected]>
Build Date      : Tuesday 03 January 2023 06:09:54 PM
MD5 Sum         : d9d269db940537e916ba5725cbb7a599
SHA-256 Sum     : c5c4fc6de6a1458d1a37c11ad8dbc15a4b20c6e07a5a8a5110a0023f843ab0a4
Signatures      : 7A4E76095D8A52E4

So we are in fact using the same version. Did you already try launching konsole via another terminal, eg. Alacritty?
Also, try reinstalling the package konsole.

2 Likes

Yes, I have tried launching it via Termius, Yakuake and Alacritty.
As you have requested, I reinstalling it using the command garuda-update konsole

Reinstalling the package worked, Thanks :star_struck:

1 Like

Glad to hear! The executable must've been messed up somehow as restoring the original state helped :eyes:

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.