KGpg won't run

I will start with this…


 ╭─fenris@fenris in ~ took 14ms
 ╰─λ sudo garuda-inxi
[sudo] password for fenris:         
System:
  Kernel: 6.7.0-zen3-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=8adfdab2-f46f-4dc9-bec4-6c286c843cff rw rootflags=subvol=@
    quiet resume=UUID=a72d297c-8ad5-4e2f-9483-375f636e64b4 loglevel=3 ibt=off
  Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 info: xfce4-panel wm: xfwm
    v: 4.18.0 dm: LightDM v: 1.32.0 Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop System: AZW product: MINI S v: N/A serial: <filter>
  Mobo: AZW model: MINI S v: 10 serial: N/A UEFI: American Megatrends LLC.
    v: ADLNV104 date: 02/06/2023
Battery:
  Device-1: hidpp_battery_0 model: Logitech M705 serial: <filter> charge: 90%
    rechargeable: yes status: discharging
CPU:
  Info: model: Intel N100 socket: U3E1 bits: 64 type: MCP arch: Alder Lake
    level: v3 note: check built: 2021+ process: Intel 7 (10nm ESF) family: 6
    model-id: 0xBE (190) stepping: 0 microcode: 0x12
  Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 384 KiB
    desc: d-4x32 KiB; i-4x64 KiB L2: 2 MiB desc: 1x2 MiB L3: 6 MiB desc: 1x6 MiB
  Speed (MHz): avg: 700 min/max: 700/3400 base/boost: 2871/3400 scaling:
    driver: intel_pstate governor: powersave volts: 1.0 V ext-clock: 100 MHz
    cores: 1: 700 2: 700 3: 700 4: 700 bogomips: 6451
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
Graphics:
  Device-1: Intel Alder Lake-N [UHD Graphics] driver: i915 v: kernel
    arch: Gen-12.2 process: Intel 10nm built: 2021-22+ ports:
    active: HDMI-A-1,HDMI-A-2 empty: none bus-ID: 00:02.0 chip-ID: 8086:46d1
    class-ID: 0300
  Device-2: Creative Live! Cam Sync 1080p V2 driver: snd-usb-audio,uvcvideo
    type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-3.4:9
    chip-ID: 041e:40a0 class-ID: 0102 serial: <filter>
  Display: x11 server: X.Org v: 21.1.11 compositor: xfwm v: 4.18.0 driver:
    X: loaded: modesetting alternate: fbdev,intel,vesa dri: iris gpu: i915
    display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 3280x1080 s-dpi: 96 s-size: 867x285mm (34.13x11.22")
    s-diag: 913mm (35.93")
  Monitor-1: HDMI-A-1 mapped: HDMI-1 pos: bottom-l model: HKC TV
    serial: <filter> built: 2015 res: 1360x768 hz: 60 dpi: 45 gamma: 1.2
    size: 760x450mm (29.92x17.72") diag: 806mm (31.7") ratio: 16:9, 15:9
    modes: max: 1360x768 min: 720x400
  Monitor-2: HDMI-A-2 mapped: HDMI-2 pos: primary,top-right model: HP LA2206
    serial: <filter> built: 2011 res: 1920x1080 hz: 60 dpi: 102 gamma: 1.2
    size: 477x268mm (18.78x10.55") diag: 547mm (21.5") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  API: Vulkan v: 1.3.274 layers: 5 device: 0 type: integrated-gpu
    name: Intel Graphics (ADL-N) driver: mesa intel v: 23.3.3-arch1.1
    device-ID: 8086:46d1 surfaces: xcb,xlib device: 1 type: cpu name: llvmpipe
    (LLVM 16.0.6 256 bits) driver: mesa llvmpipe v: 23.3.3-arch1.1 (LLVM
    16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
  API: OpenGL Message: Unable to show GL data. glxinfo is missing.
Audio:
  Device-1: Intel driver: snd_hda_intel v: kernel
    alternate: snd_sof_pci_intel_tgl bus-ID: 00:1f.3 chip-ID: 8086:54c8
    class-ID: 0403
  Device-2: C-Media CM106 Like Sound Device
    driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 1.1 speed: 12 Mb/s
    lanes: 1 mode: 1.1 bus-ID: 1-3.2:4 chip-ID: 0d8c:0102 class-ID: 0300
  Device-3: JMTek LLC. LCS USB Audio
    driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 1.1 speed: 12 Mb/s
    lanes: 1 mode: 1.1 bus-ID: 1-3.3:7 chip-ID: 0c76:2018 class-ID: 0300
    serial: <filter>
  Device-4: Creative Live! Cam Sync 1080p V2 driver: snd-usb-audio,uvcvideo
    type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-3.4:9
    chip-ID: 041e:40a0 class-ID: 0102 serial: <filter>
  API: ALSA v: k6.7.0-zen3-1-zen status: kernel-api tools: N/A
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: PipeWire v: 1.0.1 status: n/a (root, process) with:
    1: pipewire-pulse status: active 2: wireplumber status: active
    3: pipewire-alsa type: plugin 4: pw-jack type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
Network:
  Device-1: Intel CNVi: Wi-Fi driver: iwlwifi v: kernel bus-ID: 00:14.3
    chip-ID: 8086:54f0 class-ID: 0280
  IF: wlo1 state: down mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 3000
    bus-ID: 01:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp1s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-3: ASIX AX88179 Gigabit Ethernet driver: ax88179_178a type: USB
    rev: 3.0 speed: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 bus-ID: 2-3.1:6
    chip-ID: 0b95:1790 class-ID: ff00 serial: <filter>
  IF: enp0s20f0u3u1 state: down mac: <filter>
  IF-ID-1: vmnet1 state: unknown speed: N/A duplex: N/A mac: <filter>
  IF-ID-2: vmnet8 state: unknown speed: N/A duplex: N/A mac: <filter>
Bluetooth:
  Device-1: Intel AX201 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-10:5 chip-ID: 8087:0026
    class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: <filter> bt-v: 5.2 lmp-v: 11
    status: discoverable: no pairing: no
Drives:
  Local Storage: total: 4.1 TiB used: 100.86 GiB (2.4%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 model: PCIe SSD size: 476.94 GiB
    block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4
    tech: SSD serial: <filter> fw-rev: EHFM90.1 temp: 39.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000LM015-2E8174
    size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    tech: HDD rpm: 5400 serial: <filter> fw-rev: 0001 scheme: GPT
  ID-3: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST1000LM048-2E7172
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B type: USB
    rev: 3.2 spd: 10 Gb/s lanes: 1 mode: 3.2 gen-2x1 tech: HDD rpm: 5400
    serial: <filter> fw-rev: 0202 scheme: MBR
  ID-4: /dev/sdc maj-min: 8:32 vendor: Corsair model: Survivor 3.0
    size: 922.46 GiB block-size: physical: 512 B logical: 512 B type: USB
    rev: 3.2 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 tech: N/A serial: <filter>
    fw-rev: 000A scheme: MBR
Partition:
  ID-1: / raw-size: 500 GiB size: 500 GiB (100.00%) used: 13.38 GiB (2.7%)
    fs: btrfs block-size: 4096 B dev: /dev/sda3 maj-min: 8:3
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
    used: 588 KiB (0.1%) fs: vfat block-size: 512 B dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 1.06 TiB size: 1.06 TiB (100.00%)
    used: 87.48 GiB (8.1%) fs: btrfs block-size: 4096 B dev: /dev/sda4
    maj-min: 8:4
  ID-4: /var/log raw-size: 500 GiB size: 500 GiB (100.00%)
    used: 13.38 GiB (2.7%) fs: btrfs block-size: 4096 B dev: /dev/sda3
    maj-min: 8:3
  ID-5: /var/tmp raw-size: 500 GiB size: 500 GiB (100.00%)
    used: 13.38 GiB (2.7%) fs: btrfs block-size: 4096 B dev: /dev/sda3
    maj-min: 8:3
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 15.4 GiB used: 6.55 GiB (42.5%)
    priority: 100 comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 4
    dev: /dev/zram0
  ID-2: swap-2 type: partition size: 24 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/sda2 maj-min: 8:2
Sensors:
  System Temperatures: cpu: 60.0 C mobo: N/A
  Fan Speeds (rpm): N/A
Info:
  Processes: 301 Uptime: 4h 56m wakeups: 0 Memory: total: 16 GiB
  available: 15.4 GiB used: 10.06 GiB (65.3%) igpu: 60 MiB Init: systemd
  v: 255 default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
  pm: pacman pkgs: 1521 libs: 421 tools: pamac,paru,yay
  Shell: garuda-inxi (sudo) default: Bash v: 5.2.21 running-in: xfce4-terminal
  inxi: 3.3.31
Garuda (2.6.22-1):
  System install date:     2024-01-12
  Last full system update: 2024-01-18 ↻
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       Yes
  Failed units:            vmware-workstation-server.service vmware.service 

 ╭─fenris@fenris in ~ as 🧙 took 11s
 ╰─λ 

So I installed KGpg on my system last week, and I did it by doing sudo pacman -S kgpg with no issue. It worked once to get my keys installed. Now for some reason when run it, it just wont load up. Don’t know why, can’t figure it out, but this is what I get…

 ╭─fenris@fenris in ~ as 🧙 took 11s
 ╰─λ kgpg

 ╭─fenris@fenris in ~ took 163ms
 ╰─λ sudo kgpg
[sudo] password for fenris:         
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
kf.dbusaddons: DBus session bus not found. To circumvent this problem try the following command (with bash):
    export $(dbus-launch)

 ╭─fenris@fenris in ~ as 🧙 took 3s
[🔴] × 

Is it because this program maybe designed to run in KDE rather then XFCE?

Restart, fix vmware, post in unsupported software.

1 Like

The vmware issue isn’t something that can be fixed, that was talked about in another post

So I have just chosen to ignore this particular issue with vmware since its functional to the point where I need it

It might be related to the recent Arch dbus change.
Anyway, have you tried the suggestion?

1 Like

What suggestion?

  • Restart? Yes, about 12 times since I installed it
  • Fix vmware? Yes, you can see the post where I did the work
  • Post in unsupported software? Well, I guess I could try that, but I haven’t fixed the issue :man_shrugging:

The text in the error message.

1 Like
 ╭─fenris@fenris in ~ as 🧙 took 3s
[🔴] × export $(dbus-launch)

 ╭─fenris@fenris in ~ as 🧙 took 17ms
 ╰─λ 

Not a whole lot seems to happen

Then I think you should launch the application again.
But just in case execute all this entering into bash, as per that message.

1 Like

You know what’s weird? It works when I type kgpg in the command window but the shortcut under the menu/accessories won’t launch it for some reason

This is probably a side effect of the dbus change, if this worked at first. The dbus change arrived after.
For the moment you should replace the shortcut with a script with the commands above.
Or you could try a one liner, maybe in fish as well.
I’m not a fish expert but it could be something like

eval (dbus-launch) kgpg

I just wanted to test that command in the terminal before I edited anything…

 ╭─fenris@fenris in ~ as 🧙 took 17ms
 ╰─λ kgpg
QSystemTrayIcon::setVisible: No Icon set

 ╭─fenris@fenris in ~ took 5m22s
 ╰─λ eval (dbus-launch) kgpg
bash: syntax error near unexpected token `dbus-launch'

 ╭─fenris@fenris in ~ took 39ms
[🔴] × 

It won’t launch using the eval command. Also running kgpg from terminal keeps the terminal open as well.

Well I was considering that command but in a fish shell.
Maybe you were still in bash?
Try in a new terminal?
If it doesn’t work, try with a bash script, or do it manually.
At least as a workaround…

1 Like

I’m not to knowledgeable with this so here’s is my attempt…

#!/bin/bash
#Launching KGpg
eval (dbus-launch) kgpg

I saved this under ~/Documents/kgpg.sh then ran this in the terminal


 ╭─fenris@fenris in ~/Documents took 59ms
 ╰─λ bash kgpg.sh
kgpg.sh: line 3: syntax error near unexpected token `dbus-launch'
kgpg.sh: line 3: `eval (dbus-launch) kgpg'

 ╭─fenris@fenris in ~/Documents took 12ms
[🔴] × 

No

This is fish syntax. In bash I think

#!/bin/bash

export $(dbus-launch)
kgpg

Make it executable with e.g.

chmod +x launch_kgpg.sh

And launch it with e.g.

./launch_kgpg.sh
1 Like

Well this works, it just keeps the terminal window open when you run it. Again it won’t cooperate as a menu shortcut however

You need to update the desktop file if you want to start it from a launcher with your custom command. Copy the desktop file out of /usr/share/applications/ and paste it into ~/.local/share/applications/, then edit the Exec= line to use your custom command.

...
Exec=export $(dbus-launch) && sudo kgpg
...

Refresh the desktop entries (you may need to log out and log back in), then you should be able to start the application from your launcher.

1 Like

I get an error message that says…
Failed to execute command “Exec=export $(dbus-launch) && sudo kgpg”.
Failed to execute child process “export” (No such file or directory)

Ah…makes sense I guess, since export is not really a standalone executable (it’s specific to Bash, kind of built in to the shell).

In that case, just use the script you made on the Exec= line.

...
Exec=/path/to/launch_kgpg.sh
...

Be sure to use the full path.

1 Like

Well that worked!

Thank you

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.