Kernel wont load after system update

So after a system update which probably went wrong, grub wont load the kernel anymore, i tried chrooting and reinstalling it, it went through and now is in /boot/ but still wont load..
My question is, is there any way i could load the kernel manually or fix this?
Thanks for any help.

Can you restore the latest working snapshot?


Im trying to, but i cant find where theyre stored, since im using snapper and the snapshots are read only, i cant boot them, so i fixed that before with changing them to RW, but i forgot where theyre located, also yes, snapshots load with the kernel, both the [kernel] and [kernel].img are in the boot folder

edit: i might know how to fix the snapshots not booting so im on that rn also i tried restoring a snapshot with a live usb, that didnt work, sorry for my frantic typing but i have school tmr so in trying to fix this asap

edit2: shouldnt i be able to copy the kernel from the snapshot? also im in the snapshot before the system upgrade right now

edit3: the snapshot still says theres a partial upgrade, but ive managed to recover it and have now booted back, still thanks for the response, rn im running a full system update with the garuda assistant

btrfs-assistant by @dalto
I think no need to change the ro part.
I cant help, I use timeshift :wink:

i havent heard of btrfs-assistant, im going to look it up, right now while doing a system update i got only one error with
Deprecated feature: REMAKE_INITRD when DKMS was doing dkms install --no-depmod v4l2loopback/0.12.5 -k 5.15.7-zen1-1-zen
error: python-py3nvml: signature from "Nico Jensch (Chaotic-AUR) <[email protected]>" is invalid :: File /var/cache/pacman/pkg/python-py3nvml-0.2.7-1-any.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)). Do you want to delete it? [Y/n] error: kazam: signature from "Nico Jensch (Chaotic-AUR) <[email protected]>" is invalid :: File /var/cache/pacman/pkg/kazam-1.4.5-9-any.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)). Do you want to delete it? [Y/n] error: libcomps: signature from "Nico Jensch (Chaotic-AUR) <[email protected]>" is invalid :: File /var/cache/pacman/pkg/libcomps-0.1.18-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)). Do you want to delete it? [Y/n] error: librepo: signature from "Nico Jensch (Chaotic-AUR) <[email protected]>" is invalid :: File /var/cache/pacman/pkg/librepo-1.14.2-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)). Do you want to delete it? [Y/n] error: libsolv: signature from "Nico Jensch (Chaotic-AUR) <[email protected]>" is invalid :: File /var/cache/pacman/pkg/libsolv-0.7.20-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)). Do you want to delete it? [Y/n] error: failed to commit transaction (invalid or corrupted package (PGP signature)) Errors occurred, no packages were upgraded. Press enter to exit
at the end, i dont think the end is much of a problem, but it still bothers me, do you know why the signatures are invalid?

so, even after a full system update, i still get the "partial update" message, i know this happened after i installed pa_volume-git which is for pulse audio, without realizing garuda has pipewire, it fell out of my head at that moment, im not sure if it installed pulseaudio drivers, probably not since it looks like im still on pipewire, but i know that pa_volume-git installed a ton of packages, but i restored to a snapshot before i did yay -S pa_volume-git so i dont know what the problem is, another thing to note is that the "partial update" message appeared after doing yay -S pa_volume-git, and stuff like ``virt-manager and obs doesnt start.

edit: virt-manager starts, but obs doesnt since it cant find but thats for another forum post, im still kind of bothered about the "partial update" message, i dont know why it would be there..

edit2: also i forgot to mention, i uninstalled pa_volume-git with yay -R pa_volume-git after realizing its for pulse audio, installing it in the first place was very dumb of me.

another edit: i managed to get obs working after i realized there was a python update like 3 days ago, and obs-studio-git still wanted python3.9 while i was on python3.10.1 so installing obs-studio and removing obs-studio-git fixed it.

I have no real idea what your specific issue is, but I thought I'd clarify something for you. When you install a program that creates configuration files stored in the users home directory they may not be removed if you then uninstall the program.

When you restore from a snapshot, the users home directory is not by default going to be restored to its prior state. Therefore, after a restore operation conflicting config files could be still present in your home directory that could cause problems.

Also if you just did your update and aren't aware a recent Python update could be causing some of your issues. You may need to rebuild any programs that use Python. Search the forum for information on this issue.

Also, perhaps you may want to create a new user account to see if it resolves some of your issues.

Good luck.


Yes, im aware that snapshots dont recover the /home/user directory, but i typed all stuff out frantically, this has been the worst hour of my life, creating a new user account is a good idea, but i think its easier for me to go out on a limb and just stay on this one to see if i manage to fix it, tomorrow im going to write out what i did and how i managed to boot in more detail, since i really did write this as idiotically as i updated my system lmao.
Rest assured, have a nice day/night.

edit: WOO! i managed to fix it, what i did was find / -name pa_volume and it found a file of it in ~/.cache/yay so i removed the whole folder and it fixed the "partial update" message, garuda really didnt like something about that package since i had other packages there as well, and only this one was a problem.. im still going to write the step-by-step tomorrow if i find the time

1 Like

Ya, I kind of figured you had some leftover config file in your home directory that was creating issues.

Glad you found it. :+1:


Please mark @tbg's post as the Solution. It's a checkbox in the little sideways three-dot "hamburger menu" below his post above. This helps search engines/other users find similar solutions.


I think @jurosic_park had more than than simply that one leftover conf file creating issues, but every single piece to the puzzle helps get the entire picture sorted out. :wink:


Did you install another kernel preferably linux lts and tried to boot from it after reinstalling grub(just to check for bad grub)?

Ef, its been solved mb

I've had a couple times where I didn't restart after certain pacman updates or perhaps accidentally Ctrl + C in terminal while dkms is running on my Nvidia driver... Simply booting into a snapshot from Grub and restoring has worked for me.

@c00ter The actual issue was with the kernel, the stuff @tbg said was only some side problems, still @tbg thank you very much, configs didnt come to mind, and if its possible to mark two things as a solution im going to mark @filo 's reply, and what im going to write.

1 Like

Glad you sorted it out.
It would be interesting to understand though why the restore didn't work in the first place (if I understand correctly), since when you select a snapshot from the gurb, restore it from the Snapper GUI and reboot, it should work.
To be honest, I switched from Timeshift to Snapper but never had to restore since that.

1 Like

Read only snapshots are really hard to boot, in my case, the kernel will load but the screen will stay black, and the restore didnt work with snapper gui from live boot, instead what i did was i mounted sda2 on /mnt/ in the live enviroment and went to @/.snapshots/x/ and changed the properties of the snapshot to rw

1 Like

Use garuda-assistent and

1 Like

Yes already did that, thanks for the info tho!

Anyways, to any poor soul who finds themselves in this mind numbing situation, the way i booted back and fixed this, was by: (keep in mind there might be a better way to do this, this is just the way i did it)

First i tried to boot into a snapshot in GRUB, use the snapshot which you last remember working, and note its number, if you manage to boot, just restore it, otherwise continue below.

First i booted into i live Garuda Linux USB and opened up the terminal, in the terminal i issued:
mkdir /mnt/restore after which i issued sudo mount /def/sd[x] /mnt/restore (where [x] without the parentheses stands for the partition number, mine was sda2, yours might be different, just use lsblk to find the biggest drive and, mount that)

After mounting the partition changed dir to /mnt/restore with cd /mnt/restore.
After changing your dir and listing everything with ls, you should see a bunch of directories with the prefix @.

First check if the kernel is present, issue command ls @/boot/ if you see files that have a name vmlinuz-linux-zen then the kernel is there. It it isn't there do the steps below, also do it if you aren't sure that the kernel isn't corrupted.

If you want to be sure then you can unmount /mnt/restore with sudo umount /mnt/restore and open up Garuda Assistant, and click chroot, wait until you get into the shell and then issue
sudo pacman -Suy linux this should reinstall the linux kernel. Try to reboot. If you manage ro boot then great! Otherwise continue with the steps blow

Mount your partion back with sudo mount /dev/sd(x) /mnt/restore, and issue cd /mnt/restore/@/.snapshots after which issue btrfs property set -ts [snapshot number]/snapshot ro false after that, reboot.

Now try to boot back into the snapshot, after that, restore. Reboot again, this time normally, and do a full system update with the Garuda Assistant or in the therminal with sudo pacman -Syu.

Good luck! :wink:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.