Kernel not loading

Hello there today I tried booting to garuda linux and it kept saying you need to load kernel first I tried to boot to a snapshot and it said the same thing I have no idea what to do. And google isn’t helping me with this issue.

When you say you tried to boot into Garuda, are you in the grub menu or in your UEFI BIOS menu?

It is a multi-boot machine? If so, have there been any updates or changes to the other OS recently?

What kept saying that? What else does it say? Are you in the "minimal bash-like line editing is supported" menu?

I’m in GURB menu it loads to GURB and everything but when I boot into garuda is just says ‘you need to load kernel first’ and it keeps going to a black screen and saying **[Vmlinuz-linux not found]

What is the output of ls

Please answer all questions put to you by forum assistants. If you do not provide proper feedback to assistants then your thread is unlikely to be solved. As such, pointless help requests that the user does not respond to questions fully usually get binned. In your next reply make sure you answer All prior questions put to you.

1 Like

@Symbol I don't know if you gave up or not, but sometimes with an error like that you can just point out where the kernel is and grub will carry on normally.

ls should show you something like (hd0) (hd0,msdos2) (hd0,msdos1), which is grub's wacky way of listing out the disks and partitions. Continue to use ls on these results (ls hd0,1, etc) until you get a result that contains vimlinuz-[blah blah blah]. That is the disk you want to use.

If you found your kernel on (hd0,1) and you boot from /dev/sda1 (for example only--change for your situation, obviously):

grub> set root=(hd0,1)
grub> linux /boot/vmlinuz-[blah blah blah] root=/dev/sda1

Tab autocomplete should work in this menu, so you might not have to actually type out the whole kernel name.

For this next part, use the same version string you used for vmlinuz- but following initrd.img- this time:

grub> initrd /boot/initrd.img-[blah blah blah]

After that you should just be able to type in boot and hopefully you'll be all set.

If not, you'll really have to be more forthcoming with information about your problem if you want to get help.

2 Likes