[KERNEL BUG] mt7921e - WIfi not working - ASUSTeK Vivobook

"no available connections" in Network Manager

Hey !

I received a new laptop a month ago.
Directly removed windows without even booting it and installed Garuda KDE.
I encountered a problem I've never faced before (already have 2 laptops running garuda) :
After installation / setup / reboot, there were no available connections in the Network Manager.

For a full month, I was able to solve this :

  • reboot
  • wait ~30 seconds before logging into my session.

If I logged in too quickly, the issue would show up again.
Seems like Network Manager's services don't have time to start properly...

But after updating my system 2 days ago, this fix is not working anymore :frowning:
(I do update my system like 2 - 3 times a week)

I've tried several things to fix this :

systemctl enable NetworkManager && systemctl start NetworkManager && reboot
systemctl enable NetworkManager.service && systemctl start NetworkManager.service && reboot
  • Trying to use Garuda Network Assistant :

    • Disable wifi powersave
    • Disable MAC address randomization
    • Restart wifi module
  • Installed rtl8821ce-dkms-git

  • I've uninstalled (formatted my disk) and installed back Garuda like 5 times, but I get the same issue for every attempt.

I've read a lot of things on this forum, but none could fix my issue.
Hope someone can help me :slight_smile:

Hi there, welcome to the community.

First of all, please paste output of garuda-inxi as text here, enclosed with ~~~

1 Like
System:
  Kernel: 5.16.3-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=394702fa-734d-4ffe-be2e-fc60fa05f197 rw [email protected]
    quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    systemd.unified_cgroup_hierarchy=1
    resume=UUID=6e50783f-d483-49d4-ae7f-6d21a4cb652d loglevel=3
  Desktop: KDE Plasma 5.23.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
    vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: ASUSTeK product: Vivobook_ASUSLaptop M3401QA_M3401QA
    v: 1.0 serial: <superuser required>
  Mobo: ASUSTeK model: M3401QA v: 1.0 serial: <superuser required>
    UEFI: American Megatrends LLC. v: M3401QA.303 date: 08/06/2021
Battery:
  ID-1: BAT0 charge: 63.2 Wh (100.0%) condition: 63.2/63.0 Wh (100.3%)
    volts: 12.0 min: 12.0 model: ASUSTeK ASUS Battery type: Li-ion serial: N/A
    status: Not charging cycles: 2
CPU:
  Info: model: AMD Ryzen 7 5800H with Radeon Graphics bits: 64 type: MT MCP
    arch: Zen 3 family: 0x19 (25) model-id: 0x50 (80) stepping: 0
    microcode: 0xA50000C
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
    L3: 16 MiB desc: 1x16 MiB
  Speed (MHz): avg: 1648 high: 3505 min/max: 1200/4462 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1418 2: 1431
    3: 1196 4: 1185 5: 1197 6: 1197 7: 1397 8: 1396 9: 1196 10: 1197 11: 3395
    12: 3505 13: 3067 14: 1197 15: 1197 16: 1197 bogomips: 102208
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
    IBRS_FW, STIBP: always-on, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Cezanne vendor: ASUSTeK driver: amdgpu v: kernel
    bus-ID: 03:00.0 chip-ID: 1002:1638 class-ID: 0300
  Device-2: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo
    bus-ID: 3-3:3 chip-ID: 13d3:5458 class-ID: fe01 serial: <filter>
  Display: x11 server: X.Org 1.21.1.3 compositor: kwin_x11 driver:
    loaded: amdgpu,ati unloaded: modesetting alternate: fbdev,vesa
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1200 s-dpi: 96 s-size: 507x317mm (20.0x12.5")
    s-diag: 598mm (23.5")
  Monitor-1: eDP res: 1920x1200 hz: 90 dpi: 161 size: 302x189mm (11.9x7.4")
    diag: 356mm (14")
  Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
  Device-1: AMD Renoir Radeon High Definition Audio driver: snd_hda_intel
    v: kernel bus-ID: 03:00.1 chip-ID: 1002:1637 class-ID: 0403
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor
    vendor: ASUSTeK driver: N/A
    alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x, snd_pci_acp6x
    bus-ID: 03:00.5 chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel
    v: kernel bus-ID: 03:00.6 chip-ID: 1022:15e3 class-ID: 0403
  Sound Server-1: ALSA v: k5.16.3-zen1-1-zen running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.44 running: yes
Network:
  Device-1: MEDIATEK vendor: AzureWave driver: mt7921e v: kernel port: N/A
    bus-ID: 01:00.0 chip-ID: 14c3:7961 class-ID: 0280
  IF: wlp1s0 state: down mac: <filter>
  IF-ID-1: enp3s0f3u3 state: unknown speed: -1 duplex: half mac: <filter>
Bluetooth:
  Device-1: IMC Networks Wireless_Device type: USB driver: btusb v: 0.8
    bus-ID: 3-2:2 chip-ID: 13d3:3563 class-ID: e001 serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 2 state: up address: <filter>
Drives:
  Local Storage: total: 953.87 GiB used: 28.22 GiB (3.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: SSDPEKNU010TZ
    size: 953.87 GiB block-size: physical: 512 B logical: 512 B
    speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 002C
    temp: 28.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 936.96 GiB size: 936.96 GiB (100.00%)
    used: 28.22 GiB (3.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 936.96 GiB size: 936.96 GiB (100.00%)
    used: 28.22 GiB (3.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 936.96 GiB size: 936.96 GiB (100.00%)
    used: 28.22 GiB (3.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 936.96 GiB size: 936.96 GiB (100.00%)
    used: 28.22 GiB (3.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.1 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  ID-2: swap-2 type: partition size: 16.61 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
Sensors:
  System Temperatures: cpu: 47.0 C mobo: N/A gpu: amdgpu temp: 42.0 C
  Fan Speeds (RPM): cpu: 0
Info:
  Processes: 391 Uptime: 3h 19m wakeups: 426 Memory: 15.1 GiB
  used: 5.27 GiB (34.9%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1556 lib: 339 Shell: Zsh v: 5.8
  running-in: xfce4-terminal inxi: 3.3.12
Garuda:
    System install date:         2022-01-04
    Last full system update: 2022-01-30
    Is partially upgraded:     No
    Using TLP:                        No
    Windows dual boot:       No/Undetected
    Snapshots:                       Snapper

This is your WiFi card, currently affected.
Use mobile tethering and e.g. install e.g. linux-lts until this is fixed.

2 Likes

Basically, downgrading my kernel will let me use my previous fix (reboot + wait 30 sec).
But this won't solve the problem in its entirety…

For a whole month, before this update, I wasn't able to get my Network Manager to work properly without doing my "fix".
THIS is the problem I want to solve :slight_smile:

I should not be forced to wait 30 sec to have my Network Manager to work :man_shrugging:

Well, we understand your issue and assure that it will be fixed soon. As this is upstream issue, we can't really fix it on our own. This issue will only be fixed when hardware manufacturer will push a fix in kernel.
So you have to wait for sometime to get fix.

I hope you understand....
And sorry for inconvenience.

3 Likes

Btw, after you get the wifi back by rolling back using snapper/ downgrading, also give Linux-Mainline a shot (It is precompiled in Chaotic AUR)

It is based on kernel 5.17 rc1 . Certainly Worth a try.

2 Likes

You will usually experience some kind of hardware issue if you want to run Linux on any brand new laptop purchase, (unless you select your hardware extremely carefully).

While Mediatek should be lauded for having open source drivers, their network adapters are a poor choice for Linux IMO. When Mediatek wifi works properly, it is a an attractive choice because they are cheap and their drivers are included in the kernel. Unfortunately, when you encounter a problem with a Mediatek adapter it is very hard to correct it yourself, and fixes may be a long time in coming as they do not have a large team of Linux developers like a large company such as Intel.

Railink/Mediatek Linux wifi drivers are very simplistic and generic in nature. The Linux drivers they release often cover many different wifi chips and they are not individualized to work well with each model. Their drivers are also very simplistic in that they offer very few driver options that the end user can customize themselves. It is the user customizable driver options that allows the flexibility to compensate for issues they may encounter. Mediatek is one of the worst wifi manufacturers for providing these choices to end users.

Mediatek is a cheap alternative, and their price point makes them an attractive choice for laptop manufactures. However, if you intend to run Linux they are a poor choice for consumers IMO. Stick to respected wifi manufacturers such as Intel and Atheros if you intend to run Linux. They still have problems at times, but their drivers allow you to overcome some issues you may encounter because of their advanced driver options.

Steer clear of Broadcom and Mediatek wifi adapter's if you wish to run Linux is my advice.

You could test other alternatives to see if you can improve your connection speeds such as using IWD. You could also try an alternative such as Connman instead of Network Manager.

5 Likes

Took the time to install linux mainline :
-> did not fixed the problem.
still no connection available

It may be impossible to get that WiFi card working correctly until kernel support comes down, which I can certainly understand would be frustrating.

I'm not sure how handy you are with tinkering around with your laptop hardware, but it might be worth investigating if you can replace the WiFi card altogether. It could be impossible (if your card is soldered in, or some proprietary shape that cannot be replaced, et cetera) but if not, you can get a decent Intel WiFi card for twenty or thirty bucks.

Obviously you would have to do a little research to make sure you buy one that is compatible with your laptop.

Another option would be to buy a WiFi dongle, and just use that on the laptop until your card is properly supported by the kernel. It would occupy a USB port on your laptop, but if you have one to spare then you wouldn't have to worry about popping open the back and swapping out the card.

Edit: Here's an article that discusses the topic a little: How to Upgrade Wi-Fi on a Laptop: Speed Up & Fix Problems

1 Like

Possible fix:

https://askubuntu.com/questions/1380400/no-wifi-adapter-found-on-ubuntu-20-04-3-lts

1 Like

Thanks, but did not fix it :slight_smile:

Just in case, Network Manager was working perfectly fine during system installation.
The problem appeared right after the first reboot.

Well that's too bad, but it was worth a shot testing that fix.

If you haven't tested it already, I would install the linux-firmware-git package to see if it improves your connectivity. Reboot after installation.

Did not fix it :sweat_smile:

I really didn't expect it would, but the newest firmware is always worth testing. It kind of looks like you'll just have to wait for the newest kernel updates to work their way down the pipe. Hopefully that won't take too long.

Just posted on a similar issue, go figure?

2 Likes

Found a fix :

Unplug laptop charger > reboot > (don't have to wait 30 sec to login) > Network Manager (and every other services like Bluetooth) starts properly > you can plug charger back.

Can't explain / fix this :thinking:

Problem :

  • "Network Manager Failed to get secrets for [Every Network] "
  • I have to connect to the same network with password every time I reboot.
    Seems like it can't retain the password.

I went in :
Connections - System Settings > my Network > Wi-Fi Security > Password : filled it and applied changes.
After reboot, changes were gone.

EDIT : Deleted my network connection in [Connections - System Settings] and connected back to it. Now works fine - don't need anymore to enter network password after reboot.

Now the only problem is :
Network Manager not working after booting with charger plugged in.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.