[KERNEL BUG] MEDIATEK mt7921e Wifi not working - ASUSTeK ROG Strix

I just had a second look at your output, and I believe your issue is similar to a problem I have encountered once before.

Just wait on the bios reset, I think I know what's causing this, but I need to check my notes.

2 Likes

I loading up the UEFI menu and hit "reset to factory default"
Booted up Garuda, no change.

Did you install the program anbox?

Do you have any anbox kernel versions installed?

I don't know if you need anbox, but that program is likely going to need to be uninstalled to fix your wifi issue.

To uninstall anbox issue this command:

sudo pacman -Rns anbox-support anbox-git

Then reboot.

Then please post:

inxi -naz

After rebooting hopefully your WiFi is active again.

3 Likes

No such luck :frowning:

I don't remember installing anbox but I ran the command and it appeared to remove it.

I rebooted and nothing changed. I tried running the sudo pacman -Rns anbox-support anbox-git command again and this time it said nothing was found. I tried resetting the wifi module with garuda network assistant as well and nothing.

Here's the output from
inxi -naz

Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK driver: r8169 v: kernel port: f000 bus-ID: 04:00.0
chip-ID: 10ec:8168 class-ID: 0200
IF: enp4s0 state: down mac: 7c:10:c9:23:ea:d3
Device-2: MEDIATEK vendor: AzureWave driver: N/A modules: mt7921e
port: N/A bus-ID: 05:00.0 chip-ID: 14c3:7961 class-ID: 0280
Sensors:
System Temperatures: cpu: 53.0 C mobo: N/A
Fan Speeds (RPM): cpu: 2500
GPU: device: amdgpu temp: 50.0 C mem: 46.0 C fan: 61 watts: 16.00
device: amdgpu temp: 46.0 C

Please post:

grep -r "blacklist\|install\|options"  /etc/modprobe.d/ /etc/modules-load.d/ /usr/lib/modprobe.d/ 
1 Like

Yeah no problem.

Here's the output from
grep -r "blacklist\|install\|options" /etc/modprobe.d/ /etc/modules-load.d/ /usr/lib/modprobe.d/



/usr/lib/modprobe.d/amdgpu.conf:options amdgpu ppfeaturemask=0xffffffff
/usr/lib/modprobe.d/systemd.conf:options bonding max_bonds=0
/usr/lib/modprobe.d/systemd.conf:options dummy numdummies=0
/usr/lib/modprobe.d/nvdimm-security.conf:install libnvdimm /usr/bin/ndctl load-keys ; /sbin/modprobe --ignore-install libnvdimm $CMDLINE_OPTS
/usr/lib/modprobe.d/bluetooth-usb.conf:options btusb reset=1
/usr/lib/modprobe.d/nobeep.conf:blacklist pcspkr
/usr/lib/modprobe.d/noime.conf:blacklist mei
/usr/lib/modprobe.d/noime.conf:blacklist mei_me

Try:

sudo systemctl stop NetworkManager; sudo modprobe -r mt7921e; sudo modprobe -vr mt7921e; sudo systemctl start NetworkManager
1 Like

I assume it worked there was no output. It said "took 4 seconds"

Tried rebooting, no change.

You should have run the new garuda-inxi command given in our help request template, as that would have told me if tlp was installed on your system.

is tlpinstalled on your system?


Try starting your laptop with the power unplugged.


1 Like

Oh sorry I'm dumb. When I read that in the template my brain thought it was an example of how to structure my request.

Here's the output of garuda-inxi


System:
Kernel: 5.16.3-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=49cbabf1-bf20-4cca-b788-29b2923c2d3e rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
pcie_aspm=off
Desktop: KDE Plasma 5.23.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: ASUSTeK product: ROG Strix G513QY_G513QY v: 1.0
serial: <superuser required>
Mobo: ASUSTeK model: G513QY v: 1.0 serial: <superuser required>
UEFI: American Megatrends LLC. v: G513QY.316 date: 11/29/2021
Battery:
ID-1: BAT0 charge: 89.0 Wh (100.0%) condition: 89.0/90.0 Wh (98.9%)
volts: 16.6 min: 15.9 model: AS3GWAF3KC GA50358 type: Li-ion
serial: <filter> status: Discharging
CPU:
Info: model: AMD Ryzen 9 5900HX with Radeon Graphics bits: 64 type: MT MCP
arch: Zen 3 family: 0x19 (25) model-id: 0x50 (80) stepping: 0
microcode: 0xA50000C
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
L3: 16 MiB desc: 1x16 MiB
Speed (MHz): avg: 1396 high: 1397 min/max: 1200/4889 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 1397 2: 1397
3: 1397 4: 1396 5: 1397 6: 1397 7: 1395 8: 1396 9: 1395 10: 1397 11: 1396
12: 1395 13: 1396 14: 1396 15: 1397 16: 1395 bogomips: 105400
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
IBRS_FW, STIBP: always-on, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Navi 22 [Radeon RX 6700/6700 XT / 6800M] vendor: ASUSTeK
driver: amdgpu v: kernel bus-ID: 03:00.0 chip-ID: 1002:73df class-ID: 0380
Device-2: AMD Cezanne vendor: ASUSTeK driver: amdgpu v: kernel
bus-ID: 07:00.0 chip-ID: 1002:1638 class-ID: 0300
Display: x11 server: X.Org 1.21.1.3 compositor: kwin_x11 driver:
loaded: amdgpu,ati unloaded: modesetting,radeon alternate: fbdev,vesa
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
s-diag: 582mm (22.9")
Monitor-1: eDP res: 1920x1080 hz: 300 dpi: 142
size: 344x194mm (13.5x7.6") diag: 395mm (15.5")
OpenGL: renderer: AMD RENOIR (DRM 3.44.0 5.16.3-zen1-1-zen LLVM 13.0.0)
v: 4.6 Mesa 21.3.5 direct render: Yes
Audio:
Device-1: AMD Navi 21 HDMI Audio [Radeon RX 6800/6800 XT / 6900 XT]
vendor: ASUSTeK driver: snd_hda_intel v: kernel bus-ID: 03:00.1
chip-ID: 1002:ab28 class-ID: 0403
Device-2: AMD Renoir Radeon High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel bus-ID: 07:00.1 chip-ID: 1002:1637
class-ID: 0403
Device-3: AMD Raven/Raven2/FireFlight/Renoir Audio Processor
vendor: ASUSTeK driver: N/A
alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x, snd_pci_acp6x
bus-ID: 07:00.5 chip-ID: 1022:15e2 class-ID: 0480
Device-4: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel
v: kernel bus-ID: 07:00.6 chip-ID: 1022:15e3 class-ID: 0403
Sound Server-1: ALSA v: k5.16.3-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.44 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK driver: r8169 v: kernel port: f000 bus-ID: 04:00.0
chip-ID: 10ec:8168 class-ID: 0200
IF: enp4s0 state: down mac: <filter>
Device-2: MEDIATEK vendor: AzureWave driver: N/A modules: mt7921e
port: N/A bus-ID: 05:00.0 chip-ID: 14c3:7961 class-ID: 0280
Bluetooth:
Device-1: IMC Networks Wireless_Device type: USB driver: btusb v: 0.8
bus-ID: 3-4:2 chip-ID: 13d3:3563 class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
Local Storage: total: 596.45 GiB used: 60.48 GiB (10.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
model: MZVLQ512HBLU-00B00 size: 476.94 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: FXM7201Q temp: 31.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 type: USB vendor: Samsung
model: Flash Drive FIT size: 119.51 GiB block-size: physical: 512 B
logical: 512 B type: SSD serial: <filter> rev: 1100 scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
ID-1: / raw-size: 158.19 GiB size: 158.19 GiB (100.00%)
used: 60.46 GiB (38.2%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
used: 25.8 MiB (26.9%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 158.19 GiB size: 158.19 GiB (100.00%)
used: 60.46 GiB (38.2%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
ID-4: /var/log raw-size: 158.19 GiB size: 158.19 GiB (100.00%)
used: 60.46 GiB (38.2%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
ID-5: /var/tmp raw-size: 158.19 GiB size: 158.19 GiB (100.00%)
used: 60.46 GiB (38.2%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.1 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 53.0 C mobo: N/A
Fan Speeds (RPM): cpu: 2400
GPU: device: amdgpu temp: 46.0 C device: amdgpu temp: 50.0 C mem: 44.0 C
fan: 6 watts: 11.00
Info:
Processes: 398 Uptime: 0m wakeups: 4 Memory: 15.1 GiB
used: 2.04 GiB (13.5%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1796 lib: 545 Shell: fish
v: 3.3.1 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.12
Garuda:
System install date:     2022-01-28
Last full system update: 2022-01-28
Is partially upgraded:   No
Using TLP:               No
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper

What was this result?

1 Like

Oh yeah sorry. No change.

My best guess is this is likely a bios, firmware, or kernel issue.


You need to check if a bios update is available for your laptop and install it if there is.


Install linux-firmware-git , reboot.

If not working after rebooting, again run:

sudo systemctl stop NetworkManager; sudo modprobe -r mt7921e; sudo modprobe -vr mt7921e; sudo systemctl start NetworkManager

Then check your wifi for any differences.


If still no improvements, you will need to test some alternate kernels. Start by installing and testing the linux-mainline kernel. If no better luck, then test the linux kernel as well. Also try the linux-xanmod-rog kernel. The last hope might be linux-next-git if those kernels don't help.


I'm not quite sure what further to suggest if none of those suggestions pan out, (so hopefully one will work).

2 Likes

Hey hopefully it works. I'll try it tomorrow and see what happens. Thanks for the help :slight_smile:

1 Like

Usually I watch the Arch Wifi issues carefully, but I missed one from yesterday claiming a kernel update broke your driver. They also claim downgrading the kernel will fix it.

https://bbs.archlinux.org/viewtopic.php?id=273620

5 Likes

Uhhh, how do I downgrade a kernel on Arch? I saw some posts about it online but they all seemed to be for Ubuntu. Reading around it seems 5.16.1 would be the best for me.

I tried putting in sudo pacman -Syu linux-lts linux-lts-headers But that seems to require wifi

Hi, see
https://wiki.archlinux.org/title/Downgrading_packages

You may also want to use snapper to restore snapshot.

Also, after downgrading/restoring snapshot maybe you would like to test Linux-mainline, that is based on 5.17, rc1, and is precompiled in Chaotic AUR. Maybe this bug has been fixed in it, but am not sure.

I forgot to say, I updated my bios on 1/13/22. I double checked it's the latest version.

I'll follow the guide to downgrade the kernel and see what happens.

Yeah I'd be down for 5.17 too! Would love to see if its fixed.

1 Like

Possible fix:

https://askubuntu.com/questions/1380400/no-wifi-adapter-found-on-ubuntu-20-04-3-lts

1 Like