KDE crash on adjusting volume

This doesn't happen everytime, but it's annoying nevertheless whenever it does - Adjusting the volume crashes KDE and gets me back to SDDM login screen.

If specifics are required : I adjust the volume by holding the keyboard media keys or the the macros on my mouse. The media key is actually Fn+ F12 for vol up and Fn+F11 for vol down (yeah it's a mac friendly kind of keyboard) . I have this keyboard connected via bluetooth.

Is this a known issue? Or is it possible to log this crash?

╰─λ inxi -Faz
System:
Kernel: 5.15.11-arch2-g14-1 x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: pm_debug_messages amd_pmc.enable_stb=1 amd_pmc.dyndbg="+p"
acpi.dyndbg="file drivers/acpi/x86/s2idle.c +p"
BOOT_IMAGE=/@/boot/vmlinuz-linux-g14
root=UUID=edc8611c-d94e-4567-85f8-02b07c91fda3 rw [email protected]
quiet
cryptdevice=UUID=98382a7e-5fd2-4dca-b6e6-6aca242b8ece:luks-98382a7e-5fd2-4dca-b6e6-6aca242b8ece
root=/dev/mapper/luks-98382a7e-5fd2-4dca-b6e6-6aca242b8ece splash
rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.23.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: ASUSTeK product: ROG Zephyrus G14 GA401II_GA401II
v: 1.0 serial: <superuser required>
Mobo: ASUSTeK model: GA401II v: 1.0 serial: <superuser required>
UEFI: American Megatrends v: GA401II.219 date: 12/30/2020
Battery:
ID-1: BAT0 charge: 61.0 Wh (82.4%) condition: 74.0/76.0 Wh (97.4%)
volts: 15.8 min: 15.8 model: ASUSTeK ASUS Battery type: Li-ion serial: N/A
status: Not charging
Device-1: hid-dc:2c:26:05:66:0e-battery model: Keychron K2 serial: N/A
charge: N/A status: Discharging
Device-2: hidpp_battery_0
model: Logitech G304 Lightspeed Wireless Gaming Mouse serial: <filter>
charge: 100% (should be ignored) rechargeable: yes status: Discharging
CPU:
Info: model: AMD Ryzen 5 4600HS with Radeon Graphics bits: 64 type: MT MCP
arch: Zen 2 family: 0x17 (23) model-id: 0x60 (96) stepping: 1
microcode: 0x8600104
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 8 MiB desc: 2x4 MiB
Speed (MHz): avg: 2149 high: 3336 min/max: 1400/3000 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 1654 2: 1722
3: 1773 4: 1531 5: 1693 6: 1593 7: 3336 8: 2691 9: 2277 10: 2198 11: 2661
12: 2670 bogomips: 71895
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
IBRS_FW, STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Renoir vendor: ASUSTeK driver: amdgpu v: kernel
bus-ID: 04:00.0 chip-ID: 1002:1636 class-ID: 0300
Display: x11 server: X.Org 1.21.1.2 compositor: kwin_x11 driver:
loaded: amdgpu,ati unloaded: modesetting alternate: fbdev,vesa
display-ID: :0 screens: 1
Screen-1: 0 s-res: 2560x1440 s-dpi: 96 s-size: 677x381mm (26.7x15.0")
s-diag: 777mm (30.6")
Monitor-1: HDMI-A-0 res: 2560x1440 dpi: 109 size: 597x336mm (23.5x13.2")
diag: 685mm (27")
Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
Device-1: AMD driver: snd_hda_intel v: kernel bus-ID: 04:00.1
chip-ID: 1002:1637 class-ID: 0403
Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor
vendor: ASUSTeK driver: N/A
alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x bus-ID: 04:00.5
chip-ID: 1022:15e2 class-ID: 0480
Device-3: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel
v: kernel bus-ID: 04:00.6 chip-ID: 1022:15e3 class-ID: 0403
Sound Server-1: ALSA v: k5.15.11-arch2-g14-1 running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.42 running: yes
Network:
Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus-ID: 02:00.0
chip-ID: 8086:2723 class-ID: 0280
IF: wlp2s0 state: down mac: <filter>
Device-2: Realtek RTL8153 Gigabit Ethernet Adapter type: USB
driver: r8152 bus-ID: 6-2.4:4 chip-ID: 0bda:8153 class-ID: 0000
serial: <filter>
IF: enp4s0f4u2u4 state: up speed: 10 Mbps duplex: full mac: <filter>
Bluetooth:
Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 5-4:4 chip-ID: 8087:0029 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
Local Storage: total: 953.87 GiB used: 157.39 GiB (16.5%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: SSDPEKNW010T8
size: 953.87 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 004C
temp: 28.9 C scheme: GPT
Partition:
ID-1: / raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 157.39 GiB (16.5%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-98382a7e-5fd2-4dca-b6e6-6aca242b8ece
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 720 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 157.39 GiB (16.5%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-98382a7e-5fd2-4dca-b6e6-6aca242b8ece
ID-4: /var/log raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 157.39 GiB (16.5%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-98382a7e-5fd2-4dca-b6e6-6aca242b8ece
ID-5: /var/tmp raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 157.39 GiB (16.5%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-98382a7e-5fd2-4dca-b6e6-6aca242b8ece
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.11 GiB used: 2.8 MiB (0.0%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 43.0 C mobo: N/A gpu: amdgpu temp: 39.0 C
Fan Speeds (RPM): cpu: 2500
Info:
Processes: 382 Uptime: 47m wakeups: 7 Memory: 15.12 GiB
used: 3.4 GiB (22.5%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1466 lib: 360 Shell: fish
v: 3.3.1 default: Zsh v: 5.8 running-in: konsole inxi: 3.3.11

Send a dmesg log when this happens. Probably a kernel problem (this is not the official kernel)

2 Likes

Umm...sorry linux noob here. Not sure how to do what you just suggested.

I have to use this kernel since it comes with custom patches to enable fan curves on my particular laptop. Otherwise the fans barely spin even on high load. Maybe from kernel 5.16 or 5.17 those patches might get merged with other more widely supported kernels like zen.

1 Like

When this problem occurs, simply type the following into the terminal as root or sudo:

dmesg

And write me back with the whole output of this command

I am just logged out and sent to sddm login screen when it happens. Would this count after logging in(brand new session)?

Should be. You can also press ctrl + alt + F3 and log into the tty as root. Since this output might be long, you can do
dmesg > output.txt and then open the file and copy the contents.

4 Likes

@zoeruda @Pheidologeton

Couldn't paste the giant file here. Tried a pastebin. I hope dmesg logs don't contain any sensitive information about my PC and that's why you guys asked for it.

Password : zephg14

What happened : Booted and logged in, tried watching some video I think, increased volume with media keys on BT keyboard and it crashed.
On relogging, I removed the dmesg warning with some command and outputted the dmesg log. That's all the events which occurred.

This is very strange, I don't see any problem in dmesg. Try boot from the official kernel or linux-tkg from chaotic-aur, and try changing the volume on them.

1 Like

Sorry for late reply. It is very strange indeed.

I'll consult the maintainers of the kernel if their utility (asusctl) lets the fan curves work on other kernels, and try to replicate the issue on the zen kernel. I don't like the fans being idle on my laptop that's why I have to use this kernel with custom patches.

Is this a new keyboard for you? I have a bluetooth Keychron as well, and it required a little configuration to get the F-keys and multimedia keys working correctly on Linux.

Here's what I found for setting up the K2:

KEYCHRON LINUX FUNCTION KEYS
On Linux, the Keychron K2 doesn’t register any of the F1-F12 function keys as actual F keys, instead, treating them as multimedia keys by default. Here’s how to fix it!

They keyboard has 2 modes: Windows/Android and MacOS, but neither mode worked properly out of the box.

To fix this:

Set the keyboard to Windows mode via the side switch
Use Fn + X + L (hold for 4 seconds) to set the function key row to “Function” mode. (usually all that’s necessary on Windows)
echo 0 | sudo tee /sys/module/hid_apple/parameters/fnmode
Once complete, my F1-F12 keys work properly, and holding Fn turns them into multimedia keys. You can use the evtest utility to check how keyboard keys are registering until you get the above combination of settings configured properly.

To persist this change, add a module option for hid_apple:

echo "options hid_apple fnmode=0" | sudo tee -a /etc/modprobe.d/hid_apple.conf
You may need to rebuild your initramfs if hid_apple is included.

ubuntu: sudo update-initramfs -u

arch: mkinitcpio -P

I'm not sure if the issue you are experiencing could be caused by the keyboard not being configured correctly, but I figured I would mention it in case it was something that had been missed.

I've already fixed the function key problem on this keyboard. It is registered as an Apple keyboard so yeah pretty much used the same command as you mentioned.

It's not just an issue with keyboard, I have applied the volume adjustment to my mouse buttons and that crashes it too. After 1 crash, it works fine.