KDE and Latte Dock suddenly stops working

inxi -Faz

System:    Kernel: 5.14.3-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0  
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=0adb70a1-e86f-4824-93a4-3e9bf14a89e2  
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 resume=UUID=359b0fa8-ac06-47a2-af12-53aacb3bcc08 loglevel=3
Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM  
Distro: Garuda Linux base: Arch Linux  
Machine:   Type: Desktop Mobo: ASRock model: B450 Gaming-ITX/ac serial: <filter> UEFI: American Megatrends  
v: P3.70 date: 11/18/2019  
CPU:       Info: 6-Core model: AMD Ryzen 5 1600 bits: 64 type: MT MCP arch: Zen+ family: 17 (23)  
model-id: 8 stepping: 2 microcode: 800820D cache: L2: 3 MiB  
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 76643  
Speed: 3511 MHz min/max: 1550/3200 MHz boost: enabled Core speeds (MHz): 1: 3511 2: 2753  
3: 3506 4: 3593 5: 2417 6: 2442 7: 2854 8: 2420 9: 3051 10: 2577 11: 2797 12: 2420  
Vulnerabilities: Type: itlb_multihit status: Not affected  
Type: l1tf status: Not affected  
Type: mds status: Not affected  
Type: meltdown status: Not affected  
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp  
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization  
Type: spectre_v2  
mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling  
Type: srbds status: Not affected  
Type: tsx_async_abort status: Not affected  
Graphics:  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] vendor: Gigabyte  
driver: amdgpu v: kernel bus-ID: 09:00.0 chip-ID: 1002:67df class-ID: 0300  
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: amdgpu,ati  
unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1  
Screen-1: 0 s-res: 1680x1050 s-dpi: 96 s-size: 444x277mm (17.5x10.9") s-diag: 523mm (20.6")  
Monitor-1: DVI-D-0 res: 1680x1050 hz: 60 dpi: 99 size: 433x271mm (17.0x10.7")  
diag: 511mm (20.1")  
OpenGL: renderer: Radeon RX 570 Series (POLARIS10 DRM 3.42.0 5.14.3-zen1-1-zen LLVM 12.0.1)  
v: 4.6 Mesa 21.2.1 direct render: Yes  
Audio:     Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] vendor: Gigabyte  
driver: snd_hda_intel v: kernel bus-ID: 09:00.1 chip-ID: 1002:aaf0 class-ID: 0403  
Device-2: AMD Family 17h HD Audio vendor: ASRock driver: snd_hda_intel v: kernel  
bus-ID: 0b:00.3 chip-ID: 1022:1457 class-ID: 0403  
Sound Server-1: ALSA v: k5.14.3-zen1-1-zen running: yes  
Sound Server-2: JACK v: 1.9.19 running: no  
Sound Server-3: PulseAudio v: 15.0 running: yes  
Sound Server-4: PipeWire v: 0.3.35 running: yes  
Network:   Device-1: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi v: kernel  
bus-ID: 07:00.0 chip-ID: 8086:24fb class-ID: 0280  
IF: wlp7s0 state: up mac: <filter>  
Device-2: Intel I211 Gigabit Network vendor: ASRock driver: igb v: kernel port: f000  
bus-ID: 08:00.0 chip-ID: 8086:1539 class-ID: 0200  
IF: enp8s0 state: down mac: <filter>  
IF-ID-1: anbox0 state: down mac: <filter>  
Bluetooth: Device-1: Intel Wireless-AC 3168 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-6:2  
chip-ID: 8087:0aa7 class-ID: e001  
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>  
Drives:    Local Storage: total: 689.34 GiB used: 77.28 GiB (11.2%)  
SMART Message: Unable to run smartctl. Root privileges required.  
ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST9500325AS size: 465.76 GiB block-size:
physical: 512 B logical: 512 B speed: 3.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: HPM1
scheme: MBR
ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital model: WDS240G2G0B-00EPW0 size: 223.58 GiB
block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 0000
scheme: MBR
Partition: ID-1: / raw-size: 214.84 GiB size: 214.84 GiB (100.00%) used: 77.28 GiB (36.0%) fs: btrfs
dev: /dev/sdb1 maj-min: 8:17
ID-2: /boot/efi raw-size: 940 MiB size: 938.1 MiB (99.80%) used: 576 KiB (0.1%) fs: vfat
dev: /dev/sdb2 maj-min: 8:18
ID-3: /home raw-size: 214.84 GiB size: 214.84 GiB (100.00%) used: 77.28 GiB (36.0%) fs: btrfs
dev: /dev/sdb1 maj-min: 8:17
ID-4: /var/log raw-size: 214.84 GiB size: 214.84 GiB (100.00%) used: 77.28 GiB (36.0%)
fs: btrfs dev: /dev/sdb1 maj-min: 8:17
ID-5: /var/tmp raw-size: 214.84 GiB size: 214.84 GiB (100.00%) used: 77.28 GiB (36.0%)
fs: btrfs dev: /dev/sdb1 maj-min: 8:17
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 7.81 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sdb3
maj-min: 8:19
ID-2: swap-2 type: zram size: 7.69 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 64.8 C mobo: N/A gpu: amdgpu temp: 46.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 768
Info:      Processes: 346 Uptime: 5m wakeups: 0 Memory: 7.69 GiB used: 3.74 GiB (48.7%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1671 lib: 502
Shell: fish v: 3.3.1 default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.06

tarting my pc a few times, my kde suddenly doesnt work correctly anymore, the panel disappears, and latte dock also doesnt work anymore. SDDM cant access a config file and cant continue or something after logging out... I dont know what is happening, i pressed CTRL + ALT + T to open an terminal window and start firefox, (which worked perfectly fine) and im getting this error when starting programs:
firefox/any program:
Icon theme "gnome" not found.
plasmashell:
Icon theme "gnome" not found. and then just quits.
System: Garuda Linux Dr4gonized KDE version.


If you include terminal outputs in your post please use the proper output format in your post.

Using "~" 3 times above and "~" 3 times below the text block will provide a readable, raw look.

Did you search in forum?
IIRC it is solved.

Sorry, cant stem to find anything similair on the forums, am I missing something?

or

Refresh your mirrors.

System is up-to-date?

Yes, my system is up-to-date

Latte dock fixed by killall latte-dock and deleting the lattedockrc file from the .config folder, but the kde panel is still not working

Please, no pictures from the terminal.
Use

LANG=C latte-dock

And

As I Stated, yes, my system is up-to-date, but I don't know how to make a screenshot because kde is broken and last time I unset the shortcut of spectacle. That's why I was showing a picture of the terminal. Also, latte-dock is fixed

Ohhh, its a smartphone pic :slight_smile: ?

Was in the same situation. I decided to restore everything from the snapshot. I did not understand the reason. I follow the topic.

Yeah, smartphone picture. Also, is there a sokution to the kde panel? Im going to bed now. Im going to react tommorow

restore from /etc/skel or with Garuda-Assistent.

4 Likes

Thanks! Turns out, my default shell switched from fish to bash. Opening Garuda Assistant and resetting all configs + going back bash - fish fixed it!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.