Issues with Steam games - Session closes and moves to lock screen

Hello All :slight_smile:

Yesterday i have installed Garuda KDE Dr460nized and Garuda Linux GNOME which had the same issue.

After OS was installed I have download the updates plus installed intel and nvidia graphics cards and at the end, i have installed steam plus the game i play (Left for dead 2), just to test if everything was ok and as soon the game starts session is closed and I get to the lock screen.

This happens too with the Manjaro Kde version (didn't try others).

I do not like to give up and i love challenges, so i decided to install the Garuda LXQT which runs great. Everything works. :slight_smile: lol

Any hint how to solve this on Garuda KDE Dr460nized ?

inxi -Fazy

System:
Kernel: 5.17.7-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=e382eb2a-06df-4b48-ac6b-ad44f40a43dd rw [email protected] quiet
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.4 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: ASUSTeK product: K56CB v: 1.0
serial: <superuser required>
Mobo: ASUSTeK model: K56CB v: 1.0 serial: <superuser required>
UEFI: American Megatrends v: K56CB.205 date: 03/13/2013
Battery:
ID-1: BAT0 charge: 20.8 Wh (96.7%) condition: 21.5/44.6 Wh (48.2%)
volts: 15.1 min: 15.1 model: ASUSTeK K56--30 type: Li-ion serial: N/A
status: N/A cycles: 438
CPU:
Info: model: Intel Core i3-3217U bits: 64 type: MT MCP arch: Ivy Bridge
family: 6 model-id: 0x3A (58) stepping: 9 microcode: 0x21
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 3 MiB desc: 1x3 MiB
Speed (MHz): avg: 1085 high: 1164 min/max: 800/1800 scaling:
driver: intel_cpufreq governor: schedutil cores: 1: 1083 2: 1062 3: 1164
4: 1033 bogomips: 14368
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel 3rd Gen Core processor Graphics vendor: ASUSTeK driver: i915
v: kernel ports: active: LVDS-1 empty: DP-1,HDMI-A-1,VGA-1 bus-ID: 00:02.0
chip-ID: 8086:0166 class-ID: 0300
Device-2: NVIDIA GK107M [GeForce GT 740M] vendor: ASUSTeK driver: N/A
alternate: nouveau, nvidia_drm, nvidia pcie: speed: Unknown lanes: 63
link-max: gen: 6 speed: 64 GT/s bus-ID: 01:00.0 chip-ID: 10de:0fdf
class-ID: 0302
Device-3: IMC Networks USB Camera type: USB driver: uvcvideo
bus-ID: 1-1.2:3 chip-ID: 13d3:5165 class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.1
compositor: kwin_x11 driver: X: loaded: intel gpu: i915 display-ID: :0
screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
s-diag: 414mm (16.31")
Monitor-1: LVDS-1 mapped: LVDS1 model: AU Optronics 0x46ec
serial: <filter> built: 2010 res: 1366x768 hz: 60 dpi: 102 gamma: 1.2
size: 340x190mm (13.39x7.48") diag: 394mm (15.5") ratio: 16:9
modes: 1366x768
OpenGL: renderer: Mesa Intel HD Graphics 4000 (IVB GT2) v: 4.2 Mesa 22.0.3
compat-v: 3.1 direct render: Yes
Audio:
Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1e20
class-ID: 0403
Device-2: NVIDIA GK107 HDMI Audio driver: snd_hda_intel v: kernel pcie:
speed: Unknown lanes: 63 link-max: gen: 6 speed: 64 GT/s bus-ID: 01:00.1
chip-ID: 10de:0e1b class-ID: 0403
Sound Server-1: ALSA v: k5.17.7-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.51 running: yes
Network:
Device-1: Qualcomm Atheros AR9485 Wireless Network Adapter
vendor: AzureWave AW-NE186H driver: ath9k v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0 chip-ID: 168c:0032 class-ID: 0280
IF: wlp3s0 state: up mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: d000 bus-ID: 04:00.2 chip-ID: 10ec:8168 class-ID: 0200
IF: enp4s0f2 state: down mac: <filter>
Drives:
Local Storage: total: 111.79 GiB used: 25.3 GiB (22.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SA400S37120G
size: 111.79 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: B1D1 scheme: GPT
Partition:
ID-1: / raw-size: 111.5 GiB size: 111.5 GiB (100.00%) used: 25.3 GiB (22.7%)
fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 111.5 GiB size: 111.5 GiB (100.00%)
used: 25.3 GiB (22.7%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 111.5 GiB size: 111.5 GiB (100.00%)
used: 25.3 GiB (22.7%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 111.5 GiB size: 111.5 GiB (100.00%)
used: 25.3 GiB (22.7%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 11.58 GiB used: 19.5 MiB (0.2%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 58.0 C mobo: N/A
Fan Speeds (RPM): cpu: 3000
Info:
Processes: 245 Uptime: 1h 43m wakeups: 1 Memory: 11.58 GiB
used: 4.15 GiB (35.8%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 12.1.0 Packages: pacman: 1196 lib: 312 Shell: fish v: 3.4.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.15

mhwd -l && mhwd -li

0000:01:00.0 (0302:10de:0fdf) Display controller nVidia Corporation:
--------------------------------------------------------------------------------
NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
video-hybrid-intel-nvidia-390xx-dkms-bumblebee            2020.12.07               false            PCI
video-nvidia-390xx-dkms            2020.12.07               false            PCI
video-linux            2021.08.29                true            PCI


> 0000:04:00.2 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd.:
--------------------------------------------------------------------------------
NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
network-r8168            2020.05.22                true            PCI


> 0000:00:02.0 (0300:8086:0166) Display controller Intel Corporation:
--------------------------------------------------------------------------------
NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
video-hybrid-intel-nvidia-390xx-dkms-bumblebee            2020.12.07               false            PCI
video-linux            2021.08.29                true            PCI
video-modesetting            2020.07.13                true            PCI
video-vesa            2017.03.12                true            PCI


> Installed PCI configs:
--------------------------------------------------------------------------------
NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
video-hybrid-intel-nvidia-390xx-dkms-bumblebee            2020.12.07               false            PCI
video-linux            2021.08.29                true            PCI


Warning: No installed USB configs!

Huge thanks :slight_smile:

I believe this is supported by the 470xx driver which should be much better for a hybrid laptop than 390xx with Bumblebee.

Hello @jonathon and thank you for the reply :slight_smile:

Regarding the 470xx driver i have check on the nvidia website and my card ( GeForce GT 740M) is not supported.

I would install that driver but still not sure how everything works on Garuda Lxqt (and does not work in Garuda KDE Dr460nized, Garuda Linux GNOME and Manjaro Kde), :expressionless:

1 Like

Argh, I always forget that my GTX680M is a special case. :expressionless:

Hmm, that is curious. Does LXQT run a different kernel?

Any way we could see garuda-inxi side-by-side for both LXQT and KDE or Gnome, to compare?

1 Like

Reading GeForce GTX 765M support status - Linux - NVIDIA Developer Forums

I wonder whether 470xx is worth trying anyway.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.