Issues with sound quality and random shifting of sound output devices

❯ inxi -Faz                                                                                                                                                                                                   585.1 Mbps  ─╯
System:
  Kernel: 5.15.11-230-tkg-bmq x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: intel_pstate=passive BOOT_IMAGE=/@/boot/vmlinuz-linux-tkg-bmq
    root=UUID=0971afba-13f1-4f58-9dc9-2efda4002dba rw [email protected]
    quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    systemd.unified_cgroup_hierarchy=1 loglevel=3
  Desktop: KDE Plasma 5.23.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
    vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: System76 model: Thelio Major v: thelio-major-r2
    serial: <superuser required> UEFI: System76 v: F4c Z5 date: 06/30/2020
CPU:
  Info: model: AMD Ryzen Threadripper 3960X bits: 64 type: MT MCP arch: Zen 2
    family: 0x17 (23) model-id: 0x31 (49) stepping: 0 microcode: 0x8301025
  Topology: cpus: 1x cores: 24 tpc: 2 threads: 48 smt: enabled cache:
    L1: 1.5 MiB desc: d-24x32 KiB; i-24x32 KiB L2: 12 MiB desc: 24x512 KiB
    L3: 128 MiB desc: 8x16 MiB
  Speed (MHz): avg: 3674 high: 4184 min/max: 2200/4568 boost: enabled
    scaling: driver: acpi-cpufreq governor: performance cores: 1: 4077 2: 3591
    3: 4054 4: 3821 5: 3803 6: 3586 7: 3591 8: 3592 9: 3597 10: 3722 11: 3838
    12: 3356 13: 3591 14: 3597 15: 3587 16: 3600 17: 3600 18: 3588 19: 3584
    20: 3591 21: 3587 22: 3587 23: 3557 24: 3602 25: 4179 26: 3822 27: 3924
    28: 4184 29: 3798 30: 4015 31: 3591 32: 3594 33: 3590 34: 3742 35: 3593
    36: 3590 37: 3595 38: 3592 39: 3595 40: 3591 41: 3834 42: 3461 43: 3597
    44: 3588 45: 3590 46: 3437 47: 3328 48: 3834 bogomips: 364481
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
    STIBP: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: NVIDIA TU106 [GeForce RTX 2060 SUPER] vendor: eVga.com.
    driver: nvidia v: 495.46 alternate: nouveau,nvidia_drm bus-ID: 21:00.0
    chip-ID: 10de:1f06 class-ID: 0300
  Device-2: Logitech BRIO Ultra HD Webcam type: USB
    driver: hid-generic,snd-usb-audio,usbhid,uvcvideo bus-ID: 2-1:2
    chip-ID: 046d:085e class-ID: 0300 serial: <filter>
  Device-3: Elgato Systems Cam Link 4K type: USB
    driver: hid-generic,snd-usb-audio,usbhid,uvcvideo bus-ID: 2-2:3
    chip-ID: 0fd9:0066 class-ID: 0102 serial: <filter>
  Display: x11 server: X.Org 1.21.1.3 compositor: kwin_x11 driver:
    loaded: nvidia display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x2160 s-dpi: 162 s-size: 602x341mm (23.7x13.4")
    s-diag: 692mm (27.2")
  Monitor-1: HDMI-0 res: 3840x2160 hz: 60 dpi: 163
    size: 600x340mm (23.6x13.4") diag: 690mm (27.2")
  OpenGL: renderer: NVIDIA GeForce RTX 2060 SUPER/PCIe/SSE2
    v: 4.6.0 NVIDIA 495.46 direct render: Yes
Audio:
  Device-1: NVIDIA TU106 High Definition Audio vendor: eVga.com.
    driver: snd_hda_intel v: kernel bus-ID: 21:00.1 chip-ID: 10de:10f9
    class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio driver: snd_hda_intel v: kernel
    bus-ID: 23:00.4 chip-ID: 1022:1487 class-ID: 0403
  Device-3: Logitech BRIO Ultra HD Webcam type: USB
    driver: hid-generic,snd-usb-audio,usbhid,uvcvideo bus-ID: 2-1:2
    chip-ID: 046d:085e class-ID: 0300 serial: <filter>
  Device-4: Elgato Systems Cam Link 4K type: USB
    driver: hid-generic,snd-usb-audio,usbhid,uvcvideo bus-ID: 2-2:3
    chip-ID: 0fd9:0066 class-ID: 0102 serial: <filter>
  Device-5: Audio-Technica ATR2100x-USB Microphone type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 5-1:6 chip-ID: 0909:004d
    class-ID: 0300
  Device-6: C-Media Vanatoo T0 type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 7-2:12 chip-ID: 0d8c:0012
    class-ID: 0300
  Device-7: Giga-Byte USB Audio type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 7-5:5 chip-ID: 0414:a002
    class-ID: 0300
  Sound Server-1: ALSA v: k5.15.11-230-tkg-bmq running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.43 running: yes
Network:
  Device-1: Intel I211 Gigabit Network vendor: Gigabyte driver: igb v: kernel
    port: 9000 bus-ID: 43:00.0 chip-ID: 8086:1539 class-ID: 0200
  IF: enp67s0 state: down mac: <filter>
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus-ID: 44:00.0
    chip-ID: 8086:2723 class-ID: 0280
  IF: wlo2 state: up mac: <filter>
Bluetooth:
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 9-5:2 chip-ID: 8087:0029 class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: N/A
Drives:
  Local Storage: total: 2.72 TiB used: 414.56 GiB (14.9%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
    model: SSD 970 EVO Plus 1TB size: 931.51 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 2B2QEXM7 temp: 58.9 C scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:1 vendor: Samsung
    model: SSD 970 EVO Plus 1TB size: 931.51 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 2B2QEXM7 temp: 58.9 C scheme: GPT
  ID-3: /dev/sda maj-min: 8:0 type: USB vendor: Patriot model: N/A
    size: 922.5 GiB block-size: physical: 512 B logical: 512 B type: N/A
    serial: <filter> rev: PMAP scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
  ID-1: / raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
    used: 409.82 GiB (44.0%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:5
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 560 KiB (0.2%) fs: vfat dev: /dev/nvme1n1p1 maj-min: 259:4
  ID-3: /home raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
    used: 409.82 GiB (44.0%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:5
  ID-4: /var/log raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
    used: 409.82 GiB (44.0%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:5
  ID-5: /var/tmp raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
    used: 409.82 GiB (44.0%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:5
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 50 (default 100)
  ID-1: swap-1 type: zram size: 62.75 GiB used: 2.5 MiB (0.0%)
    priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 16.8 C mRobo: N/A gpu: nvidia temp: 58 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 15%
Info:
  Processes: 911 Uptime: 21h 27m wakeups: 0 Memory: 62.75 GiB
  used: 22.63 GiB (36.1%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.1.0 Packages: 2144 pacman: 2136 lib: 577 flatpak: 0 snap: 8
  Shell: Zsh v: 5.8 running-in: konsole inxi: 3.3.11

This problem appeared today as I was on a Zoom call with work colleagues. In System Settings -> Audio I have my USB microphone (ATR 2100x) setup as the Recording Device using the Analog Stereo Duplex profile. For Playback Device I have headphones ATR 2100x (plugged into the microphone) selected.

When I first join a Zoom call, there is a delay before my microphone kicks in, and I normally have to go to System Settings - > Audio and play with (toggle) the volume and selector for the device before it finally starts to work.

Then, several times during the call, the audio will randomly switch to my Digital Output Vanatoo speakers and my microphone intput will switch to another device such that I can't be heard. Toggling the System Settings -> Audio selections will eventually get it back, but even then I'm told my audio is crackling and spotty for a bit.

Not sure what audio subsystem I'm using (Pulseaudio or something else) but hoping someone can help to shed some light and hopefully this can be fixed so I don't have to pull out another machine just to do Zoom calls.

Please let me know what other info I can provide.

Thank you!

I notice you have Pulseaudio and Pipewire running. Is there a reason for that? Pipewire is the new standard, but still under rapid heavy development. It's got some cool, new stuff with it. (Plus JamesDSP prefers it.)

Pulseaudio is tried & true, but has a higher latency factor and a couple other things that probably only audiophiles care about.

I would pick one or the other if it were my machine.

1 Like

Thanks. Not sure why both are running and it was not done intentionally by me. Not sure which to go with (just want something reliable on this machine for listening to Spotify and doing Zoom calls.

  • Is one better for this purpose?
  • How do I go about using one and removing the other? Is there a toggle somewhere to designate one, or do I just remove the package(s) for the one I don't want?

Thank you!

(EDIT)You have a lot of audio devices, I just noticed. If it were my machine, I would give Pipewire a go first. I believe @dr460nf1r3 created a meta package to help with that. I would...

sudo pacman -Syu pipewire-support

It may say that it is in conflict with some Pulseaudio packages and want to replace them. Do so. Then reboot, re-configure audio in System Settings, and see what happens.

If you don't like the results, you can reverse that and go with Pulseaudio with a similar meta package.

regards

ANOTHER EDIT: If it is not already installed, I would later install the appropriate JamesDSP package from the AUR. There's audio support for either subsystem.

4 Likes

Thank you. You had mentioned that i have both pulseaudio AND pipewire installed already. Does the meta-package install more?

Looks like currently for pulseaudio:

❯ sudo pacman -Ss pulseaudio | grep installed                                                                                                                                                                 585.1 Mbps  ─╯
extra/paprefs 1.2-1 [installed]
extra/plasma-pa 5.23.5-1 (plasma) [installed]
extra/pulseaudio 15.0-1 [installed]
extra/pulseaudio-alsa 1:1.2.6-2 [installed]
extra/pulseaudio-qt 1.3-1 [installed]
community/pavucontrol-qt 1.0.0-2 (lxqt) [installed]
community/pulseaudio-equalizer-ladspa 3.0.2-5 [installed]
multilib/lib32-libpulse 15.0-1 [installed]
chaotic-aur/pulseaudio-ctl 1.70-1 [installed]
chaotic-aur/pulseaudio-modules-bt-git 1:15.0.r149.dbb5164-1 [installed]

And for pipewire:

❯ sudo pacman -Ss pipewire | grep installed                                                                                                                                                                   585.1 Mbps  ─╯
extra/pipewire 1:0.3.43-1 [installed]
extra/pipewire-media-session 1:0.4.1-1 [installed]
multilib/lib32-pipewire 1:0.3.43-1 [installed]

Also, would that still present the same problem as I have now where both are still being used?

Proper installation (imo) would be one or the other, not both :slight_smile:

Is there somewhere I set what the underlying sounds system SHOULD be?

It would appear I should not be able to have packages from both installed, and maybe that's why there's an issue. But I would like to settle on one that mostly works.

Garuda defaults to Pipewire with newer ISOs. Unless the user does something otherwise post installation. Try ALSA & Pipewire or ALSA & Pulseaudio. You don't need/want JACK just yet.

I would try Pipewire solely. Not Pulseaudio.

And I would read posts thoroughly, use the Garuda Wiki and Forum, plus Google searches. And I would not panic!

You can learn basic Linux in your free time.
:smiley:

7 Likes

No panic here :wink:

I am now using pipewire and have uninstalled all pulseaudio packages.

I haven't noticed any switching of audio input/output devices since then (going from headphones to speakers, for example) BUT...

the microphone quality is still not good. Audio (whether on Zoom, Loom recordings,...) has static when I talk.

The microphone is an ATR 2100x-USB microphone with Apple headphones plugged into the microphone's headphone jack

  • As mentioned, the audio from the microphone is head with static/pops and
  • I can hear the microphone input (hear myself) in the headphones when I speak.

I've installed alsa-utils and run alsamixer, but not sure if that's where to try to tweak some settings or if there is another utility (and what to check when troubleshooting) Driver, modules, microphone gain, etc.

Help from any sound gurus out there is greatly appreciated, especially if you've experienced similar.

Well, darn, at least we got one thing working proper. I've never used a microphone or microphone/headphone combination in Linux. I do know that the only times I have had problems with headsets they were driver-related. I had two audio devices and they each needed to use a different codec.

Based on that there's a chance that your devices may use different codecs, and they are in collision. Has this exact combination of devices ever worked properly, with good sound quality and no interference in Linux?

Very cool that you used alsa-utils/alsamixere. A lot of folks would not have thought of that. You might also install and run pavucontrol-qt.

And what should have come first is a consultation with Codecs and containers - ArchWiki

2 Likes

Thank you all. Since my last post I have

  • Updated the BIOS on this machine
  • Installed linux -firmware-git
  • Rebooted the machine

I installed and tried to run the mainline kernel, but could not get it to boot. Something to troubleshoot for later.

The good news is that one or more of those actions have resulted in my Bluetooth returning as well as my microphone sound improving (no more static)!

Thank you all for your help and suggestions! This is a fantastically helpful community of people!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.