Issues with snap

Just wondering if anyone else ran into issues getting snap to work correctly? I was getting an error saying "cannot locate base snap core" and then something about "file or directory not found". This error was happening even when I tried to run the snap "hello-world" app. I think I have it working by doing the following (although I'm not sure why this fixes it).

  1. Edit the /etc/os-release file and add an "ID_LIKE=arch" line after "ID=garuda" line so that it looks like this...
    NAME="Garuda Linux"
    PRETTY_NAME="Garuda Linux"
    ID=garuda
    ID_LIKE=arch
    BUILD_ID=rolling
    ...

  2. Uninstall "snapd". Note that this will also uninstall "pamac-all".

  3. Reboot (not sure if necessary - but I did)

  4. Reinstall pamac-all "sudo pacman -S pamac-all"

  5. Install hello-world app using "snap install hello-world"

Now it works! Gives you a warning message about the version of cgroups, but I think that is a know issue with snap.

Not sure why it requres a change to os-release, but it seems that snap must make some installation time decisions based on the type of OS?!?