Issues with Live USB Booting

Hello Garuda Forums,

I'm trying to install Garuda Linux on a laptop, but I have run into a problem with booting the live system I was hoping somebody would be able to help me with.

I have been able to successfully get the Garuda live system to boot on both an ASUS q503a laptop and an IBM Thinkpad X200T laptop just fine, but I am unable to get the Live System to boot on the laptop I was actually wanting to install it on.

The target laptop is a Lenovo Ideapad 130-15AST with 8GB of RAM and an AMD A9 processor. Upon booting from the Live USB and selecting one of the boot options in GRUB, the system maintains a black screen even after several hours of waiting and is completely unresponsive (ctrl+alt+del, ctrl+alt+F2, alt+F5, etc have no effect). I have tried both the options for the Open Source and Proprietary (NVIDIA) drivers.

I have disabled secure boot in the BIOS settings, enabled booting from USB, and enabled Legacy Boot in an attempt to get the operating system to boot, but no change has occurred.

I have also tried to install Garuda onto an external hard drive and then boot from that external hard drive on the target computer, but the same thing happens. I am able to get to GRUB, but something goes wrong after telling the computer to boot from that.

I have also tried the Garuda Multimedia, Garuda Gaming, and Garuda Dr460ized, and Garuda Wayfire on both SanDisk and PNY flash drives, but the problem is not resolved.

Please tell me if there is any more information I should provide, and thank you so much for your help,

Nick

Too new processor. Try some kernel parameters.
Search the web or start from this
https://wiki.archlinux.org/index.php/Ryzen#Soft_lock_freezing

4 Likes

Hi @Nick ,
If your problem is still not solved, since I had the same issue on a Lenovo AMD A9 laptop with Radeon R3 graphic card, I just wanted to let you know that I managed to solve it just adding iommu=soft kernel parameter in the grub.
For me it worked adding it to the free drivers entry without touching anything else (initially I fumbled A LOT trying all the combinations of modesets, but it was not needed in the end).

IMO it's worth trying, it's so fast and simple...

4 Likes

@filo,
Thank you so much for your response! The "iommu=soft" kernel parameter is working excellently so far. You have saved me a lot of time that I do not have much of to begin with. Thank you again, and sorry for the late reply.

Nick

Glad to help you, my pleasure :slightly_smiling_face:

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.