Issues with games and Bluetooth headset

Preformatted textSystem:
Kernel: 6.4.12-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=bafd18ce-cd6b-4899-9832-93c36cfb3955 rw rootflags=subvol=@
quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
ibt=off
Desktop: KDE Plasma v: 5.27.7 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
Mobo: ASUSTeK model: PRIME X670-P WIFI v: Rev 1.xx
serial: <superuser required> UEFI: American Megatrends v: 0823
date: 11/21/2022
Battery:
Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard serial: <filter>
charge: 55% (should be ignored) rechargeable: yes status: discharging
CPU:
Info: model: AMD Ryzen 5 7600X bits: 64 type: MT MCP arch: Zen 4 gen: 5
level: v4 note: check built: 2022+ process: TSMC n5 (5nm) family: 0x19 (25)
model-id: 0x61 (97) stepping: 2 microcode: 0xA601203
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 6 MiB desc: 6x1024 KiB
L3: 32 MiB desc: 1x32 MiB
Speed (MHz): avg: 4727 high: 5438 min/max: 3000/5453 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 5238 2: 5438
3: 4700 4: 3888 5: 4507 6: 5434 7: 3287 8: 4700 9: 4700 10: 4700 11: 4700
12: 5438 bogomips: 112588
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Graphics:
Device-1: AMD Navi 33 [Radeon RX 7700S/7600/7600S/7600M XT/PRO W7600]
vendor: ASRock driver: amdgpu v: kernel arch: RDNA-3 code: Navi-3x
process: TSMC n5 (5nm) built: 2022+ pcie: gen: 4 speed: 16 GT/s lanes: 8
ports: active: HDMI-A-1 empty: DP-1,DP-2,DP-3 bus-ID: 03:00.0
chip-ID: 1002:7480 class-ID: 0300
Device-2: AMD Raphael vendor: ASUSTeK driver: amdgpu v: kernel
arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm) built: 2020-22 pcie:
gen: 4 speed: 16 GT/s lanes: 16 ports: active: none empty: DP-4,HDMI-A-2
bus-ID: 12:00.0 chip-ID: 1002:164e class-ID: 0300 temp: 42.0 C
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.2.0
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting,radeon
alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: HDMI-A-1 mapped: HDMI-A-0 model: D40fM-K09 built: 2022
res: 1920x1080 hz: 60 dpi: 69 gamma: 1.2 size: 708x398mm (27.87x15.67")
diag: 1016mm (40") ratio: 16:9 modes: max: 1920x1080 min: 720x400
API: OpenGL v: 4.6 Mesa 23.1.7-arch1.1 renderer: AMD Radeon Graphics
(gfx1102 LLVM 16.0.6 DRM 3.52 6.4.12-zen1-1-zen) direct-render: Yes
Audio:
Device-1: AMD Navi 31 HDMI/DP Audio driver: snd_hda_intel v: kernel pcie:
gen: 4 speed: 16 GT/s lanes: 8 bus-ID: 03:00.1 chip-ID: 1002:ab30
class-ID: 0403
Device-2: AMD Rembrandt Radeon High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 12:00.1 chip-ID: 1002:1640 class-ID: 0403
Device-3: AMD Family 17h/19h HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 12:00.6 chip-ID: 1022:15e3 class-ID: 0403
API: ALSA v: k6.4.12-zen1-1-zen status: kernel-api tools: N/A
Server-1: PipeWire v: 0.3.79 status: active with: 1: wireplumber
status: active 2: pw-jack type: plugin tools: pw-cat,pw-cli,wpctl
Server-2: PulseAudio v: 16.1 status: active with: 1: pulseaudio-alsa
type: plugin 2: pulseaudio-jack type: module tools: pacat,pactl
Network:
Device-1: Realtek RTL8125 2.5GbE vendor: ASUSTeK driver: r8169 v: kernel
pcie: gen: 2 speed: 5 GT/s lanes: 1 port: d000 bus-ID: 0a:00.0
chip-ID: 10ec:8125 class-ID: 0200
IF: eno1 state: up speed: 2500 Mbps duplex: full mac: <filter>
Device-2: Realtek vendor: AzureWave driver: rtw89_8852be v: kernel pcie:
gen: 1 speed: 2.5 GT/s lanes: 1 port: c000 bus-ID: 0b:00.0
chip-ID: 10ec:b852 class-ID: 0280
IF: wlp11s0 state: down mac: <filter>
Bluetooth:
Device-1: IMC Networks Bluetooth Radio driver: btusb v: 0.8 type: USB
rev: 1.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-2:2 chip-ID: 13d3:3571
class-ID: e001 serial: <filter>
Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.3
lmp-v: 12 status: discoverable: no pairing: no class-ID: 7c0104
Drives:
Local Storage: total: 1.82 TiB used: 39.4 GiB (2.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
model: SSD 970 EVO Plus 2TB size: 1.82 TiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: 2B2QEXM7 temp: 51.9 C scheme: GPT
Partition:
ID-1: / raw-size: 1.82 TiB size: 1.82 TiB (100.00%) used: 39.4 GiB (2.1%)
fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 1.82 TiB size: 1.82 TiB (100.00%)
used: 39.4 GiB (2.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 1.82 TiB size: 1.82 TiB (100.00%)
used: 39.4 GiB (2.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 1.82 TiB size: 1.82 TiB (100.00%)
used: 39.4 GiB (2.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 30.5 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 12 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 47.5 C mobo: N/A
Fan Speeds (rpm): N/A
GPU: device: amdgpu temp: 42.0 C device: amdgpu temp: 40.0 C mem: 54.0 C
fan: 1 watts: 9.00
Info:
Processes: 351 Uptime: 7m wakeups: 2 Memory: total: 32 GiB note: est.
available: 30.5 GiB used: 3.57 GiB (11.7%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
pm: pacman pkgs: 1391 libs: 388
tools: gnome-software,octopi,pamac,paru,trizen Shell: fish v: 3.6.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.29
Garuda (2.6.16-1):
System install date:     2023-09-07
Last full system update: 2023-09-08
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       No/Undetected
Failed units:

Welcome @Popcorn. When you have a chance please explain what the issue you are having is, and describe what you have done so far to troubleshoot.

3 Likes

Looks like you have both PipeWire and PulseAudio active; that could be at least part of the problem. Have you tried just with Pipewire? (Pipewire has its own way to run Pulse through pipewire-pulse)

You might be able to fix it by using Garuda Assistant, and going to the System Components tab. Remove the PulseAudio support and PipeWire support (since the PipeWire installation looks only to be partially there) then hit apply. Then Click the PipeWire support to check the box this time, and hit apply.
Hopefully that will set the components properly. If it still does not work after a restart, could you give us a new garuda-inxi output after all that?

2 Likes

Alright, It’s working now, thanks! I’m still having issues with games crashing, so if you know how to fix it or know someone who does I would greatly appreciate it!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.