Issues with audio on screen mirrioring (no audio over HDMI)

Hii
I am trying to mirror my laptop screen to tv via hdmi cable. The display seems fine though, however there is no audio output from the tv. This is my system info

System:    Kernel: 5.14.12-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0 Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 
info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux 
Machine:   Type: Laptop System: LENOVO product: 81MT v: Lenovo V145-15AST serial: <filter> Chassis: type: 10 
v: Lenovo V145-15AST serial: <filter> 
Mobo: LENOVO model: LNVNB161216 v: No DPK serial: <filter> UEFI-[Legacy]: LENOVO v: 8ZCN27WW(V2.06) 
date: 01/12/2021 
Battery:   ID-1: BAT1 charge: 26.2 Wh (98.5%) condition: 26.6/30.0 Wh (88.5%) volts: 8.6 min: 7.5 
model: 0x53 0x4D 0x50 0x00 0x31 0x PABAS0241231 type: Li-ion serial: <filter> status: Charging cycles: 436 
CPU:       Info: Dual Core model: AMD A6-9225 RADEON R4 5 COMPUTE CORES 2C+3G bits: 64 type: MCP arch: Excavator rev: 0 cache:
L2: 1024 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 10380
Speed: 2279 MHz min/max: 1300/2400 MHz boost: enabled Core speeds (MHz): 1: 2279 2: 2326
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Stoney [Radeon R2/R3/R4/R5 Graphics] vendor: Lenovo driver: amdgpu
v: kernel bus-ID: 00:01.0 chip-ID: 1002:98e4 class-ID: 0300
Device-2: Syntek EasyCamera type: USB driver: uvcvideo bus-ID: 1-1.3:4 chip-ID: 174f:241a class-ID: 0e02
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: amdgpu,ati unloaded: modesetting
alternate: fbdev,vesa resolution: 1366x768~60Hz s-dpi: 96
OpenGL: renderer: AMD STONEY (DRM 3.42.0 5.14.12-zen1-1-zen LLVM 12.0.1) v: 4.5 Mesa 21.2.3 direct render: Yes
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] vendor: Lenovo driver: snd_hda_intel v: kernel bus-ID: 00:01.1
chip-ID: 1002:15b3 class-ID: 0403
Device-2: Advanced Micro Devices [AMD] Family 15h Audio vendor: Lenovo driver: snd_hda_intel v: kernel
bus-ID: 00:09.2 chip-ID: 1022:157a class-ID: 0403
Sound Server-1: ALSA v: k5.14.12-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.38 running: yes
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo driver: N/A port: 3000
bus-ID: 01:00.0 chip-ID: 10ec:8168 class-ID: 0200
Device-2: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter vendor: Lenovo driver: rtw_8821ce v: N/A
port: 2000 bus-ID: 02:00.0 chip-ID: 10ec:c821 class-ID: 0280
IF: wlp2s0 state: up mac: <filter>
Bluetooth: Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8 bus-ID: 1-1.2:3 chip-ID: 0bda:c024 class-ID: e001
serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 4 state: down bt-service: enabled,running rfk-block: hardware: no software: no
address: <filter>
Drives:    Local Storage: total: 931.51 GiB used: 53.61 GiB (5.8%)
ID-1: /dev/sda vendor: Toshiba model: MQ04ABF100 size: 931.51 GiB speed: 6.0 Gb/s type: HDD rpm: 5400
serial: <filter> rev: 0E scheme: MBR
Partition: ID-1: / size: 931.51 GiB used: 53.61 GiB (5.8%) fs: btrfs dev: /dev/sda1
ID-2: /home size: 931.51 GiB used: 53.61 GiB (5.8%) fs: btrfs dev: /dev/sda1
ID-3: /var/log size: 931.51 GiB used: 53.61 GiB (5.8%) fs: btrfs dev: /dev/sda1
ID-4: /var/tmp size: 931.51 GiB used: 53.61 GiB (5.8%) fs: btrfs dev: /dev/sda1
Swap:      ID-1: swap-1 type: zram size: 3.72 GiB used: 765.4 MiB (20.1%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 77.5 C mobo: N/A gpu: amdgpu temp: 77.0 C
Fan Speeds (RPM): N/A
Info:      Processes: 228 Uptime: 2h 5m wakeups: 7 Memory: 3.72 GiB used: 2.59 GiB (69.5%) Init: systemd v: 249 Compilers:
gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1630 Shell: fish v: 3.3.1 default: Bash v: 5.1.8 running-in: konsole
inxi: 3.3.06

anything I can do? I did try few troubleshooting from forum but was not much help.
Thanks in advance

Go to System Settings -> Audio, and select the hdmi under output devices.

4 Likes

Got it..!!
Excuse my bad format, this was first ever :grinning_face_with_smiling_eyes:
Thank you

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.