Issue with plymouth

btw, garuda-boot-options

1 Like

Ehmmm, i do not understand what you mean, sorry :S
I know that "garuda boot options" is a GUI program that lets you configure several settings, i was saying that i have not edited any files "by myself" or "by hand" regarding grub and plymouth, however, the changes i did to grub worked flawlessly (perhaps because i have experience with grub?).

OK, these are the contents of "/etc/plymouth/plymouthd.conf"

# Set your plymouth configuration here.

It does seem to be pointing at the "aperture" theme folder.

Please use

Terminal text
then others can easily expand or copy the text.

terminal text
then others can easily expand or copy the text in the view. Move the mouse pointer over it in the upper right corner.

Move the mouse pointer over it in the upper right corner.

for terminal text.

1 Like

Sure, but i do not know how to use the forum settings to format the text. It is not my intention to cause issues to others. I am using plain text, i am not embedding malicious code.

# text in forum give


so put it in three ~
Terminal text
or delete the mark down format #

Oh, i see now. Thank you!


1 Like

OK, these are the contents of "/etc/default/grub"

# GRUB boot loader configuration

GRUB_CMDLINE_LINUX_DEFAULT="rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3 splash"

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices

# Set to 'countdown' or 'hidden' to change timeout behavior,
# press ESC key to display menu.

# Uncomment to use basic console

# Uncomment to disable graphical terminal

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'

# Uncomment to allow the kernel use the same resolution used by grub

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"

# Uncomment to disable generation of recovery mode menu entries

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.

# Uncomment one of them for the gfx desired, a image background or a gfxtheme

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

# Uncomment to make GRUB remember the last selection. This requires
# setting 'GRUB_DEFAULT=saved' above.

# Uncomment to disable submenus in boot menu

# Probing for other operating systems is disabled for security reasons. Read
# documentation on GRUB_DISABLE_OS_PROBER, if still want to enable this
# functionality install os-prober and uncomment to detect and include other
# operating systems.


Those settings are correct, unless there is something that i should change or improve. (maybe the os prober?)

OK, there is still no change for me, can i somehow upload the files i am using, so they can be reviewed?, can i do something similar without uploading them?

Anyone has any other idea about what can be done?, the issue persists.

Do other themes work?

I just saw this on the Arch Wiki. What if you try manually showing the plymouth splash? Are there any errors? Maybe the theme uses long deprecated and removed features

Edit: Have you tried the following?

Every time a theme is changed, the initrd must be rebuilt. The -R option ensures that it is rebuilt (otherwise manually run mkinitcpio -P):
# plymouth-set-default-theme -R <theme>

Well i will try that, but i thought that Garuda does that after each system update?, at least, the output logs from octopi seem to indicate that. Also, i recently "upgraded" the os with the dracut stuff. i also thought that initrd was rebuilt then, anyway, i am off to test.

OK, so, the command "plymouth-set-default-theme -R aperture" returns the following statement:
"find: ‘/etc/mkinitcpio.d/’: No existe el fichero o el directorio" (translation: "the file or the directory do not exist/missing file or directory")
The "default" themes work, and i can set them up in the boot options.

OK, i also "redid" the theme, i used one that was very similar in content as a base, i then copied the variables and instructions of the theme over and then tested it, but there was no change. The boot options allows me to select it as the splash for plymouth, the rest works fine but the theme does not shows up.

This Plymouth theme does not work. I just installed it for myself to confirm.

It was added to GitHub six years ago, and the code has not been touched once in that entire time. It has either broken at some point over the past six years, or it never worked in the first place.

Normally I would suggest opening an issue on the project's page so the developer can address the problem, but I'm kind of thinking no one is looking after the code. There hasn't been a hint of activity on this project since it was added to GitHub six years ago, not even an issue opened despite the fact that it appears to be broken.

I hate to say so, but I think you should just give up on this one.


I see, well then, i am going to (again) review the documentation for plymouth in archwiki, and try to recreate the theme for more current versions. Thank you so very much for the help, guys.
Oh, also, was the output i received from the terminal command that "UltraBlack" told me to execute, within expected parameters? (i think it failed).

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.