Is there a bug in the system and error reduction

Just for your feedback, I tried several Garuda versions, and have the following experiences.
a) If the bios has secure boot enabled, Garuda will not run. Garuda did not want to use the fat32 "/boot/efi" It does not appear to support secure boot.

b) I am in Québec, and my interface is Canadian English, but the keyboard is Canadian French layout. Garuda's calamari accepts the Canadian French layout, but installs something else. I think it just installed US American layout. In any event, I was unable to log into the system via terminal mode or via gui. My password includes non-alphanumeric characters, and those were missing from the layout that was presented. (Euro symbol was one such character). (Cinnamon and KDE versions).

I wrote an editor and formatter program for an fstab file (fstabxref). It even validates the settings for subvol= UUIDs, etc. It is as complete as I could make it, given lvm, ext4, and btrfs type of file systems. I have not yet tried it with zfs. I will be doing so.

Because I add other disks and partitions, to the distro configuration, the fstabxref editor/formatter becomes a very useful tool.
It flags errors, it says why, and it identifies the fstab line within the fstab. It is also very safe. It does not allow writing to /etc, /bin, /usr, ... So, the way I do it is to write output to /tmp, I check it out, and then sudo mv /tmp/fstab to /etc.


This is a known feature, not a bug, but thanks.

This could probably be a Calamares bug (Calamares is an independent installer, used from many distros). So, you have a personal experience of the Artificial Intelligence inefficiencies.


Very impressive, welcome to the forum.