Is it possible to change the network icon?

Hello,
Is it possible to change the network icon ? I use a a wired connection and the network icon has small blue line when disconnected and small yellow line when connected. I would like a clearer visual indication of connected and disconnected.

Ideally, it should be an all red icon for disconnected, an all amber icon for a wired connection and an all green icon for wired VPN connection.

If this is possible please let me know how to make the changes.

Thanks.

Please post the output of garuda-inxi for all topics in the Issues & Assistance category as requested in the topic template.

Topic template

:warning: Missing information requested in the template may result in not receiving assistance :warning:

Make sure you have done the following before you post:

Issue still unresolved? Then:

  • ONE issue per topic.
  • Describe your issue in detail. The more we know, the better we can help
  • Show us the results of your searches, and what you’ve tried
  • After rebooting, post the FULL output of garuda-inxi in the body of the post (not linked externally, or collapsed with the “hide details” feature)
  • Format terminal output (including your garuda-inxi) as a code block by clicking the preformatted text button (</>) , or put three tildes (~) above and below the text

The template above should be deleted before posting your help request.

We ask that this output always be included so our forum helpers can have a consistent baseline of information to troubleshoot issues with. At the very least we will need to know what desktop environment is in use. If you know what application provides the tray icon you are describing that would be helpful to know as well.

5 Likes

garuda-inxi

System:
  Kernel: 6.7.4-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc avail: hpet,acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=cf4a4272-7f5a-48f5-a1ba-538597770f13 rw rootflags=subvol=@
    quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
    ibt=off
  Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.12 info: frameworks
    v: 5.115.0 wm: kwin_x11 vt: 2 dm: SDDM Distro: Garuda base: Arch Linux
Machine:
  Type: Desktop Mobo: ASRock model: X570S PG Riptide
    serial: <superuser required> UEFI: American Megatrends v: P1.50
    date: 02/23/2022
CPU:
  Info: model: AMD Ryzen 5 5600G with Radeon Graphics bits: 64 type: MT MCP
    arch: Zen 3 gen: 4 level: v3 note: check built: 2021-22
    process: TSMC n7 (7nm) family: 0x19 (25) model-id: 0x50 (80) stepping: 0
    microcode: 0xA50000C
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 16 MiB desc: 1x16 MiB
  Speed (MHz): avg: 1263 high: 2994 min/max: 400/4464 scaling:
    driver: amd-pstate-epp governor: powersave cores: 1: 400 2: 400 3: 2994
    4: 2994 5: 2993 6: 400 7: 400 8: 400 9: 400 10: 2984 11: 400 12: 400
    bogomips: 93423
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities: <filter>
Graphics:
  Device-1: AMD Cezanne [Radeon Vega Series / Radeon Mobile Series]
    driver: amdgpu v: kernel arch: GCN-5 code: Vega process: GF 14nm
    built: 2017-20 pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4
    speed: 16 GT/s ports: active: HDMI-A-1 empty: DP-1,DP-2 bus-ID: 08:00.0
    chip-ID: 1002:1638 class-ID: 0300 temp: 20.0 C
  Display: x11 server: X.Org v: 21.1.11 with: Xwayland v: 23.2.4
    compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
    alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 507x285mm (19.96x11.22")
    s-diag: 582mm (22.9")
  Monitor-1: HDMI-A-1 mapped: HDMI-A-0 model: Samsung serial: <filter>
    built: 2018 res: 1920x1080 hz: 60 dpi: 26 gamma: 1.2
    size: 1872x1053mm (73.7x41.46") diag: 1894mm (74.6") ratio: 16:9 modes:
    max: 3840x2160 min: 720x400
  API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
    device: 1 drv: swrast surfaceless: drv: radeonsi x11: drv: radeonsi
    inactive: gbm,wayland
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 23.3.5-arch1.1
    glx-v: 1.4 direct-render: yes renderer: AMD Radeon Graphics (radeonsi
    renoir LLVM 16.0.6 DRM 3.57 6.7.4-zen1-1-zen) device-ID: 1002:1638
    memory: 500 MiB unified: no
  API: Vulkan v: 1.3.276 layers: 3 device: 0 type: integrated-gpu name: AMD
    Radeon Graphics (RADV RENOIR) driver: mesa radv v: 23.3.5-arch1.1
    device-ID: 1002:1638 surfaces: xcb,xlib device: 1 type: cpu name: llvmpipe
    (LLVM 16.0.6 256 bits) driver: mesa llvmpipe v: 23.3.5-arch1.1 (LLVM
    16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Audio:
  Device-1: AMD Renoir Radeon High Definition Audio driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4
    speed: 16 GT/s bus-ID: 08:00.1 chip-ID: 1002:1637 class-ID: 0403
  Device-2: AMD Family 17h/19h HD Audio vendor: ASRock driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4
    speed: 16 GT/s bus-ID: 08:00.6 chip-ID: 1022:15e3 class-ID: 0403
  API: ALSA v: k6.7.4-zen1-1-zen status: kernel-api tools: N/A
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: PipeWire v: 1.0.3 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
  Device-1: Realtek Killer E3000 2.5GbE vendor: ASRock driver: r8169 v: kernel
    pcie: gen: 2 speed: 5 GT/s lanes: 1 port: f000 bus-ID: 03:00.0
    chip-ID: 10ec:3000 class-ID: 0200
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IF-ID-1: tun0 state: unknown speed: 10000 Mbps duplex: full mac: N/A
  Info: services: NetworkManager,systemd-timesyncd
Drives:
  Local Storage: total: 931.51 GiB used: 506.5 GiB (54.4%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 980 PRO 1TB
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: 5B2QGXA7 temp: 19.9 C
    scheme: GPT
Partition:
  ID-1: / raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
    used: 506.5 GiB (54.4%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 588 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
    used: 506.5 GiB (54.4%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
    used: 506.5 GiB (54.4%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
    used: 506.5 GiB (54.4%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 14.99 GiB used: 0 KiB (0.0%) priority: 100
    comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 12 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 25.8 C mobo: N/A gpu: amdgpu temp: 21.0 C
  Fan Speeds (rpm): N/A
Info:
  Memory: total: 16 GiB note: est. available: 14.99 GiB used: 4.88 GiB (32.5%)
  Processes: 301 Power: uptime: 6h 18m states: freeze,mem,disk suspend: deep
    avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
    suspend, test_resume image: 5.96 GiB services: org_kde_powerdevil,
    power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
    tool: systemctl
  Packages: 1331 pm: pacman pkgs: 1325 libs: 389 tools: octopi,paru
    pm: flatpak pkgs: 6 Compilers: gcc: 13.2.1 Shell: garuda-inxi default: Bash
    v: 5.2.26 running-in: konsole inxi: 3.3.33
Garuda (2.6.23-1):
  System install date:     2022-10-07
  Last full system update: 2024-02-16
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager mkinitcpio
  Windows dual boot:       No/Undetected
  Failed units:

You can play around in the /usr/share/icons/<your icons folder> e.g Beauty line.
And physically edit the icons you don’t like with an image editor like gimp.

You can wait for Plasma 6 to arrive (Feb 28th), it will use the icons from the System Icons Set your installation will use, that will greatly change the standard Plasma 5 icon.

3 Likes

Hi, thanks for your replies.

I had a look at :
`/usr/share/icons/Beauty line
but I could not find the corresponding icons for Networks.

I will wait for the Plasma 6 change to see how it looks.

Thanks again.

Did you by chance look at

/usr/share/icons/BeautyLine/actions/scalable

and view the following icons

network-connect.svg
network-disconnect.svg

I don’t know which icon pack you are using but you can always

ls | grep network #whithin the folders of your icon pack till you get the culprit

Anyway. It is good to know you tried looking for it.

3 Likes

Yes, for some reason they are different icons ?

I am using Beauty line but the
/usr/share/icons/BeautyLine/actions/scalable
are

and my desktop icons
are

Sorry for not being accurate with you.

Could you cd <icon pack> i.e BeautyLIne

and

find . -name "*network*"

Look for icons with the name below

network-wired

And see if any of them is similar to the icon you wanna change.

You could also view all of them quickly by

find . -name "*network*" | <your favourite image viewer e.g imv>

If none of them work, it could suggest a fallback of some sort of which you could try change your icon pack

  • Repeat the same process above for that icon pack and notic which icons changed

  • Then you could copy the respective icons to the respective folders in beauty line

  • I think this is a much more cleaner sure bet approach. Do not give up, I might switch to KDE and do it myself if this process isn’t straight forward enough.

Thanks for your help.
Please keep in mind I am not very Linux technical - so I may mess this up or not make sense.

Try 1)
super@super-computer BeautyLine]$ find . -name “network-wired

./apps/scalable/network-wired.svg
./devices/scalable/network-wired-activated.svg
./devices/scalable/network-wired-symbolic.svg
./devices/scalable/network-wired-unavailable.svg
./devices/scalable/network-wired.svg

none of these show my actual network icons.

Try 2)
switch to different icon set
I downloaded and installed BeautySolar and applied.
All icons changed but my Network icons remain the same.

Okay,I shall install it and try to figure it out. Hope you keep checking up later today. I will update this text. Unless someone solves it for you first.

1 Like

If you are trying to change your Network icon in the SYSTEM TRAY, you should wait until Plasma 6 next week, as your icon will get overridden anyway.
Besides, the one you will see in Plasma 6 may well be the one you will want.

3 Likes

I have an idea but might not be what your looking for, if you right click on the taskbar at bottom > Add Widgets, Then look for Network Speed, Click that once, When its added, Right click > configure network speed and theres some feature in there you can do for network display’s.

There is also Conky that run on the desktop, This can tell you about all kinds of infomation like if eth0 is down or up or in your case tun0 (VPN) is down or up.

Thanks FGD - eagerly awating Plasma 6.
Thanks francisuk1989 - I will try that - hope I don’t mess anything up.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.