Is grub no longer updating with garuda-update?

If I recall correctly grub used to update automatically after updating? Is it still doing so and not saying or did I miss something? Do I need to update grub separately now? Is this even a problem I need to be thinking about?

:: Running post-transaction hooks...
( 1/24) Creating system user accounts...
( 2/24) Updating journal message catalog...
( 3/24) Reloading system manager configuration...
( 4/24) Reloading user manager configuration...
( 5/24) Updating udev hardware database...
( 6/24) Applying kernel sysctl settings...
( 7/24) Creating temporary files...
( 8/24) Reloading device manager configuration...
( 9/24) Arming ConditionNeedsUpdate...
(10/24) Updating the MIME type database...
(11/24) Updating initramfs...
:: Building initramfs for linux-zen (6.6.10-zen1-1-zen)
:: Building fallback initramfs for linux-zen (6.6.10-zen1-1-zen)
(12/24) Updating linux initcpios...
(13/24) Updating the appstream cache...
? Metadata cache was updated successfully.
(14/24) Foreign/AUR package notification
libelectron 1.0.17-1
libretro-duckstation 2105-2
obs-cli-bin 0.5.0-1
tailscaledesktop 1.0.2-1
(15/24) Orphaned package notification...
electron25 25.9.8-1
electron27 27.2.2-1
go 2:1.21.6-1
libajantv2 1:16.2_bugfix5-2
(16/24) Checking for .pacnew and .pacsave files...
(17/24) Reloading system bus configuration...
(18/24) Warn about old perl modules
(19/24) Copy Firefox Distribution Settings
(20/24) Compiling GSettings XML schema files...
(21/24) Updating icon theme caches...
(22/24) Updating the desktop file MIME type cache...
(23/24) Performing snapper post snapshots for the following configurations...
==> root: 174
(24/24) Syncing all file systems...

System updated! 🐧

Here do I dont get called an idiot.

System:
  Kernel: 6.6.10-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=cddde15f-ffa8-4d6b-b056-eb680ae11c76 rw rootflags=subvol=@
    quiet loglevel=3 amdgpu.ppfeaturemask=0xfffd7fff atkbd.reset ibt=off
  Desktop: GNOME v: 45.3 tk: GTK v: 3.24.39 wm: gnome-shell dm: GDM
    v: 45.0.1 Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop System: Micro-Star product: MS-7C37 v: 2.0
    serial: <superuser required>
  Mobo: Micro-Star model: MPG X570 GAMING PLUS (MS-7C37) v: 2.0
    serial: <superuser required> UEFI: American Megatrends LLC. v: A.G0
    date: 03/16/2022
Battery:
  ID-1: hidpp_battery_0 charge: 51% condition: N/A volts: 3.8 min: N/A
    model: Logitech G Pro Wireless Gaming Mouse type: N/A serial: <filter>
    status: discharging
CPU:
  Info: model: AMD Ryzen 7 5800X bits: 64 type: MT MCP arch: Zen 3+ gen: 4
    level: v3 note: check built: 2022 process: TSMC n6 (7nm) family: 0x19 (25)
    model-id: 0x21 (33) stepping: 0 microcode: 0xA201016
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
    L3: 32 MiB desc: 1x32 MiB
  Speed (MHz): avg: 3663 high: 3800 min/max: 2200/5084 boost: enabled
    scaling: driver: acpi-cpufreq governor: performance cores: 1: 3635 2: 3800
    3: 3600 4: 3604 5: 3599 6: 3598 7: 3800 8: 3737 9: 3598 10: 3615 11: 3800
    12: 3597 13: 3800 14: 3613 15: 3598 16: 3619 bogomips: 121600
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities: <filter>
Graphics:
  Device-1: AMD Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT]
    vendor: Tul / PowerColor AXRX driver: amdgpu v: kernel arch: RDNA-1
    code: Navi-1x process: TSMC n7 (7nm) built: 2019-20 pcie: gen: 4
    speed: 16 GT/s lanes: 16 ports: active: DP-1,DP-2,HDMI-A-1 empty: DP-3
    bus-ID: 2f:00.0 chip-ID: 1002:731f class-ID: 0300
  Display: wayland server: X.org v: 1.21.1.10 with: Xwayland v: 23.2.3
    compositor: gnome-shell driver: gpu: amdgpu display-ID: 0
  Monitor-1: DP-1 model: Samsung LC34G55T serial: <filter> built: 2020
    res: 3440x1440 dpi: 109 gamma: 1.2 size: 798x334mm (31.42x13.15")
    diag: 869mm (34.2") modes: max: 3440x1440 min: 720x400
  Monitor-2: DP-2 model: AOC 2770G4 serial: <filter> built: 2016
    res: 1920x1080 dpi: 82 gamma: 1.2 size: 598x336mm (23.54x13.23")
    diag: 686mm (27") ratio: 16:9 modes: max: 1920x1080 min: 720x400
  Monitor-3: HDMI-A-1 model: Asus VE278 serial: <filter> built: 2013
    res: 1920x1080 dpi: 82 gamma: 1.2 size: 598x336mm (23.54x13.23")
    diag: 686mm (27") ratio: 16:9 modes: max: 1920x1080 min: 720x400
  API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
    device: 1 drv: swrast surfaceless: drv: radeonsi wayland: drv: radeonsi x11:
    drv: radeonsi inactive: gbm
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 23.3.3-arch1.1
    glx-v: 1.4 direct-render: yes renderer: AMD Radeon RX 5700 XT (radeonsi
    navi10 LLVM 16.0.6 DRM 3.54 6.6.10-zen1-1-zen) device-ID: 1002:731f
    memory: 7.81 GiB unified: no display-ID: :0.0
  API: Vulkan v: 1.3.274 layers: 11 device: 0 type: discrete-gpu name: AMD
    Radeon RX 5700 XT (RADV NAVI10) driver: mesa radv v: 23.3.3-arch1.1
    device-ID: 1002:731f surfaces: xcb,xlib,wayland device: 1 type: cpu
    name: llvmpipe (LLVM 16.0.6 256 bits) driver: mesa llvmpipe
    v: 23.3.3-arch1.1 (LLVM 16.0.6) device-ID: 10005:0000
    surfaces: xcb,xlib,wayland
Audio:
  Device-1: AMD Navi 10 HDMI Audio driver: snd_hda_intel v: kernel pcie:
    gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 2f:00.1 chip-ID: 1002:ab38
    class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 31:00.4 chip-ID: 1022:1487 class-ID: 0403
  Device-3: Thesycon System & Consulting GmbH SMSL USB DAC
    driver: snd-usb-audio type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0
    bus-ID: 1-1:2 chip-ID: 152a:85dd class-ID: fe01
  Device-4: BEHRINGER GmbH UMC202HD 192k driver: snd-usb-audio type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-2:3 chip-ID: 1397:0507
    class-ID: fe01
  API: ALSA v: k6.6.10-zen1-1-zen status: kernel-api tools: N/A
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: PipeWire v: 1.0.1 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Micro-Star MSI X570-A PRO driver: r8169 v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 27:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  IF: enp39s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IF-ID-1: wg0-mullvad state: unknown speed: N/A duplex: N/A mac: N/A
Drives:
  Local Storage: total: 10.02 TiB used: 8.34 TiB (83.2%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: A-Data model: SX8200PNP
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: R0906I temp: 38.9 C
    scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:5 vendor: Samsung
    model: MZ9LQ256HBJD-00BVL size: 238.47 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: FXM71V1Q temp: 39.9 C scheme: GPT
  ID-3: /dev/sda maj-min: 8:0 vendor: Seagate model: ST6000VN0033-2EE110
    size: 5.46 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    tech: HDD rpm: 7200 serial: <filter> fw-rev: SC60 scheme: GPT
  ID-4: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST4000DM004-2CV104
    size: 3.64 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    tech: HDD rpm: 5425 serial: <filter> fw-rev: 0001 scheme: GPT
  ID-5: /dev/sdc maj-min: 8:32 vendor: Samsung model: SSD 840 EVO 120GB
    size: 111.79 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: BB6Q scheme: GPT
  ID-6: /dev/sdd maj-min: 8:48 vendor: Kingston model: SV200S3128G
    size: 119.24 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 506a scheme: GPT
Partition:
  ID-1: / raw-size: 118.95 GiB size: 118.95 GiB (100.00%)
    used: 111.78 GiB (94.0%) fs: btrfs dev: /dev/sdd2 maj-min: 8:50
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 584 KiB (0.2%) fs: vfat dev: /dev/sdd1 maj-min: 8:49
  ID-3: /home raw-size: 118.95 GiB size: 118.95 GiB (100.00%)
    used: 111.78 GiB (94.0%) fs: btrfs dev: /dev/sdd2 maj-min: 8:50
  ID-4: /var/log raw-size: 118.95 GiB size: 118.95 GiB (100.00%)
    used: 111.78 GiB (94.0%) fs: btrfs dev: /dev/sdd2 maj-min: 8:50
  ID-5: /var/tmp raw-size: 118.95 GiB size: 118.95 GiB (100.00%)
    used: 111.78 GiB (94.0%) fs: btrfs dev: /dev/sdd2 maj-min: 8:50
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 31.26 GiB used: 4 MiB (0.0%) priority: 100
    comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 16 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 51.0 C mobo: N/A gpu: amdgpu temp: 51.0 C
    mem: 50.0 C
  Fan Speeds (rpm): N/A gpu: amdgpu fan: 790
Info:
  Processes: 434 Uptime: 42m wakeups: 0 Memory: total: 32 GiB
  available: 31.26 GiB used: 5.75 GiB (18.4%) Init: systemd v: 255
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
  Packages: pm: pacman pkgs: 1595 libs: 525 tools: pamac,paru Shell: Bash
  v: 5.2.21 running-in: gnome-terminal inxi: 3.3.31
Garuda (2.6.22-1):
  System install date:     2023-11-24
  Last full system update: 2024-01-13 ↻
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       Probably (Run as root to verify)
  Failed units:            


If you refer to the update-grub, this is triggered automatically by the following hook

But this is done only when it is needed, i.e. when kernel is updated or installed.

4 Likes

Thank you.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.