Installing NVIDIA drivers

Hello all :wink:

First of all congrats to the Garuda Linux for the great work.

I was a UBUNTU user for a long time but now thanks to the wonderful work from Garuda Linux Team Im switching to Garuda Linux.

After install everything works great less my GPU. I have a laptop with geforce 740m but Im not sure why Im not being able to install/use the right drivers.

Any help ?

Thanks and long live Garuda Linux :smiley:

2 Likes

Which driver series supports your GPU?

3 Likes

Please post the following command output in your initial post:

inxi -Fxxxza

Please do not post any command outputs as a picture. You can run this command in the live environment and the post it to the forum.

Please use three of these symbols ~ before and after any terminal outputs that you post. This ensures that the output is formatted correctly in a code block on the forum.

~~~
your terminal output here
~~~

Welcome to Garuda.

1 Like

Ty for the answer @tbg :slightly_smiling_face:

System:
  Kernel: 5.10.4-107-tkg-bmq x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: intel_pstate=passive 
  BOOT_IMAGE=/@/boot/vmlinuz-linux-tkg-bmq 
  root=UUID=4a6e945c-fc2d-4052-ad61-f2774e350890 rw rootflags=subvol=@ 
  quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 
  systemd.unified_cgroup_hierarchy=1 loglevel=3 
  Desktop: KDE Plasma 5.20.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 
  dm: SDDM Distro: Garuda Linux 
Machine:
  Type: Laptop System: ASUSTeK product: K56CB v: 1.0 serial: <filter> 
  Mobo: ASUSTeK model: K56CB v: 1.0 serial: <filter> 
  UEFI: American Megatrends v: K56CB.205 date: 03/13/2013 
Battery:
  ID-1: BAT0 charge: 0.5 Wh condition: 0.5/44.6 Wh (1%) volts: 15.1/15.1 
  model: ASUSTeK K56--30 type: Li-ion serial: N/A status: Charging 
  cycles: 438 
CPU:
  Info: Dual Core model: Intel Core i3-3217U bits: 64 type: MT MCP 
  arch: Ivy Bridge family: 6 model-id: 3A (58) stepping: 9 microcode: 21 
  L2 cache: 3 MiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 14383 
  Speed: 1787 MHz min/max: 800/1800 MHz Core speeds (MHz): 1: 1787 2: 1739 
  3: 1726 4: 1772 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: Intel 3rd Gen Core processor Graphics vendor: ASUSTeK 
  driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:0166 
  Device-2: NVIDIA GK107M [GeForce GT 740M] vendor: ASUSTeK 
  driver: nouveau v: kernel bus ID: 01:00.0 chip ID: 10de:0fdf 
  Device-3: IMC Networks USB Camera type: USB driver: uvcvideo 
  bus ID: 1-1.2:3 chip ID: 13d3:5165 serial: <filter> 
  Display: x11 server: X.org 1.20.10 compositor: kwin_x11 
  driver: modesetting resolution: <missing: xdpyinfo> 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4000 (IVB GT2) 
  v: 4.2 Mesa 20.3.2 compat-v: 3.0 direct render: Yes 
Audio:
  Device-1: Intel 7 Series/C216 Family High Definition Audio 
  vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  chip ID: 8086:1e20 
  Device-2: NVIDIA GK107 HDMI Audio driver: snd_hda_intel v: kernel 
  bus ID: 01:00.1 chip ID: 10de:0e1b 
  Sound Server: ALSA v: k5.10.4-107-tkg-bmq 
Network:
  Device-1: Qualcomm Atheros AR9485 Wireless Network Adapter 
  vendor: AzureWave AW-NE186H driver: ath9k v: kernel port: e000 
  bus ID: 03:00.0 chip ID: 168c:0032 
  IF: wlp3s0 state: up mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK driver: r8169 v: kernel port: d000 bus ID: 04:00.2 
  chip ID: 10ec:8168 
  IF: enp4s0f2 state: down mac: <filter> 
Drives:
  Local Storage: total: 111.79 GiB used: 25.26 GiB (22.6%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SA400S37120G 
  size: 111.79 GiB block size: physical: 512 B logical: 512 B 
  speed: 6.0 Gb/s serial: <filter> rev: B1D1 
Partition:
  ID-1: / raw size: 111.49 GiB size: 111.49 GiB (100.00%) 
  used: 25.26 GiB (22.7%) fs: btrfs dev: /dev/sda2 maj-min: 8:2 
  ID-2: /boot/efi raw size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 560 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1 
  ID-3: /home raw size: 111.49 GiB size: 111.49 GiB (100.00%) 
  used: 25.26 GiB (22.7%) fs: btrfs dev: /dev/sda2 maj-min: 8:2 
  ID-4: /var/log raw size: 111.49 GiB size: 111.49 GiB (100.00%) 
  used: 25.26 GiB (22.7%) fs: btrfs dev: /dev/sda2 maj-min: 8:2 
  ID-5: /var/tmp raw size: 111.49 GiB size: 111.49 GiB (100.00%) 
  used: 25.26 GiB (22.7%) fs: btrfs dev: /dev/sda2 maj-min: 8:2 
Swap:
  Kernel: swappiness: 10 (default 60) cache pressure: 75 (default 100) 
  ID-1: swap-1 type: zram size: 2.85 GiB used: 0 KiB (0.0%) 
  priority: 32767 dev: /dev/zram0 
  ID-2: swap-2 type: zram size: 2.85 GiB used: 0 KiB (0.0%) 
  priority: 32767 dev: /dev/zram1 
  ID-3: swap-3 type: zram size: 2.85 GiB used: 0 KiB (0.0%) 
  priority: 32767 dev: /dev/zram2 
  ID-4: swap-4 type: zram size: 2.85 GiB used: 0 KiB (0.0%) 
  priority: 32767 dev: /dev/zram3 
Sensors:
  System Temperatures: cpu: 57.0 C mobo: N/A gpu: nouveau temp: 52.0 C 
  Fan Speeds (RPM): cpu: 3000 
Info:
  Processes: 255 Uptime: 4m wakeups: 1 Memory: 11.4 GiB 
  used: 3.47 GiB (30.4%) Init: systemd v: 247 Compilers: gcc: 10.2.0 
  clang: 11.0.0 Packages: pacman: 1230 lib: 398 Shell: fish v: 3.1.2 
  running in: konsole inxi: 3.2.01 

Btw im trying to install video-nvidia-390xx-dkms but I get the following error

warning: libldac: local (2.0.2.3-3) is newer than extra (2.0.2.3-1)
resolving dependencies...
looking for conflicting packages...

Packages (27) ananicy-git-2.2.0.r50.g2308166-1  dkms-2.8.4-1  egl-wayland-1.1.6-1  eglexternalplatform-1.1-2  gc-8.0.4-4  guile-2.2.6-2  lib32-libxv-1.0.11-2  libnm-1.28.1dev+7+g3f5df3cdc6-1  libxnvctrl-390xx-390.138-1  make-4.3-3  networkmanager-1.28.1dev+7+g3f5df3cdc6-1  nm-cloud-setup-1.28.1dev+7+g3f5df3cdc6-1  openresolv-3.12.0-1  patch-2.7.6-8  texinfo-6.7-3  bbswitch-dkms-0.8-376  bumblebee-3.2.1-21  lib32-nvidia-390xx-utils-390.138-2  lib32-opencl-nvidia-390xx-390.138-2  lib32-primus-20151110-4  lib32-virtualgl-2.6.4-2  nvidia-390xx-dkms-390.138-10  nvidia-390xx-settings-390.138-1  nvidia-390xx-utils-390.138-3  opencl-nvidia-390xx-390.138-3  primus-20151110-9  virtualgl-2.6.4-1

Total Download Size:     1.51 MiB
Total Installed Size:  442.11 MiB
Net Upgrade Size:      414.57 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
downloading virtualgl-2.6.4-1-x86_64.pkg.tar.zst...
downloading bumblebee-3.2.1-21-x86_64.pkg.tar.zst...
downloading primus-20151110-9-x86_64.pkg.tar.zst...
downloading bbswitch-dkms-0.8-376-x86_64.pkg.tar.zst...
downloading lib32-primus-20151110-4-x86_64.pkg.tar.xz...
downloading lib32-libxv-1.0.11-2-x86_64.pkg.tar.xz...
downloading lib32-virtualgl-2.6.4-2-x86_64.pkg.tar.zst...
checking keyring...
checking package integrity...
loading package files...
checking for file conflicts...
checking available disk space...
:: Running pre-transaction hooks...
(1/1) Creating Timeshift snapshot before upgrade...
E: Commands listed below are not available on this system:

 * rsync
 * /sbin/blkid
 * df
 * mount
 * umount
 * fuser
 * crontab
 * cp
 * rm
 * touch
 * ln
 * sync

Please install required packages and try running TimeShift again

** (process:8638): CRITICAL **: 19:50:47.829: app_lock_remove: assertion 'self != NULL' failed
Unable to run timeshift-autosnap! Please close Timeshift and try again. Script will now exit...
error: command failed to execute correctly
error: failed to commit transaction (failed to run transaction hooks)
Errors occurred, no packages were upgraded.
Error: pacman failed!
Error: script failed!

I will not give up on Garuda Linux :slight_smile:

Thx in advanced and a great 2021 to all Garuda Users and Team :slight_smile:

Please, open Konsole terminal and run these commands (post everything in the terminal, input and output text)

pwd
echo $PATH
/usr/bin/bash -c 'echo $PATH'

ty @petsam :slight_smile:

╭─sysope at sysope-k56cb in ⌁
╰─λ pwd
    echo $PATH
    /usr/bin/bash -c 'echo $PATH'
/home/sysope
/usr/local/sbin /usr/local/bin /usr/bin /usr/bin/site_perl /usr/bin/vendor_perl /usr/bin/core_perl
/usr/local/sbin:/usr/local/bin:/usr/bin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl

Your timeshift output seems very strange.
Are you sure you have done initial tasks after installation (package update?) and rebooted?

Yeap. I have done all steps after install. Any clue ?

How did you decide which driver set is the right one?
You should install a hybrid set, since you have Intel and Nvidia GPUs, and your nvidia card is not old (does not need xx390).
Check your options

mhwd -l --pci
1 Like

The error is not related to that package. The package installed but the timeshift snapshot post-installation hook failed to run.

Did you install on an ext4 partition?

1 Like

There is more than rsync... :scream: :sob:

2 Likes