Installing Garuda KDE issue - "networkcfg" error

Hello everyone!
I have a problem installing Garuda KDE.
Each time I receive this error in the middle of the installation:
<class 'NameError'>
name 'target_network' is not defined

Traceback:
File "/usr/lib/calamares/modules/networkcfg/main.py", line 126, in run
replace_username(target_network, live_user, user)

File "/usr/lib/calamares/modules/networkcfg/main.py", line 76, in replace_username
with open(target_network, "r") as network_conf:

So far I have tried the following:

  • Disable fastboot and secure boot.
  • Set device's SATA controller to AHCI mode
  • Selected UEFI only in BIOS
  • I tried several flash usb disks and several ISO writing programs

Interestingly, I have exactly the same error with Manjaro KDE 21.1.4 but I also tried older versions of Manjaro, such as 20.0, and it works without any problems.

So, I'm thinking... Is there a problem with Calamari? Both distros use the same installer.

Can anyone help me please?
Thank you!

3 Likes

Thank you so much! Worked like a charm...

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.