Installer wont detect my partition

So the linux installer wont detect my partition. and I've even tried other distros and nothing works, anyone know how I can fix this?

Thanks for any help!

Are you able to boot up the OS with a Usb drive? If so, have you checked your drive with Partition Manager of any sort? What other distros? Do you have any system details?

2 Likes

On My Laptop system (ASUS ROG G752) Bios was configured for RAID SATA even as I only had a single SSD installed. Other versions of Linux before Garuda saw the SSD no problem and formatted it just fine, But the installer for Garuda (Booted off of a USB Stick) would not partition the drive at all. Changing the Bios setting from RAID fixed that for me....

I am in fact able to boot up the OS with a USB, and Im sure that the partition is created correctly. Ive tried Manjaro, and a few other Arch based distros. Im pretty sure its just the installer

The fact that multiple distros can't see your partition makes it very likely that it was not partitioned properly. How was it partitioned anyways? MBR or GPT? With what program did you create your USB bootable media? I would suggest partitioning with the aforementioned methods, maybe provide us with some details of your system.... Hopefully, with your assistance, we can help more. Welcome to the forum.

3 Likes

Assuming your trying to install Garuda as your only OS on your computer ... boot the live USB & open the program GParted. On the home page of that program, it will have scanned your device & will have any drives (including your internal hard drive) listed right there.

Select your hard drive, then select device from the top menu & then select "create new partition table" from that list. Select "GPT" & press the "apply" button. You'll see the progress end in a single line that says something like "unallocated". The device size will be your total hard drive.

Now, reboot your computer and run the live USB. Retry the installation process & select the "erase disk" option. If you want an encrypted drive, you'll be able to check that box just below that.

GM

1 Like

You have not provided your system info.

If your system is UEFI, you should boot the ISO image in UEFI.
If your system is MSDOS/Legacy you have to boot the ISO image in Legacy.
Check boot options (BIOS Quick Boot Menu), there should be two entries for the USB installer.

4 Likes

It does not find my internal hard drive for some reason. It just sees the USB that i booted it from

Did your hard drive take a crap?

Check BIOS settings for drive mode. Set to AHCI, not RAID.

Post

sudo parted -l
sudo lsblk -f
2 Likes