Installation problem, pls help

Here is my laptop specs:
CPU: I7 5500u
Ram 12gbs of ddr3 ram
gpu:gt840m 2gb
Brand HP Pavilion 15
So recently, i tried installing the Garuda Linux .iso file with my USB flash drive.I downloaded it from source forge and uploaded it using etcher. Here is my file details:
(i cant upload the picture) So heres the directory: This PC - MISO_EFI usb - efi - boot - bootx64.efi. Nothing else.
Then, i rebooted my laptop, booted to the bios section and turned legacy to enabled also selecting usb rom drive as the first priority, and i clicked f10 to save and exit (security boot is disabled). After rebooting again it rebooted and i pressed f9. Somehow it shows the original name of my flash drive (ADATA flash drive) and it showed this message. What did i do wrong?

Selected boot drive did not authenticate, please press enter to continue

It would be thankful if you guys can help me with it.

I suspect you need to disable secure boot in your bios.


uh even it is not disabled, the error msg still appears. is the file normal after using echer ? it only has a 140KB inside it

It is not normal. Check your checksums.

1 Like

Have you verified the checksum as per the below link.
In the link below you'll find also an alternative method to flash the USB (if you start from another Linux distro)

1 Like

sorry but i dont understand what checksum mind if you guide me through it? thanks

Please search before asking.

1 Like

Check the wiki.
If you start from windows there are alternative methods and tools, just search on line "checksum verification" or similar.


poggers I just successfully booted the drive but I have another issue, after clicking boot with open source driver, it shows

Failed to mount '/dev/loop3'

and then I tried the Nvidia driver as well still have the same problem

Do you have another USB stick to try with?
I assume that the checksum has been checked and if necessary the ISO downloaded again...

seems weird here after booting with another USB stick I get another error

ERROR: '/dev/disk/by-local/GARUDA_DR460NIZED_SOARING_'

and with the msg

device did not show up after 30 seconds

Christ, format your USB stick FAT32, download the garuda-dr460nized-linux-zen-210720.iso (size should be about 2.5 GB), then use Etcher to flash the ISO to the newly-formatted USB stick.

Make sure it is the .ISO file you download. We'll worry about checksums later.

actually I tried installing another same iso file and it finally worked poggers and thanks for the help