Installation failed at last step

Dear sir,

I have tried all the edition of Garuda Linux. But every time when I reached the last step of installation (Install Now) installer is stopped. I mean freeze the installation screen. Mouse and keyboard freeze. Nothing is happened. I am using etcher for making bootable usb on windows system. I am using bios method to install.

Please help me.

Thanks in advance.

Welcome to forums,

How much RAM do you have?

And how much time did you wait?


8 gb ddr 3

Where was it frozen?

1 Like

almost one hour I waited

at the last stage of installation. When we click on install and installation process start.

Did you connect to any network?

1 Like

yes my internet connection is on

Then turn it off and try again

Actually, installer tries to install language modules. So, it gets stuck sometimes.

1 Like

nothing happened. I tried many times


This is screenshot of error where Installer is stuck.

Any other utility for windows to make bootable usb except etcher ?

Are you dual booting with windows ?

Looks like you messed up partition table.


Hi kinjar,
welcome to the Garuda Community! :slight_smile:

I dont' see any error message here!
Share your Partitons , installation Summary would be more helpful!
Also read! : UEFI or BIOS? :thinking:
Boot to Windows than Windows, “System Information ” what BIOS mod says?


No. This is just a screen shot of error where my installation failed. I am trying to install in a fully formated harddisk with no operating system.

I'm having the same problem.

Start answer the questions, nobody can or will help on this point.

post the inxi, like in wiki, as text!