Infinite loading screen

Hey there!

After probably yesterday's update, I can't boot up my PC.
This loading screen never finishes.

This might be related to some new init system or smth?.. Not quite clear on this though. Any help appreciated.

Can't post inxi, because it doesn't open..

If you have the LTS kernel installed, try booting with that. If not, restore a snapshot from before the breaking update and post the `garuda-inxi from there. Then, update again, install the LTS kernel and headers, and boot with the LTS kernel from the advanced boot options in the Grub menu.


Can this be done with live-usb? I mean, chrooting and invoking inxi?

Yes, you can do the whole thing from a live environment if you want. Mount the disks and chroot, then update the system and install the LTS kernel and headers from there, then reboot to see if you can get the system up. In my opinion that seems like more work than just restoring a working snapshot.


OK, will do, thank you.

FYI, I discovered just now that my system boots up pretty normally, if I choose in grub "Advanced settings -> ... (fallback initramfs)". I don't know if it's relevant, but this is what happens.

Also, what is up with LTS kernel? Are you suggesting, that the new kernel update is broken, or it is for some other reason?

Thank you!

I guess, the problem kinda solved itself by actually migrating to drakut.
Logged in with 'fallback initramfs', and installed garuda-drakut-support, after which everything went back normal.
Thanks for the help!

LTS==Long Term Support.
Kernel updates can sometimes cause erratic behavior for various reasons known or unknown. The next update may or maynot fix those items. The LTS kernel is said to provide more stable behavior.

You wanted to run with the big dogs, right?


Did you test with the normal image, to confirm the fallback image isn't what was resolving the issue?

Dracut is spelled with a "c" by the way, for anyone following along from home. :wink:

Yes, new kernels can introduce bugs or breaking changes so this is a common troubleshooting step. Any kernel with a different version would be worth testing. The LTS kernel will be on 6.1 for a while, so it can be handy for troubleshooting.

1 Like

Please press Escape and make a photo of that.

Actually the samething happened with me when I updated my system.
Then I tried to boot the system in the recovery mode and then I've found the error saying that my /dev/sda is not getting mounted.. I then removed the entry corresponding to /dev/sda from somefile(probably /etc/fstab) and then the system booted well.

But the HDD not being recognized by the OS is still an issue :sob:

Sounds like this other case here Hard Disk not recognized after update to Kernel: 6.2.2-zen1-1-zen

1 Like

Out of curiosity, ESC in plymouth still works for you? It just freezes the progress bar here.

The same person I think. :male_detective:

I uninstalled plymouth a long time ago haha. I hate not being able to see the kernel log. This is also why I absolutely despise the quiet kernel parameter.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.