Infinite garuda loading screen

I've waited 5 hours for this loading screen to finish and it's still loading. Yesterday, I waited 3 hours, any fix?

linux linux - Album on Imgur

Please, have a look at this article and add the information we need to provide help. Right now, all we have is a pretty bad picture which does not have any value.


I had the same problem and this worked for me
0 - boot from Garuda iso bootable usb
1 - Choose chroot in the Garuda Welcome prompt
2 - Choose You installation of Garuda linux (with numbers)
2 - install text editor like vim sudo pacman -S vim
3 - sudo vim /etc/mkinitcpio.conf
4 - Add vmd to MODULES="..."
5 - Make sure to save the file
6 - mkinitcpio -P linux or mkinitcpio -p linux ( or whatever command regenerates the mkinitfile for you)


Due to the nature of the error, I can only provide a picture of the terminal output, not the text

I dont have a bootable usb unfortunately

Isn't this a new installation?
If so, you should still have the USB used to install.
If not, this could be a problem due to an update, so you should try with a timeshift restore.


It was, but in one of my previous posts I mentioned that my USB was not being detected by Garuda

So, I assume this started doing something to fix that USB problem.
If the USB problem is recent, I'd still go for a restore, but I guess you don't know when it started since USBs are not used daily...
Why don't you try to boot to tty and e.g. try to uninstall what you installed recently?


You can press ESC to get actual text messages about the system startup. That would be a good thing to start with, maybe there are some error messages which are useful to us :slight_smile:


Im currently in the gnu grub command line trying to figure out what happened, I only had several programs on my PC (Brave, OBS, VSCode, Wine, GIMP and Davinci Resolve 17). When I rebooted, my pc was working fine. However, I installed xhci_pci and rebooted my pc to fix my USB and now here I am

Try to boot to tty adding a 3 at the end of the linux line in the grub string.
If it works, you should be able to unistall xhci_pci.
If it doesn't work, restore the snapshot before that installation.

I cant post an image but Ill type out the output

setfont: KDFONTOP: Function not implemented
mount: /new_root/: wrong fs type, bad option, bad superblock on /dev/nvme0n1p1, missing codepage or helper program, or other error.
You are now being dropped into an emergency shell.
sh: can't acess tty: job control turned off

I recommend you go to previous snapshots in the grub menu.
if you don't see the grub menu when you boot modify this file /boot/grub/grub.cfg with sudo sed -i 's/=hidden/=menu/g' /boot/grub/grub.cfg
figure out which snapshot is good for you than choose it as default with timeshift


Ive already tried all the previous snapshots (3, all of them are ~1 hour apart), all of them still brings me to the infinite loading screen

Update on the problem : The problem I caused might be due to me partitioning my 256gb SSD due to the error mentioning something about my SSD

Re-partitioning a drive with an existing operating system installed? Is that what you're saying? Or do you have Garuda on a different drive?

Yes, I had Garuda Linux installed and was about to install Windows 10 to dual boot because most of my steam games wont run in Linux, I partitioned 100 GB if thats relevant

First thing to do for dualbooting is installing the Windows partition. (you can also do it the other way round but that requires chrooting and reinstalling the bootloader via terminal - and its unsupported in this forum even though its certainly possible)

1 Like

That would change the UUID, if I'm reading you right..

Ok, it seems like I made a mistake but is the infinite loading still possible to fix via the command line? Because having a bootable USB is not an option for me right now