Increasing Entropy size

I recently switched to Multimedia version and so far I'm loving it, but everything starts stuttering after a while. I only see Entropy at 98% and I'm wondering how to allocate more to it

System:    Kernel: 5.10.7-111-tkg-bmq x86_64 bits: 64 compiler: gcc v: 10.2.0 
           parameters: intel_pstate=passive BOOT_IMAGE=/@/boot/vmlinuz-linux-tkg-bmq 
           root=UUID=143c2c19-aa35-40e6-8679-3e33e3adf61a rw [email protected] quiet splash 
           rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 loglevel=3 
           Desktop: KDE Plasma 5.20.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 dm: SDDM 
           Distro: Garuda Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: Z170 PRO GAMING v: Rev X.0x serial: <filter> 
           UEFI: American Megatrends v: 3805 date: 05/16/2018 
CPU:       Info: Dual Core model: Intel Pentium G4560 bits: 64 type: MT MCP arch: Kaby Lake family: 6 
           model-id: 9E (158) stepping: 9 microcode: DE L2 cache: 3 MiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 28026 
           Speed: 800 MHz min/max: 800/3500 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 
           mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: srbds mitigation: Microcode 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: NVIDIA GM206 [GeForce GTX 950] vendor: ASUSTeK driver: nouveau v: kernel bus ID: 01:00.0 
           chip ID: 10de:1402 
           Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: nouveau unloaded: modesetting 
           alternate: fbdev,nv,vesa display ID: :0 screens: 1 
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9") 
           Monitor-1: HDMI-1 res: 1920x1080 hz: 60 dpi: 82 size: 598x336mm (23.5x13.2") diag: 686mm (27") 
           OpenGL: renderer: NV126 v: 4.3 Mesa 20.3.3 direct render: Yes 
Audio:     Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: ASUSTeK driver: snd_hda_intel 
           v: kernel bus ID: 00:1f.3 chip ID: 8086:a170 
           Device-2: NVIDIA GM206 High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus ID: 01:00.1 chip ID: 10de:0fba 
           Sound Server: ALSA v: k5.10.7-111-tkg-bmq 
Network:   Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: kernel port: f000 
           bus ID: 00:1f.6 chip ID: 8086:15b8 
           IF: enp0s31f6 state: up speed: 100 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 931.51 GiB used: 134.24 GiB (14.4%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000DM003-1SB102 size: 931.51 GiB block size: 
           physical: 4096 B logical: 512 B speed: 6.0 Gb/s serial: <filter> rev: CC64 
Partition: ID-1: / raw size: 931.22 GiB size: 931.22 GiB (100.00%) used: 134.24 GiB (14.4%) fs: btrfs 
           dev: /dev/sda2 maj-min: 8:2 
           ID-2: /boot/efi raw size: 300 MiB size: 299.4 MiB (99.80%) used: 560 KiB (0.2%) fs: vfat 
           dev: /dev/sda1 maj-min: 8:1 
           ID-3: /home raw size: 931.22 GiB size: 931.22 GiB (100.00%) used: 134.24 GiB (14.4%) fs: btrfs 
           dev: /dev/sda2 maj-min: 8:2 
           ID-4: /var/log raw size: 931.22 GiB size: 931.22 GiB (100.00%) used: 134.24 GiB (14.4%) fs: btrfs 
           dev: /dev/sda2 maj-min: 8:2 
           ID-5: /var/tmp raw size: 931.22 GiB size: 931.22 GiB (100.00%) used: 134.24 GiB (14.4%) fs: btrfs 
           dev: /dev/sda2 maj-min: 8:2 
Swap:      Kernel: swappiness: 10 (default 60) cache pressure: 75 (default 100) 
           ID-1: swap-1 type: zram size: 1.93 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram0 
           ID-2: swap-2 type: zram size: 1.93 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram1 
           ID-3: swap-3 type: zram size: 1.93 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram2 
           ID-4: swap-4 type: zram size: 1.93 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram3 
Sensors:   System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nouveau temp: 24.0 C 
           Fan Speeds (RPM): N/A gpu: nouveau fan: 0 
Info:      Processes: 236 Uptime: 33m wakeups: 0 Memory: 7.71 GiB used: 2.82 GiB (36.6%) Init: systemd v: 247 
           Compilers: gcc: 10.2.0 clang: 11.0.1 Packages: pacman: 1417 lib: 338 Shell: Zsh v: 5.8 
           running in: konsole inxi: 3.2.01

It is next to impossible for us to help you without properly identifying how your system is setup.

I am posting a link to the Garuda Wiki where you will find out how to post the information required to help you:

The section to pay close attention to is the inxi command.

Please post the required output(s) within a reasonable period of time or your help request will be moved off the main forum to an unfrequented backwater channel of the forum.

This is because help requests that include no information are of no use on the forum. Permitting posts with no information to remain on the main forum only encourages other users to think it is acceptable to post similar help requests that can never be solved because of lack of info.

If your post is removed from the main forum you will now know why. If you edit your relocated thread and provide the required info, your post will likely be returned to the main forum. To edit your post press the three dots near the bottom of your post, then press the pencil icon. This will allow you to perform an edit and include the information we require to help you.

1 Like

https://wiki.archlinux.org/index.php/Haveged

We have this already active & 98% is quite a lot? I dont understand this request.

3 Likes

Are you sure this is the correct question?

http://xyproblem.info/

6 Likes

No, I was basically dead inside after installing LineageOS so I just posted this and went to sleep, sorry about that. Everything runs smoothly until Entropy hits around 98% (usually at around 93%) when I'm multitasking, so I'm searching for a way to decrease usage/increase capacity if that is what I'm supposed to do

1 Like

Normally, more "entropy" means the pool is contains more available bits for use, so more is normally better. Exhausting the available entropy pool is normally when processes will stall.

So, two questions:

  1. what are you checking to determine "entropy"?
  2. is this simply a symptom of a different issue, e.g. have you looked at top and iotop to see what else the system is doing?
3 Likes

On multimedia edition there is monitoring thing on the right side of the screen. I have 4096 entropy in total, Fxx is also added on the edit
I'm looking at both top and iotop, but I don't see anything going nuts even at 97% (I'm only looking at CPU, MEM, DISK READ, DISK WRITE, SWAPIN, IO).

I still fail to see the issue here. Entropy is already increased by haveged?

1 Like

This kind of implies that the available entropy value is not related to the issue you're seeing.

Keep watching top and iotop to see what happens when the issue occurs.

2 Likes

When I'm using multiple programs and tabs everything becomes laggy. Cpu and ram are more than fine, but it's always happening when entropy reaches around 98%

1 Like

"Entropy" is very likely the wrong direction here. haveged refills the entropy pool so the issue is not a lack of entropy.

The fact entropy hits 98% is more likely an indication of a process stalling and allowing available entropy to reach that point. That is, it is a symptom.

1 Like

I'll do some digging then, what tabs in top and iotop should I look at?

Neither of those programs has tabs?

You're looking for anomalous behaviour that occurs around the same time you see the issue, e.g. high CPU and/or high IO use by a process. You might also look at network usage with e.g. iftop.

1 Like

I meant those lines like cpu and etc, I'm not native so I occasionally butcher thing or two

1 Like

All of them. :wink:

2 Likes

What about PR, VIRT, RES, SHR in top? And can you take a glance at this? Just duble checking if everything is ok

top - 14:57:30 up  1:13,  3 users,  load average: 1,66, 1,89, 1,96
Tasks: 231 total,   1 running, 229 sleeping,   0 stopped,   1 zombie

Update: Noticed cpu spike on latte-dock process (30-60% cpu usage) and xorg (20-30% cpu) when minimalizing and maximalizing windows and consoles

I can't tell you what to look for. You need to observe the system running in a normal state.

You will see occasional CPU usage as programs do things - that's normal and to be expected given that's what a CPU is supposed to do. However, you can watch for a process constantly running at 100% or more.

Same for RAM usage - programs need RAM, so will use RAM, but you can watch for processes constantly taking up more until the RAM fills.

4 Likes