If monitor sleeps/is turned off, have to reboot system to get it working again

This is a somewhat recent issue (started maybe a month ago?). If my monitor falls asleep or if I turn it off and try to wake/turn it on later, it gives me "no signal". Note this is waking the monitor from sleep, not the system (the system is set to never sleep). When I jiggle the mouse the monitor turns on, displays a gray screen, then gives me "no signal". So it's definitely getting something from the system. There's another issue that may be related: when I start my computer and get to the login screen, the monitor is on but it's just a black screen. I only get video after I input my password and hit enter.

garuda-inxi output:

System:
Kernel: 6.0.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=6276c6a9-723f-47e6-a43b-06f7b629b5b5 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=a0a9f712-b7b9-4caf-974c-8def2b54643e loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.26.1 tk: Qt v: 5.15.6 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: Alienware product: Alienware m15 R3 v: 1.20.0
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: Alienware model: Alienware m15 R3 v: A00
serial: <superuser required> UEFI: Alienware v: 1.20.0 date: 09/02/2022
Battery:
ID-1: BAT1 charge: 74.5 Wh (100.0%) condition: 74.5/86.0 Wh (86.7%)
volts: 12.6 min: 11.4 model: COMPAL PABAS0241231 type: Li-ion
serial: <filter> status: full
CPU:
Info: model: Intel Core i7-10750H bits: 64 type: MT MCP arch: Comet Lake
gen: core 10 level: v3 note: check built: 2020 process: Intel 14nm
family: 6 model-id: 0xA5 (165) stepping: 2 microcode: 0xF0
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
L3: 12 MiB desc: 1x12 MiB
Speed (MHz): avg: 3069 high: 4853 min/max: 800/5000 scaling:
driver: intel_pstate governor: performance cores: 1: 2600 2: 2600 3: 1585
4: 2600 5: 2600 6: 4853 7: 2600 8: 4791 9: 4800 10: 2600 11: 2600
12: 2600 bogomips: 62399
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
Type: retbleed mitigation: Enhanced IBRS
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
filling, PBRSB-eIBRS: SW sequence
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel CometLake-H GT2 [UHD Graphics] vendor: Dell driver: i915
v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20 bus-ID: 00:02.0
chip-ID: 8086:9bc4 class-ID: 0380
Device-2: NVIDIA TU104M [GeForce RTX 2070 SUPER Mobile / Max-Q]
vendor: Dell driver: nvidia v: 520.56.06 alternate: nouveau,nvidia_drm
non-free: 515.xx+ status: current (as of 2022-10) arch: Turing
code: TUxxx process: TSMC 12nm built: 2018-22 pcie: gen: 3 speed: 8 GT/s
lanes: 8 link-max: lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:1e91
class-ID: 0300
Device-3: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo
bus-ID: 1-7:3 chip-ID: 0bda:5538 class-ID: 0e02 serial: <filter>
Device-4: Realtek Cable Matters USB-C Video type: USB driver: N/A
bus-ID: 11-2:2 chip-ID: 0bda:5442 class-ID: 1100 serial: <filter>
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.4
compositor: kwin_x11 driver: X: loaded: nvidia gpu: i915,nvidia
display-ID: :0 screens: 1
Screen-1: 0 s-res: 4480x1440 s-dpi: 93 s-size: 1222x393mm (48.11x15.47")
s-diag: 1284mm (50.54")
Monitor-1: DP-0 pos: primary res: 2560x1440 dpi: 93
size: 697x392mm (27.44x15.43") diag: 800mm (31.48") modes: N/A
Monitor-2: DP-2 size-res: N/A modes: N/A
OpenGL: renderer: NVIDIA GeForce RTX 2070 Super/PCIe/SSE2 v: 4.6.0 NVIDIA
520.56.06 direct render: Yes
Audio:
Device-1: Intel Comet Lake PCH cAVS vendor: Dell driver: snd_hda_intel
v: kernel bus-ID: 5-2:2 chip-ID: 2188:6533
alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
class-ID: 0300 chip-ID: 8086:06c8 class-ID: 0403
Device-2: NVIDIA TU104 HD Audio vendor: Dell driver: snd_hda_intel
v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 8 link-max: lanes: 16
bus-ID: 01:00.1 chip-ID: 10de:10f8 class-ID: 0403
Device-3: No brand CalDigit Thunderbolt 3 Audio type: USB
driver: hid-generic,snd-usb-audio,usbhid
Device-4: SteelSeries ApS Arctis Pro Wireless type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 7-1.3:5 chip-ID: 1038:1297
class-ID: 0300
Sound API: ALSA v: k6.0.2-zen1-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.59 running: yes
Network:
Device-1: Intel I210 Gigabit Network vendor: CalDigit driver: igb v: kernel
pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 7000 bus-ID: 0b:00.0
chip-ID: 8086:1533 class-ID: 0200
IF: enp11s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-2: Realtek Killer E3000 2.5GbE vendor: Dell driver: r8169
v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1 port: 3000 bus-ID: 3e:00.0
chip-ID: 10ec:3000 class-ID: 0200
IF: enp62s0 state: down mac: <filter>
Device-3: Intel Wi-Fi 6 AX200 vendor: Rivet Networks driver: iwlwifi
v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1 bus-ID: 3f:00.0
chip-ID: 8086:2723 class-ID: 0280
IF: wlp63s0 state: down mac: <filter>
IF-ID-1: anbox0 state: down mac: <filter>
Bluetooth:
Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 1-14:5 chip-ID: 8087:0029 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Drives:
Local Storage: total: 5.01 TiB used: 214.93 GiB (4.2%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:4 vendor: Samsung model: SSD 980 1TB
size: 931.51 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 2B4QFXO7
temp: 44.9 C scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: KIOXIA model: KXG60ZNV512G NVMe
512GB size: 476.94 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 10604106
temp: 53.9 C scheme: GPT
ID-3: /dev/sda maj-min: 8:0 type: USB vendor: Seagate
model: ST4000LM024-2AN17V size: 3.64 TiB block-size: physical: 4096 B
logical: 512 B type: HDD rpm: 5526 serial: <filter> rev: 0003 scheme: GPT
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
ID-1: / raw-size: 914.3 GiB size: 914.3 GiB (100.00%) used: 214.93 GiB
(23.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:6
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 596 KiB
(0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:5
ID-3: /home raw-size: 914.3 GiB size: 914.3 GiB (100.00%) used: 214.93
GiB (23.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:6
ID-4: /var/log raw-size: 914.3 GiB size: 914.3 GiB (100.00%) used: 214.93
GiB (23.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:6
ID-5: /var/tmp raw-size: 914.3 GiB size: 914.3 GiB (100.00%) used: 214.93
GiB (23.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:6
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.38 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
ID-2: swap-2 type: partition size: 16.92 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:7
Sensors:
System Temperatures: cpu: 62.0 C pch: 69.0 C mobo: N/A gpu: nvidia
temp: 49 C
Fan Speeds (RPM): N/A
Info:
Processes: 348 Uptime: 14m wakeups: 4 Memory: 15.38 GiB used: 5.7 GiB
(37.1%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: pm: pacman pkgs: 2244
libs: 570 tools: octopi,paru pm: flatpak pkgs: 0 Shell: fish v: 3.5.1
running-in: konsole inxi: 3.3.22
Garuda (2.6.8-1):
System install date:     2022-05-08
Last full system update: 2022-10-20
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:            systemd-networkd-wait-online.service

I have almost exactly the same issue with my main monitor (I run a dual monitor setup) when the monitor goes to sleep as well. Maybe this will help the admins diagnose our issue:

my garuda-inxi output:

System:
Kernel: 6.0.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=fb870b32-9d3f-40a8-9f3f-40654c06e4e2 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=b5416a9f-e921-41f1-9110-9b2bbce75c0e loglevel=3
Desktop: KDE Plasma v: 5.26.1 tk: Qt v: 5.15.6 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: ASUSTeK model: ROG STRIX B450-F GAMING v: Rev 1.xx
serial: <superuser required> UEFI: American Megatrends v: 4901
date: 07/25/2022
Battery:
Device-1: hidpp_battery_0 model: Logitech G700s serial: <filter> charge: 70%
(should be ignored) rechargeable: yes status: discharging
CPU:
Info: model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen 2 gen: 3
level: v3 note: check built: 2020-22 process: TSMC n7 (7nm)
family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701021
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 32 MiB desc: 2x16 MiB
Speed (MHz): avg: 3698 high: 4200 min/max: 2200/4208 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3600 2: 3600
3: 3600 4: 3600 5: 3600 6: 3600 7: 3600 8: 4158 9: 4200 10: 3600 11: 3600
12: 3628 bogomips: 86406
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed mitigation: untrained return thunk; SMT enabled with STIBP
protection
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
always-on, RSB filling, PBRSB-eIBRS: Not affected
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA GA104 [GeForce RTX 3070 Ti] vendor: eVga.com.
driver: nvidia v: 520.56.06 alternate: nouveau,nvidia_drm non-free: 515.xx+
status: current (as of 2022-10) arch: Ampere code: GAxxx process: TSMC n7
(7nm) built: 2020-22 pcie: gen: 2 speed: 5 GT/s lanes: 16 link-max:
gen: 4 speed: 16 GT/s bus-ID: 07:00.0 chip-ID: 10de:2482 class-ID: 0300
Device-2: Logitech C920 HD Pro Webcam type: USB
driver: snd-usb-audio,uvcvideo bus-ID: 5-2:2 chip-ID: 046d:0892
class-ID: 0102 serial: <filter>
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.4
compositor: kwin_x11 driver: X: loaded: nvidia gpu: nvidia display-ID: :0
screens: 1
Screen-1: 0 s-res: 5360x1440 s-dpi: 95 s-size: 1433x389mm (56.42x15.31")
s-diag: 1485mm (58.46")
Monitor-1: DP-4 pos: primary,top-left res: 3440x1440 hz: 60 dpi: 109
size: 800x335mm (31.5x13.19") diag: 867mm (34.15") modes: N/A
Monitor-2: HDMI-0 pos: bottom-r res: 1920x1080 hz: 60 dpi: 96
size: 509x286mm (20.04x11.26") diag: 584mm (22.99") modes: N/A
OpenGL: renderer: NVIDIA GeForce RTX 3070 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA
520.56.06 direct render: Yes
Audio:
Device-1: NVIDIA GA104 High Definition Audio vendor: eVga.com.
driver: snd_hda_intel v: kernel bus-ID: 5-2:2 chip-ID: 046d:0892 pcie:
gen: 3 class-ID: 0102 serial: <filter> speed: 8 GT/s lanes: 16 link-max:
gen: 4 speed: 16 GT/s bus-ID: 07:00.1 chip-ID: 10de:228b class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 09:00.4 chip-ID: 1022:1487 class-ID: 0403
Device-3: Logitech C920 HD Pro Webcam type: USB
driver: snd-usb-audio,uvcvideo
Sound API: ALSA v: k6.0.2-zen1-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.59 running: yes
Network:
Device-1: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: kernel
pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: e000 bus-ID: 04:00.0
chip-ID: 8086:1539 class-ID: 0200
IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
Local Storage: total: 13.19 TiB used: 6.11 TiB (46.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
model: WDBRPG0010BNC-WRSN size: 931.51 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 111130WD temp: 38.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 500GB
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 1B6Q scheme: MBR
ID-3: /dev/sdb maj-min: 8:16 vendor: Toshiba model: HDWE140
size: 3.64 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
type: HDD rpm: 7200 serial: <filter> rev: FP1R scheme: GPT
ID-4: /dev/sdc maj-min: 8:32 vendor: Toshiba model: MD04ACA500
size: 4.55 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
type: HDD rpm: 7200 serial: <filter> rev: FP2A scheme: GPT
ID-5: /dev/sdd maj-min: 8:48 type: USB vendor: Toshiba model: External
USB 3.0 size: 3.64 TiB block-size: physical: 4096 B logical: 512 B
type: N/A serial: <filter> rev: 5438 scheme: GPT
Partition:
ID-1: / raw-size: 896.83 GiB size: 896.83 GiB (100.00%) used: 54.3 GiB
(6.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 608 KiB
(0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 896.83 GiB size: 896.83 GiB (100.00%) used: 54.3
GiB (6.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 896.83 GiB size: 896.83 GiB (100.00%) used: 54.3
GiB (6.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 896.83 GiB size: 896.83 GiB (100.00%) used: 54.3
GiB (6.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.26 GiB used: 16 MiB (0.0%) priority: 100
dev: /dev/zram0
ID-2: swap-2 type: partition size: 34.39 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
Sensors:
System Temperatures: cpu: 38.0 C mobo: 28.0 C gpu: nvidia temp: 44 C
Fan Speeds (RPM): cpu: 837 case-1: 766 case-2: 0 case-3: 891 gpu: nvidia
fan: 0%
Power: 12v: 9.87 5v: N/A 3.3v: N/A vbat: 3.23
Info:
Processes: 335 Uptime: 3h 15m wakeups: 3 Memory: 31.26 GiB used: 5.64 GiB
(18.0%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 1857 libs: 505
tools: octopi,paru Shell: fish v: 3.5.1 default: Bash v: 5.1.16
running-in: konsole inxi: 3.3.22
Garuda (2.6.9-1):
System install date:     2022-10-21
Last full system update: 2022-10-23
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:            irqbalance.service

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.