I3 switch keyboard layouts problem

Hello! I installed Garuda I3 distro and got this problem from the very beginning. At first, if I choose ru locale on the installation stage, I can't even run Garuda settings or assistant, cause I can't switch languages. Also the I3 does not react Cyrillic keys. If I choose US locale as default, I still have problems.

There is no way to set lang-change keybindings in default settings gui. So each time I have to:

  1. run default settings gui -> keyboard settings
  2. Switch to russian and back

setxkbmap -layout us, ru
setxkbmap -option 'grp:alt_shift_toggle'

Putting this scripts into . bashrc . zshrc gives no result after reboot.
Configuring /etc/locale.conf and

locale-gen gives no result.

Configuring /etc/vconsole.conf and reboot gives no result.

Also default keybindings for i3 from the box are not good, because traditionaly i3 used to be exploiting jkl; for changins focus/size rather than arrows - it is much handy after all.

Laptop: Fudjitsu Lifebook e780
Distro: Garuda I3wm.

Have you tried to put the lines

setxkbmap -layout us, ru
setxkbmap -option 'grp:alt_shift_toggle'

in the i3 config?

Let i3 execute them on start

i3 is not for everyone.
You haven't said:

  • if you are a new or old i3 user
  • which guide do you seek advice from

Have you read this?

1 Like