I encountered two errors in the new version. I don’t know what they are and how to solve them

After I installed a new version, I would get such an error every time in the terminal. What caused it? How can I solve it?

McFly: Upgrading McFly DB to version 3, please wait...thread 'main' panicked at 'McFly error: Unable to add cm
d_tpl to commands (duplicate column name: cmd_tpl)', src/history/schema.rs:41:17
note: run with RUST_BACKTRACE=1 environment variable to display a backtrace

Of course, there is another long-standing error, which has always existed in previous versions. I don’t understand what the error is and how to solve it.

Failed to write file "/sys/module/pcie_aspm/parameters/policy": Operation not permitted
Error: The command could not be executed correctly

The above are two errors. Can you help me fix it? Thanks everyone for your help. I use translation software to study with everyone. There may be an error in the expression.

I wish you all good health and happiness

quick search i found this mcfly issue seems like it could just be some non-printable characters in your history

image :grinning:

1st error can be fixed by removing mcfly database (~/.mcfly/history.db)
2nd error can be fixed (Power management - ArchWiki)

and both error can be fixed if you search it on the internet. You can use duckduckgo, google, bing, whoogle, searx, and many more.

As told when creating the post, tell what have you done for the issue, what have you tried, atleast search the error on the internet.

Sorry if you think its rude but it is what it is.


Thanks, I understand, I struggled to find the answer too much as a ARCH newbie I'm trying to learn, I was reading this power supply question you posted.

if the issue is solved you can mark the solution so others could be helped

sudo rm ~/.mcfly/history.db ?

I solved the terminal error by typing: sudo rm ~/.mcfly/history.db, the second error is not solved yet, I read the documentation what should I do?

you can ignore it, it doesnt cause any problems but if you really want to do it, you need to add pcie_aspm=force to kernel parameter, but as written in wiki:

  • Forcing on ASPM can cause a freeze/panic, so make sure you have a way to undo the option if it does not work.
  • On systems that do not support it forcing on ASPM can even increase power consumption.

it is a risky thing, my advice is to ignore it.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.