I can't update my system anymore due to a poppler issue

sudo pacman -Syu
[sudo] password for partha:            
:: Synchronizing package databases...
core is up to date
extra is up to date
community is up to date
multilib is up to date
chaotic-aur is up to date
:: Starting full system upgrade...
:: Replace crda with core/wireless-regdb? [Y/n] y
resolving dependencies...
looking for conflicting packages...
:: poppler-git and poppler are in conflict. Remove poppler? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: removing poppler breaks dependency 'poppler=22.03.0' required by poppler-qt5

Another solved thread said to remove all conflicting package but that keeps expanding as when i

sudo pacman -R cups-filters
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing cups-filters breaks dependency 'cups-filters' required by cups
:: removing cups-filters breaks dependency 'cups-filters>=1.0.42' required by foomatic-db-engine
:: removing cups-filters breaks dependency 'cups-filters' required by gutenprint
:: removing cups-filters breaks dependency 'cups-filters' required by printer-support

I tried removing all 4 poppler packages manually but i am not able to do so because they keep showing inter-dependencies.

Do you try the standard/recommended N?

i selected N before

Same issue arises

sudo pacman -Syu
[sudo] password for partha:
:: Synchronizing package databases...
core is up to date
extra is up to date
community is up to date
multilib is up to date
chaotic-aur                                                                                                      1668.9 KiB   688 KiB/s 00:02 [----------------------------------------------------------------------------------------] 100%
:: Starting full system upgrade...
:: Replace crda with core/wireless-regdb? [Y/n] y
resolving dependencies...
looking for conflicting packages...
:: poppler-git and poppler are in conflict. Remove poppler? [y/N] N
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: poppler-git and poppler are in conflict

Also i tried

sudo pacman -Syu --ignore=poppler
:: Synchronizing package databases...
core is up to date
extra is up to date
community is up to date
multilib is up to date
chaotic-aur is up to date
:: Starting full system upgrade...
:: Replace crda with core/wireless-regdb? [Y/n] y
resolving dependencies...
looking for conflicting packages...
:: poppler-git and poppler are in conflict. Remove poppler? [y/N] N
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: poppler-git and poppler are in conflict

Remove poppler-git with

sudo pacman -Rdd poppler-git && sudo pacman -Syu
5 Likes

Solution Provided by User Tako on telegram

sudo pacman -S poppler-glib && sudo pacman -Syu

[email protected] in ~ as 🧙 took 11s
[🔴] × sudo pacman -S poppler-glib && sudo pacman -Syu
[sudo] password for partha:            
resolving dependencies...
looking for conflicting packages...
:: poppler-glib and poppler-glib-git are in conflict. Remove poppler-glib-git? [y/N] y

Packages (2) poppler-glib-git-22.03.0.r84.g8942ba12-1 [removal]  poppler-glib-22.03.0-1

Total Download Size:   0.27 MiB
Total Installed Size:  2.78 MiB
Net Upgrade Size:      0.02 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages...
poppler-glib-22.03.0-1-x86_64                                                                                     277.6 KiB   125 KiB/s 00:02 [----------------------------------------------------------------------------------------] 100%
(1/1) checking keys in keyring                                                                                                                 [----------------------------------------------------------------------------------------] 100%
(1/1) checking package integrity                                                                                                               [----------------------------------------------------------------------------------------] 100%
(1/1) loading package files                                                                                                                    [----------------------------------------------------------------------------------------] 100%
(1/1) checking for file conflicts                                                                                                              [----------------------------------------------------------------------------------------] 100%
(2/2) checking available disk space                                                                                                            [----------------------------------------------------------------------------------------] 100%
:: Running pre-transaction hooks...
(1/1) Performing snapper pre snapshots for the following configurations...
==> root: 291
:: Processing package changes...
(1/1) removing poppler-glib-git                                                                                                                [----------------------------------------------------------------------------------------] 100%
(1/1) installing poppler-glib                                                                                                                  [----------------------------------------------------------------------------------------] 100%
:: Running post-transaction hooks...
(1/7) Arming ConditionNeedsUpdate...
(2/7) Refreshing PackageKit...
(3/7) Foreign/AUR package notification
ani-cli 1.9-1
crda 4.14-4
davfs2 1.6.1-1
lockdown-ms 20130326-4
lohit-fonts 2.95.5.1-2
snapd 2.55.2-1
(4/7) Orphaned package notification...
=> No orphans found.
(5/7) Checking for .pacnew and .pacsave files...
.pac* files found:
/etc/locale.gen.pacnew
/etc/pamac.conf.pacnew
/etc/pacman.d/mirrorlist.pacnew
/etc/paru.conf.pacnew
Please check and merge
(6/7) Performing snapper post snapshots for the following configurations...
==> root: 292
(7/7) Syncing all file systems...
:: Synchronizing package databases...
core is up to date
extra is up to date
community is up to date
multilib is up to date
chaotic-aur                                                                                                      1668.9 KiB   954 KiB/s 00:02 [----------------------------------------------------------------------------------------] 100%
:: Starting full system upgrade...
4 Likes

i also was having this issue and this worked for me, thank you very much <3

My question is, why was poppler-git installed in the first place?
I might try to automate this fix.

@Michael_joseph @Partha2003 when did you install your system and what edition is it?

4 Likes

my system did not have poppler-git, i believe the updater was attempting to install it and i have no idea why.

i recently reinstalled my entire OS from the 210809.iso about a month ago.
i had this same poppler-git issue back then, but it rectified itself with the 'pacman -Syu' command as mentioned in a previous thread regarding this issue and just reappeared yesterday evening.

i normally use 'update' from terminal to keep my system updated.

the Garuda version i have is the Dragonized gaming edition.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.