I broke grub

Hello community!
I installed Garuda Linux with your installer (dual boot with Windows 10, and I chose luks encrpytion in the Garuda installer). All went well.
I had the system up running.
But later on, I wanted to make a change to grub, which broke it.
Now I cannot boot Garuda anymore. :sad:
Grub asks for my pw, I providee it, it unlocks and then the grub menu comes up - I can choose Windows or Garuda, but if I choose garuda , it never boots up.
I tried to find a solution myself. The web says I should run a live CD , then mount my partition and chroot into it, then fix grub config.
However, the encryption complicates things a bit.
I tried
cryptsetup open /dev/sda4 mycryptpart
it asked for my password and gave no error.
But sudo mount /dev/mapper/mycryptpart /mnt
says missing codepage or unknown fs , yet I have btrfs tools installed and blkid shows that /dev/mapper/mycryptpart is btrfs, not unknown.
I think I remember a message from the installer saying it installed a keyfile sowewhere, but I don't remember.
Can anybody please help me???
I'm not a pro, so the more details, the better. Thank you very much in advance. I really like Garuda and would really want to be able to get back in.

What change did you make?

The steps for reinstalling GRUB are available in several places (e.g. GRUB - ArchWiki), but it might be better to reinstall rather than messing around with something that's quite complicated.

2 Likes

Thank you for the fast response, jonathon.
I tried to make grub on boot automatically decrypt another drive as well. So I added another device into grubconfig, as cryptdevice2.
Yet, I messed up as I hadn't seen that I made no space between thew first device's UUID and cryptdevice2, so now after asking for the pw, grub says it cannot find the device, because it is the valid UUID immediately followed by cryptdevice2=/dev/sdb4 and grub complains first about the slash, and then about the device.
If I reinstall, I lose all my data too.
I think, fixing grub should be ok, if only I'd manager to get into the encrypted drive, but as I said, I cannot mount it. Probably I need to specify some keyfile that the installer put somewhere.
Once I can decrypt and mount it, I would try to chroot and fix the typo in grub config.

If this is your only problem, you may edit grub menu entry, press E at grub menu.

2 Likes