Hyprland wont open

I type the password on the login screen and log in, but it shows me a short black screen and throws me back to the login screen and this has annoyed me, no matter how many times I try, it has not changed.

Are you currently on live iso, i e. Installation stage? If yes, use open source drivers to boot into hyprland. It seems nvidia drivers have got some bugs.

See also this post Garuda hyprland booting issue in case you have already installed garuda hyprland.


I want to install it as the main operating system on my computer, but I tried the open source driver version and the nvidia version and it didn’t work and I didn’t make any mistakes in installing the iso and I reinstalled it a lot and it’s always the same thing, it throws me back to the login screen after a black screen.

Assure that you have latest ISO and please provide us with the full name of the ISO that you are using


First thing

:warning: Missing information requested in the template may result in not receiving assistance

Make sure you have done the following before you post:

Issue still unresolved? Then:

  • ONE issue per topic.

Use live ISO to post the FULL output of garuda-inxi in the body of the post (not linked externally, or collapsed with the “hide details” feature)

  • Format terminal output (including your garuda-inxi) as a code block by clicking the preformatted text button (</>) , or put three tildes (~) above and below the text

Next read


Try completing the installer with the “default” language/keyboard layout choices and see if it succeeds.

Or, if you’d like to serve as a “guinea pig”, make this proposed change to ~/.local/bin/garuda-locale.sh from a TTY or the live environment (not sure if you can log in to TTY or not) and see if it makes any difference: fix(garuda-hyprland-settings): Update garuda-locale.sh (!40) · Merge requests · Garuda Linux 🦅 / Themes and Settings / Settings / Garuda Hyprland Settings · GitLab

The proposed new file would look like this:

cat /tmp/garuda-locale.txt | grep Keymap > /tmp/keymap.txt

layout=$(cat /tmp/keymap.txt | awk '{ print $3 }' | cut -d- -f1)
variant=$(cat /tmp/keymap.txt | awk '{ print $3 }' | cut -d- -f2-)

sed -i "/kb_layout =/c\kb_layout = $layout" .config/hypr/hyprland.conf
if [ "$variant" != "$layout" ]
    sed -i "/kb_variant =/c\kb_variant = $variant" .config/hypr/hyprland.conf

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.