Hyprland Downloads | 240428 | Fixes | Nvidia

See I was able to boot Hyprland on bare metal just fine about a week ago with one of the earlier isos... Everything loaded for me, except it did crash when trying to open Firedragon then. I'll see if I can get to boot on bare metal again and start testing myself. Exciting progress!! :smile:

1 Like

Mh, work but I can’t download pictures or files, or upload with discourse app with FD.
Not to be used.
Flameshot-git had worked fine, now it doesn’t.
But only with me, with @ankur both go well. :smiley:

2 Likes

https://iso.builds.garudalinux.org/iso/community/hyprland/230625/

Now with SDDM login manager :crossed_fingers:

2 Likes

Excellent downloading it now and will tell you how it goes.

1 Like

Like with the Sway spin it gets stuck at the Live Keyring part of the boot up section which I assume is when SDDM is suppose to show its login screen.

I'm using the NVIDIA proprietary drivers, I have a 3080 but with a 32:9 resolution (5120x1440). I tried the open source drivers but my monitor doesn't pick up any signal (probably due to the resolution not being supported correctly).

What log file do I need to share with you to find the problem?

1 Like

I could not test it with SDDM on a computer with Nvidia GPU yet, with greetd it went, as with all other GPU’s only about TTY to log in.

I ask for patience and would be happy if you would try again at a later time.

On my notebook with AMD CPU and GPU no problem.


General notice:
This, Hyprland and the ISO, is beta and not for a beginner. You WILL encounter bugs!

1 Like

So I'm guessing these hyprland builds do not have the nvidia fix in them :slight_smile:

There is a fix? :smiley:

It was only booted, the display settings were not changed.
Free driver works, NVIDIA failed.

You should check if the hardware is Linux compatible when buying anyway.
Linux is not responsible if there is closed software for hardware drivers.

That’s why I wait with the purchase of hardware until I know that many hard-working helpers have done the work to make it usable on Linux.

It is often forgotten that all this only exists because there are enthusiasts who provide this in their spare time for the Linux community free of charge.

2 Likes

https://aur.archlinux.org/packages/hyprland-nvidia-git

I was on Windows for a good five years as my main driver due to game development and went back to Linux recently (was on it for twelve years before) cause I had enough of Windows. I had the 3080 before I went back to Linux - last time I used Linux as my main OS NVIDIA ruled supreme and AMD drivers were terrible (now it has changed). And looking at 3080 performance on AMD cards atm - the price isn’t really worth my time.

1 Like

Hi,
Running the Hypr beta an the laptop now. 25th June one....
SSDM booted ok took a few seconds after install but now is good after a reboot or two.
Have no icons (folder set on Dolphin )
icons are there , work on NWG full screen rofi ,
so I downloaded Thunar and it came up, with the garish neon candy icon set ;).
ill replace it soon.
..................
removed / reinstalled dolphin, no icons, (Im not worried dont like the kde files anyways.
Other than that this interation works ok on my Dell , Ryzen 5 . 6gb ram.
................
the icons in waybar up top was resolved couple of days ago as noted above.
........................
I also noted why my vm doesnt work, you guys use virtualbox, I use plain old boxes, i have too much trouble with vbox on rolling release, considering i only have a windows vm for 1 application . :slight_smile:
..........will continue testing ,
so far icon on dolphin only thing not working in 2 hours up that i can see.
edit...cursor disappears after i close a window./frame.
have to swipe cursor to top bar for it to reappear.. Im used to it now almost forgot it was a bug ...ill retest using mouse , now im thinking about it.
Regards,
Nebo

1 Like

Cursor disappearing is not a bug. works fine with my mouse is probably (laptop / my touchpad specific).

1 Like

Thanks, maybe @dr460nf1r3 can make a git from the git for us :slight_smile:

Yes, we don’t know what the problem is, @Ankur wrote me it never worked for him. With me sometimes, it varies without changing anything from ISO to ISO.
I will change it now to Thunar.

Also thanks to you for your help.

1 Like

https://iso.builds.garudalinux.org/iso/community/hyprland/

3 Likes

Nice to see the new login manager , it looks so cool:smiley:!!!

But forgot to change keybindings for thunar file manager :slightly_smiling_face:

1 Like

https://iso.builds.garudalinux.org/iso/community/hyprland/230630/

1 Like

Guess what I just did :thinking: :yum:

2 Likes

Hi,
This latest one works much smoother than previous on live usb.
Loaded onto the laptop... So cannot reproduce the log as have no page up to capture it all...and no skill to do a work around.. BUT error as follows.
GUI calamares is not starting (for me) , (already known) so i tried the sudo -E calamares -d
....................
This worked previously the three times this week i have loaded the different betas and run them on the laptop (metal)
...........................
error written on the gui is that calamares is unable to load all of the configured modules .
the following modules could not be loaded .
users@users
users@users

regards,
Nebo

edit 30-6-23 beta above

1 Like

Please, use

sudo -E calamares -D8

and post the log as text.
New build
https://iso.builds.garudalinux.org/iso/community/hyprland/230701/

1 Like

I did try the Archcraft Hyprland iSO which I donated to and it does work but it requires a bit of a work around. It uses hyprland-nvidia-git and it also requires to put certain grub settings in as well.

Here it is below:

I> nstall the nvidia-dkms driver and add it to your initramfs & kernel parameters.

For people using systemd-boot you can do this adding nvidia_drm.modeset=1 to the end of /boot/loader/entries/arch.conf. For people using grub you can do this by adding nvidia_drm.modeset=1 to the end of GRUB_CMDLINE_LINUX_DEFAULT= in /etc/default/grub, then run # grub-mkconfig -o /boot/grub/grub.cfg For others check out kernel parameters and how to add nvidia_drm.modeset=1 to your specific bootloader.

in /etc/mkinitcpio.conf add nvidia nvidia_modeset nvidia_uvm nvidia_drm to your MODULES

run # mkinitcpio --config /etc/mkinitcpio.conf --generate /boot/initramfs-custom.img (make sure you have the linux-headers package installed first)

add a new line to /etc/modprobe.d/nvidia.conf (make it if it does not exist) and add the line options nvidia-drm modeset=1

More information is available here: NVIDIA - ArchWiki

1 Like

I/we have a problem building with hyprland-nvidia-git, so, change later :slight_smile: .

For SDDM login screen.

bg-hypr

2 Likes