Huge issue stuck at Grub

So I was there, trying new kernels for graphic cards drivers.
Anyway, I installed some new but always keep the normal linux kernel.

I reboot my computer, the new kernel don't appear in the advance options, so no worries.

Then I log back in, and try to update the grub with garuda assistant. I reboot, the new kernels still don't show.

So I go back, and search for grub in the menu, and I find a software called something like grub manager, it offers to install it with pamac.

I do this, but DURING THE install I get a lot of weird errors saying something like (kernel needs to be compile with /proc). This error message opens like a thousand time, freezing my computer.

So I reboot it and I'M STUCK AT GRUB. no theme, when ichoose garuda, it says kernel not found
when I go to advance options not found, when I go to snapshots NOT FOUND again!!!

Please help, I need my computer to work!

Refer to my post here:

The issue is caused because grub is booting with configuration files from a snapshot instead of the actual system files. There is a further explanation in my post. I've been procrastinating on putting an announcement post out there about this issue, but I probably should soon since so many people seem to have this issue.

1 Like

You should still be able to get into grub without the theme file loaded.

Does the picture you posted recently resemble the problem you are having now?

Also, if you installed another program called grub-customizer(which I think is what you are referencing), you've got another problem on your hands(it's pretty depreciated software and doesn't work with grub anymore).

Yes the picture I posted is the problem I have. Grub won't launch anything saying "file not found" for kernels or any other things !

can I download garuda on a usb stick boot from there and fix that ?

"Press any key to continue..."

You should be able to hit any key(I would use something like enter) as it asks and still get into a barebones grub menu with no theme. From there, you can edit the "Garuda Linux" boot entry and apply the fix I provided in my previous post.

1 Like

Now I have this issue ... :cry: never ending nightmare...

"Failed to deactivate plymouth boot screen" is a standard error during boot.

If it freezes there, however, that means you have a graphics driver issue(Or a BIOS configuration issue).
It seems like you have a perfect trifecta of issues.

What graphics driver did you install, just for reference? I would assume Nvidia-dkms

latest nvidia dkms tkg

Ok, check in your BIOS and look at the "Initial Display Output" or Graphics Card "Slot."

If it is set to "Auto," try setting it to the slot your graphics card is installed in and rebooting(+apply fixes for the unrelated grub issue in boot entry)


initial display output was put on pcie 1 slot, and there is an option for igfx.

I think igfx is for intel integrated graphics should I try with this one ?

Ok so I managed to log in
what should I do now?

to fix this issue entirely

Please stop sending so many messages and edit your previous post with new info(Garuda Forums policy)

Anyways, I'm surprised you got in. What display output did you set?

To fix the grub issue, you can run the stuff I listed in my solution earlier.

If you got in using igfx, I'm not sure if it would load the nvidia drivers properly

TY, I fix it, to be clear it s not a chat.

Until nobody answer use old post for new news :slight_smile:

1 Like

I used a tkg kernel I had installed and it worked with the graphic drivers.

Got it! So the slot in the BIOS wasn't the issue.

What kernel were you trying to boot before? I believe chaotic-nvidia-tkg drivers only really work with tkg kernels

Linux nothing more

Alrighty then, glad this issue is solved!

In regards to any offer you made to me, all I ask is that you contribute to the community, if you think there is something you can help with. I do this to help people, not for money :smiling_face_with_three_hearts:


Well if getting you a video game can help you with prolonging your good mood, that would also help the community. Joke aside a thousand thanks for your help


I mark-it-solved ! :slight_smile: