How to setup libinput-gestures in kde?

I installed the dependencies: wmctrl & xdotool
Then installed libinput-gestures & gestures

But then libinput-gestures won't start on boot

so I tried:

 ╰─λ libinput-gestures-setup autostart
Systemd service is not available.

But I get the above error


I have to always have to run gestures app as root, otherwise I get the error:
can not read configuration file, please check permissions
How can I open it without root permissions?

Any good hints here?

E.g. You must be a member of the input group to have permission to read the touchpad device

1 Like

Sorry I didn't mention it before, I had already done that.


╭─[email protected] in ~ took 20ms
[🔴] × sudo libinput-gestures-setup service
[sudo] password for austin:      
Non-installation commands must be run as your own user.

 ╭─[email protected] in ~ took 1s
[🔴] × libinput-gestures-setup service
Systemd not available, can not run as service.

Shouldn't you enter

libinput-gestures-setup autostart start

to run it in autostart?


Which kde are you using

We setup libinput-gestures by default in all editions except barebones


Same error like the above ones

I am using Barebones edition :stuck_out_tongue_winking_eye:


So if it works it other editions, it shou;d work with barebones :thinking:

The difference could be here.

1 Like

That's exactly the reason why barebones is considered unsupported. We make some things easier by preinstalling stuff others might deem to be bloat :sweat_smile:


Thanks @filo

 Maintainer: Librewish <[email protected]>

pkgdesc="Metapkg for commonly used input devices such as fingerprint sensors or Wacom tablets"
pkgdesc="Meta package for input devices support."
optdepends=('piper: GTK application to configure gaming mice'
            'antimicrox: GUI for mapping keyboard keys to controller'
            'plasma-thunderbolt: Plasma integration for managing Thunderbolt devices')
package() {

  install -d $pkgdir/etc/xdg/autostart
  cp -rf $srcdir/libinput-gestures.desktop $pkgdir/etc/xdg/autostart

cp -rf $srcdir/libinput-gestures.desktop $pkgdir/etc/xdg/autostart in the install script seems to do the autostart stuff, but even after a reboot it doesn't work.
When I tried to do it manually( cp -rf $srcdir/libinput-gestures.desktop $pkgdir/etc/xdg/autostart), it seems that $srcdir/libinput-gestures.desktop doesn't exist,.

Then I checked /etc/xdg/autostart and there I found libinput-gestures.desktop file which was a symlink and pointed to /home/main-builder/pkgwork/libinput-gestures.desktop, which too didn't exist.

But if it doesn't work for me it shouldn't either work with other curated editions.
Is it that you install it some other way or is it that I am missing some steps :thinking:

Thank You

Good Night it's almost 12 midnight in India!

I last edited 24mins after post

Well, same here (with Dr460nized Ed.).
What I tried to do so far is that I removed that (wrong) symlink and copied "manually":

sudo cp /usr/share/applications/libinput-gestures.desktop /etc/xdg/autostart/

Then it worked (always as a desktop application, not as a service, but I think that this is what that cp should do).


Double fail on your part for not providing all the required information on your issue. You've been a member of the forum for a long time and you should be well aware of what is required when opening a help request.

Go to your room without dinner, and I'm cutting off your wifi access for the night as well. Let that be a lesson to you. :crazy_face:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.