How to set firedragon as default browser

Hi
Love Garuda Linux KDE Dr460nized. Gorgeous and pretty. Thanks

I want to set Firedragon as default browser but the option is grayed out and a message says:

"Your browser is being managed by your organization."

any hint?

Use .profile

3 Likes

Sorry, newbie here. What doesexactly mean "use .profile" ?

Open file .profile in your home folder with kate or

micro .profile

and change to your browser, I use firefox

export BROWSER=firefox

Start reading :slight_smile:

5 Likes

but that's ok. I opened .profile and there is firedragon defined as default browser already. :sweat_smile:

export AMD_VULKAN_ICD=RADV
export BROWSER=firedragon
export EDITOR=/usr/bin/micro
export GTK2_RC_FILES="$HOME/.gtkrc-2.0"
export MAIL=thunderbird
export TERM=xterm
export VISUAL=kate

so,any other config is needed?

In terminal

pacman -Qi firedragon firedragon-stable

post output please.

2 Likes

Well, the other possibility is setting the default browser in KDE settings -> default applications

4 Likes

Why do you think it is not already the default?

2 Likes

this one worked for me. I didn't had this file so I created a new one.
Use the following command to find out the right .desktop file:

ls /usr/share/applications | grep firedragon

The output should be something like:
'firedragon.desktop'
or: 'firedragon-stable.desktop'

then change the 'firefox.desktop' from the example with your output.

I hope this works for you in KDE too ^^

2 Likes

firedragon should be the default browser by default on garuda...It is atleast in my case