How to prevent FireDragon from trying to launch .jar links

I noticed how to always download, instead of trying to open .zip files but I cannot get .jar files to always download. Instead, I am asked if I'm sure i want to launch the .jar. How can I change it so the default is to always download the .jar?

I added screenshots to help explain what I am seeing.

I unchecked "Always open".

Here is the prompt to launch .jar which I want to avoid.
Java executable prompt
Where is the "Always open" check box?

  Kernel: 5.16.14-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=49e35eec-1ebd-48a5-bd14-4f07adbbc0b6 rw [email protected]
    quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
  Desktop: KDE Plasma 5.24.3 tk: Qt 5.15.3 info: latte-dock wm: kwin_x11
    vt: 2 dm: SDDM Distro: Garuda Linux base: Arch Linux
  Type: Laptop System: ASUSTeK product: G74Sx v: 1.0
    serial: <superuser required>
  Mobo: ASUSTeK model: G74Sx v: 1.0 serial: <superuser required>
    BIOS: American Megatrends v: G74Sx.201 date: 04/27/2011
  ID-1: BAT0 charge: 0 Wh (0.0%) condition: 64.3/78.0 Wh (82.5%) volts: 5.7
    min: 14.8 model: ASUSTek type: Li-ion serial: N/A status: N/A
  Info: model: Intel Core i7-2630QM bits: 64 type: MT MCP arch: Sandy Bridge
    family: 6 model-id: 0x2A (42) stepping: 7 microcode: 0x2F
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 6 MiB desc: 1x6 MiB
  Speed (MHz): avg: 988 high: 1549 min/max: 800/2900 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 893 2: 799 3: 908
    4: 798 5: 925 6: 833 7: 1549 8: 1199 bogomips: 31929
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GF116M [GeForce GT 560M] vendor: ASUSTeK driver: nvidia
    v: 390.147 alternate: nouveau,nvidia_drm pcie: gen: 2 speed: 5 GT/s
    lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:1251 class-ID: 0300
  Device-2: Sunplus Innovation ASUS Webcam type: USB driver: uvcvideo
    bus-ID: 1-1.2:4 chip-ID: 1bcf:2885 class-ID: 0e02
  Display: x11 server: X.Org v: compositor: kwin_x11 driver: X:
    loaded: nvidia gpu: nvidia display-ID: :1 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 128 s-size: 381x211mm (15.0x8.3")
    s-diag: 436mm (17.1")
  Monitor-1: LVDS-0 res: 1920x1080 hz: 60 dpi: 128
    size: 382x215mm (15.0x8.5") diag: 438mm (17.3")
  OpenGL: renderer: GeForce GTX 560M/PCIe/SSE2 v: 4.6.0 NVIDIA 390.147
    direct render: Yes
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio
    vendor: ASUSTeK driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
    chip-ID: 8086:1c20 class-ID: 0403
  Device-2: NVIDIA GF116 High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:0bee class-ID: 0403
  Sound Server-1: ALSA v: k5.16.14-zen1-1-zen running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.48 running: yes
  Device-1: Qualcomm Atheros AR9285 Wireless Network Adapter
    vendor: AzureWave AW-NB037H 802.11bgn driver: ath9k v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0 chip-ID: 168c:002b
    class-ID: 0280
  IF: wlp3s0 state: down mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK U6V/U31J laptop driver: r8169 v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: 9000 bus-ID: 05:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-1: Qualcomm Atheros AR3011 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 1-1.1:3 chip-ID: 0cf3:3005 class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
  Local Storage: total: 1.82 TiB used: 12.04 GiB (0.6%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: SanDisk model: SSD PLUS 2000GB
    size: 1.82 TiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 04RL scheme: MBR
  ID-1: / raw-size: 1.82 TiB size: 1.82 TiB (100.00%) used: 12.04 GiB (0.6%)
    fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-2: /home raw-size: 1.82 TiB size: 1.82 TiB (100.00%)
    used: 12.04 GiB (0.6%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-3: /var/log raw-size: 1.82 TiB size: 1.82 TiB (100.00%)
    used: 12.04 GiB (0.6%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-4: /var/tmp raw-size: 1.82 TiB size: 1.82 TiB (100.00%)
    used: 12.04 GiB (0.6%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 11.66 GiB used: 105 MiB (0.9%)
    priority: 100 dev: /dev/zram0
  System Temperatures: cpu: 77.0 C mobo: N/A gpu: nvidia temp: 77 C
  Fan Speeds (RPM): cpu: 3500
  Processes: 305 Uptime: 22h 43m wakeups: 16 Memory: 11.66 GiB
  used: 4.78 GiB (41.0%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.2.0 clang: 13.0.1 Packages: pacman: 1301 lib: 383 Shell: fish
  v: 3.3.1 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.13
e[1;34mGaruda (2.5.6-2):e[0m
e[1;34m  System install date:e[0m     2022-03-14
e[1;34m  Last full system update:e[0m 2022-03-15 e[1;31m↻
e[1;34m  Is partially upgraded:  e[0m No
e[1;34m  Relevant software:      e[0m NetworkManager
e[1;34m  Windows dual boot:      e[0m <superuser required>
e[1;34m  Snapshots:              e[0m Snapper
e[1;34m  Failed units:           e[0m 

It is possible I am not understanding, because in the screenshot it looks like those files are already downloaded.

But downloading without a prompt is a brand-new feature in Firefox 98, so will probably trickle down to Firedragon on the next release. More: Firefox 98.0, See All New Features, Updates and Fixes

I don't want FireDragon to try and launch the .jar. I never want it to do that. I only want to download.

Did you check FD settings, edit .jar to save file


I looked at the applications but .jar files didn't who and I didn't know how to add them. Can I add .jar files?


Try opening this page

It is a random link from sourceforge of a random .jar file.

So, as soon as 5 seconds are done, it automatically prompts where to save the file here. After downloading, it is just saved to the folder.

Is behavior different at your end?

1 Like

I get a prompt to launch or cancel. Launching uses Ark to open the jar like an .zip.

I would like it to just ask where to save or ask if I want to open the file. It doesn't do that for me.

Here is my application list where the .jar option is missing.


Here's how mine list looks like


I appreciate the help. I had to abandon Garuda on this computer for an unrelated reason. I'm going to pay more attention to the defaults on FireDragon next time I try the Plasma install.


This sounds like some developer-java application you have installed that is possibly using clever symbolic links to overwrite or over-privilege any application that touches a .jar file. Do you have any Java SDKs installed, and if so, try seeing if there is a setting that is related to auto-opening .jar or adding .jar to your path environment, etc.

e: holy batman I'm not sure why this post showed up in my feed, didn't mean to bump an ancient thread :negative_squared_cross_mark: