How to make animation smoother?

The animation in Latte Dock works but the icons seem little bit like dancing, especially when I slowly move the cursor over it. Is it possible to make it smoother?

Inxi -Fazxxxy

Please let me know if I have to paste any other information.

Edit: Also in this forum the same kind of glitch happens when I scroll. I think it must be a global problem.

Please help.

Thanks.

Afaik there is a setting when you rightclick -> edit dock -> animation which goes from 1 to 3. Just open the settings and play around a bit. :smiley:

1 Like

I already checked it. Yes it slowed the animation, but the glitch kind of thing still happens. As I edited my post, if I scroll over in this forum website, the background gradient also happens to be glitched. Am I the only one having this problem or does it just happen to everyone?

This is how it happens.

1 Like

A Garuda cloud link, nice! :grin:
Just tried to do the same, happens for me too (never noticed before tho). This must be a latte thing, might be worth reporting at their git? :thinking:

Should I reoprt here or here?

1 Like

Definitly at the actual latte-dock project page (Plasma / Latte Dock · GitLab). Reporting at AUR is suited when there is an issue with the package itself, this however is more of a source code thing :slight_smile:

2 Likes

It seems like a graphics animation general, not only latte. Do other KDE animations behave smoother?

Not all. Application Launcher, Latte pannel on the top, Window, etc. work fine. But when I'm visiting this Forum website, the background gradient behave like the same: when I scroll up or down, the bluish background also glitches. I want to make sure if it happens to everyone or only me.

Test if it happens with disabled Dark Reader extension in Firefox, or other browser extensions.

No, it's not a general issue.

2 Likes

I'm using Falkon, it doesn't support any third-party extensions.

Change compositor settings (OpenGL 2.0 or XRender and others) to see if it improves.

Also have a look at this

4 Likes

I tried changing it and rebooting, but no change.

I haven't installed Conky yet and have no idea what it is. I'll try installing it and check if I can do something there.

No no...that's counter productive, conky causes (in some cases) FPS drops. Unless you want it for some other reason, it will not help in graphics degradation.

3 Likes

Old thread but noticed the same. If you hover the latte dock the animations are super choppy. However if you disable the tooltips everything works fine.

Plasma / Latte Dock · GitLab