How to install dotnet (winetricks)

Im using this tutorial: GitHub - borisbabic/hearthstone_hdt_linux: Contains instructions and code to get hearthstone with hdt running on linux
But when i execute "WINEPREFIX=~/.wine.hearthstone winetricks dotnet472" this happens:

╰─λ WINEPREFIX=~/.wine.hearthstone winetricks dotnet472
SSL_INIT
Executing mkdir -p /home/z3r0ut
Using winetricks 20210206-next - sha256sum: 0769bbcdbd92c407f4eacaa85acc1339f607dbeafe2febd1be0912034c7af3a1 with wine-7.0-rc5 and WINEARCH=win32
Executing w_do_call dotnet472
Executing mkdir -p /home/z3r0ut
Executing load_dotnet472
Executing cd /home/z3r0ut/.cache/winetricks/dotnet472
Downloading https://download.microsoft.com/download/6/E/4/6E48E8AB-DC00-419E-9704-06DD46E5F81D/NDP472-KB4054530-x86-x64-AllOS-ENU.exe to /home/z3r0ut/.cache/winetricks/dotnet472
--2022-01-14 18:41:44--  https://download.microsoft.com/download/6/E/4/6E48E8AB-DC00-419E-9704-06DD46E5F81D/NDP472-KB4054530-x86-x64-AllOS-ENU.exe
SSL_INIT
Loaded CA certificate '/etc/ssl/certs/ca-certificates.crt'
Resolving download.microsoft.com (download.microsoft.com)... 2a02:26f0:b700:28d::e59, 2a02:26f0:b700:294::e59, 2.19.105.18
Connecting to download.microsoft.com (download.microsoft.com)|2a02:26f0:b700:28d::e59|:443... connected.
HTTP request sent, awaiting response... 404 Not Found
2022-01-14 18:41:44 ERROR 404: Not Found.

SSL_INIT
SSL_INIT
Executing cd /home/z3r0ut/.cache/winetricks/dotnet472
Downloading https://web.archive.org/web/2000/https://download.microsoft.com/download/6/E/4/6E48E8AB-DC00-419E-9704-06DD46E5F81D/NDP472-KB4054530-x86-x64-AllOS-ENU.exe to /home/z3r0ut/.cache/winetricks/dotnet472
--2022-01-14 18:41:44--  https://web.archive.org/web/2000/https://download.microsoft.com/download/6/E/4/6E48E8AB-DC00-419E-9704-06DD46E5F81D/NDP472-KB4054530-x86-x64-AllOS-ENU.exe
SSL_INIT
Loaded CA certificate '/etc/ssl/certs/ca-certificates.crt'
Resolving web.archive.org (web.archive.org)... 207.241.237.3
Connecting to web.archive.org (web.archive.org)|207.241.237.3|:443... connected.
HTTP request sent, awaiting response... Read error (Connection timed out) in headers.
Retrying.

--2022-01-14 18:42:03--  (try: 2)  https://web.archive.org/web/2000/https://download.microsoft.com/download/6/E/4/6E48E8AB-DC00-419E-9704-06DD46E5F81D/NDP472-KB4054530-x86-x64-AllOS-ENU.exe
SSL_INIT
Connecting to web.archive.org (web.archive.org)|207.241.237.3|:443... connected.
HTTP request sent, awaiting response... Read error (Connection timed out) in headers.
Retrying.

--2022-01-14 18:42:31--  (try: 3)  https://web.archive.org/web/2000/https://download.microsoft.com/download/6/E/4/6E48E8AB-DC00-419E-9704-06DD46E5F81D/NDP472-KB4054530-x86-x64-AllOS-ENU.exe
SSL_INIT
Connecting to web.archive.org (web.archive.org)|207.241.237.3|:443... connected.
HTTP request sent, awaiting response... 503 Service Unavailable
2022-01-14 18:42:37 ERROR 503: Service Unavailable.

------------------------------------------------------
warning: Downloading https://web.archive.org/web/2000/https://download.microsoft.com/download/6/E/4/6E48E8AB-DC00-419E-9704-06DD46E5F81D/NDP472-KB4054530-x86-x64-AllOS-ENU.exe failed
------------------------------------------------------

And i know that this tutorial works, cause i did follow it some months ago and everything worked. Now this.
Here my inxi -Faz

System:
Kernel: 5.16.0-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=040abae5-a66a-4e4e-96eb-be857e61b87b rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Console: pty pts/1 wm: kwin_x11 DM: SDDM Distro: Garuda Linux
base: Arch Linux
Machine:
Type: Desktop Mobo: Micro-Star model: B450M PRO-VDH MAX (MS-7A38) v: 8.0
serial: <filter> UEFI-[Legacy]: American Megatrends v: B.40
date: 11/07/2019
CPU:
Info: model: AMD Ryzen 5 3600X socket: AM4 bits: 64 type: MT MCP
arch: Zen 2 family: 0x17 (23) model-id: 0x71 (113) stepping: 0
microcode: 0x8701013
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 32 MiB desc: 2x16 MiB
Speed (MHz): avg: 3800 min/max: 2200/4409 boost: enabled
base/boost: 3800/4400 scaling: driver: acpi-cpufreq governor: performance
volts: 1.1 V ext-clock: 100 MHz cores: 1: 3800 2: 3800 3: 3800 4: 3800
5: 3800 6: 3800 7: 3800 8: 3800 9: 3800 10: 3800 11: 3800 12: 3800
bogomips: 91203
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT]
vendor: Tul driver: amdgpu v: kernel bus-ID: 2b:00.0 chip-ID: 1002:731f
class-ID: 0300
Display: server: X.Org 1.21.1.3 compositor: kwin_x11 driver:
loaded: amdgpu,ati unloaded: modesetting,radeon alternate: fbdev,vesa
display-ID: :0 screens: 1
Screen-1: 0 s-res: 4480x1440 s-dpi: 96 s-size: 1185x381mm (46.7x15.0")
s-diag: 1245mm (49")
Monitor-1: DisplayPort-0 res: 1920x1080 hz: 60 dpi: 102
size: 476x268mm (18.7x10.6") diag: 546mm (21.5")
Monitor-2: HDMI-A-0 res: 2560x1440 hz: 60 dpi: 109
size: 597x336mm (23.5x13.2") diag: 685mm (27")
OpenGL: renderer: AMD Radeon RX 5600 XT (NAVI10 DRM 3.44.0
5.16.0-zen1-1-zen LLVM 13.0.0)
v: 4.6 Mesa 21.3.4 direct render: Yes
Audio:
Device-1: AMD Navi 10 HDMI Audio driver: snd_hda_intel v: kernel
bus-ID: 2b:00.1 chip-ID: 1002:ab38 class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel bus-ID: 2d:00.4 chip-ID: 1022:1487
class-ID: 0403
Device-3: C-Media CM108 Audio Controller type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-3:4 chip-ID: 0d8c:013c
class-ID: 0300
Sound Server-1: ALSA v: k5.16.0-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.43 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Micro-Star MSI driver: r8169 v: kernel port: f000 bus-ID: 25:00.0
chip-ID: 10ec:8168 class-ID: 0200
IF: enp37s0 state: down mac: <filter>
Device-2: Realtek RTL8811AU 802.11a/b/g/n/ac WLAN Adapter type: USB
driver: rtl88XXau bus-ID: 1-3:2 chip-ID: 0bda:a811 class-ID: 0000
serial: <filter>
IF: wlp3s0f0u3 state: up mac: <filter>
IF-ID-1: anbox0 state: down mac: <filter>
IF-ID-2: enp3s0f0u1 state: unknown speed: -1 duplex: half mac: <filter>
Bluetooth:
Device-1: Spreadtrum W_K120 type: USB driver: rndis_host v: kernel
bus-ID: 1-1:4 chip-ID: 1782:5d20 class-ID: 0a00 serial: <filter>
Report: bt-service: enabled,stopped note: tool can't run
Drives:
Local Storage: total: 3.18 TiB used: 261.05 GiB (8.0%)
ID-1: /dev/sda maj-min: 8:0 vendor: Toshiba model: DT01ACA300
family: 3.5" DT01ACA... Desktop HDD size: 2.73 TiB block-size:
physical: 4096 B logical: 512 B sata: 3.0 speed: 6.0 Gb/s type: HDD
rpm: 7200 serial: <filter> rev: ABB0 temp: 39 C scheme: GPT
SMART: yes state: enabled health: PASSED on: 2y 183d 16h cycles: 1978
ID-2: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 750 EVO 500GB
family: based SSDs size: 465.76 GiB block-size: physical: 512 B
logical: 512 B sata: 3.1 speed: 6.0 Gb/s type: SSD serial: <filter>
rev: 1B6Q temp: 30 C scheme: MBR
SMART: yes state: enabled health: PASSED on: 2y 213d 13h cycles: 2332
written: 97.72 TiB
Partition:
ID-1: / raw-size: 465.76 GiB size: 465.76 GiB (100.00%)
used: 260.62 GiB (56.0%) fs: btrfs block-size: 4096 B dev: /dev/sdb1
maj-min: 8:17
ID-2: /home raw-size: 465.76 GiB size: 465.76 GiB (100.00%)
used: 260.62 GiB (56.0%) fs: btrfs block-size: 4096 B dev: /dev/sdb1
maj-min: 8:17
ID-3: /var/log raw-size: 465.76 GiB size: 465.76 GiB (100.00%)
used: 260.62 GiB (56.0%) fs: btrfs block-size: 4096 B dev: /dev/sdb1
maj-min: 8:17
ID-4: /var/tmp raw-size: 465.76 GiB size: 465.76 GiB (100.00%)
used: 260.62 GiB (56.0%) fs: btrfs block-size: 4096 B dev: /dev/sdb1
maj-min: 8:17
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.63 GiB used: 67.8 MiB (0.4%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 53.0 C
mem: 56.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 0
Info:
Processes: 415 Uptime: 1h 11m wakeups: 0 Memory: 15.63 GiB
used: 6.34 GiB (40.6%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 2104 lib: 477
Shell: fish (sudo) v: 3.3.1 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.11

Ask him in Discord, He has offered you the help.

If the below doesn't help you can create an issue or ask for help in my discord

Well, i would if the invite link where still active.

To be honest, I've checked it, the link is active. And pardon me as this is too Greek to me, I am not able to help you.

The server is unavailable or slow. All you can do is try again later - there's nothing to be fixed or solved within Garuda.

Oh youre right.. I had VPN active and probably that IP was already banned on that discord xD
(I didnt have VPN active while trying that command) sorry, the link is working..

1 Like

It's okay, Welcome to the community :slight_smile:

i solved it. i installed dotnet 48 instead of the dotnet 472.

That's more of a workaround rather than a solution, but at least it works.

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.