How to fix this side black bar

I got issue on my resolution, a black bar show up on right side of screen just when i set 1024x768 but the native resolution is: 1360x768. How to fix it?

image: Whats App Image 2023 12 14 at 16 24 42 — Postimages

this is xrandr output:
Screen 0: minimum 320 x 200, current 2048 x 768, maximum 16384 x 16384
DisplayPort-0 disconnected (normal left inverted right x axis y axis)
DisplayPort-1 disconnected (normal left inverted right x axis y axis)
DisplayPort-2 connected primary 1024x768+0+0 (normal left inverted right x axis y axis) 406mm x 229mm panning 1024x768+0+0
1366x768 59.79 +
1280x720 59.79
1024x768 75.03* 60.00
832x624 74.55
800x600 75.00 60.32
640x480 75.00 59.94
720x400 70.08
HDMI-A-0 connected 1024x768+1024+0 (normal left inverted right x axis y axis) 344mm x 194mm
1360x768 60.02 +
1280x720 60.02
1024x768 75.03* 70.07 60.00
832x624 74.55
800x600 72.19 75.00 60.32 56.25
640x480 75.00 72.81 66.67 59.94
720x400 70.08
DVI-D-0 disconnected (normal left inverted right x axis y axis)

inxi output:
CPU: quad core Intel Core i3-9100F (-MCP-) speed/min/max: 800/800/4200 MHz
Kernel: 6.6.7-zen1-1-zen x86_64 Up: 34m Mem: 4.69/15.53 GiB (30.2%)
Storage: 1.25 TiB (22.0% used) Procs: 240 Shell: fish inxi: 3.3.31

Hi @ldvy , as you mentioned you selected a resolution lower than yours , so change it to 1360x768
and please provide garuda-inxi every time you have an issue .

3 Likes

Exactly i set a lower resolution because is the only way to avoid the black bar appearing, when i select 1360x768, the black bar just appear, as I showed in the print

please go the terminal and paste this : garuda-inxi
copy what you got and past it in a comment

2 Likes
System:
Kernel: 6.6.7-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=bed46617-a919-4f08-b168-211062c486f6 rw rootflags=subvol=@
quiet resume=UUID=d91d658a-35b0-4279-b10d-44959e5a03af loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.11 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: ASUSTeK model: TUF H310M-PLUS GAMING/BR v: Rev X.0x
serial: <superuser required> UEFI: American Megatrends v: 2601
date: 07/17/2019
CPU:
Info: model: Intel Core i3-9100F bits: 64 type: MCP arch: Coffee Lake
gen: core 9 level: v3 note: check built: 2018 process: Intel 14nm family: 6
model-id: 0x9E (158) stepping: 0xA (10) microcode: 0xF4
Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB
desc: 1x6 MiB
Speed (MHz): avg: 800 min/max: 800/4200 scaling: driver: intel_pstate
governor: powersave cores: 1: 800 2: 800 3: 800 4: 800 bogomips: 28800
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Graphics:
Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
vendor: XFX Pine driver: amdgpu v: kernel arch: GCN-4 code: Arctic Islands
process: GF 14nm built: 2016-20 pcie: gen: 3 speed: 8 GT/s lanes: 4
link-max: lanes: 16 ports: active: DP-3,HDMI-A-1 empty: DP-1,DP-2,DVI-D-1
bus-ID: 01:00.0 chip-ID: 1002:67df class-ID: 0300 temp: 48.0 C
Display: x11 server: X.Org v: 21.1.10 with: Xwayland v: 23.2.3
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 2048x768 s-dpi: 96 s-size: 541x203mm (21.30x7.99")
s-diag: 578mm (22.75")
Monitor-1: DP-3 mapped: DisplayPort-2 pos: primary,left model: HP L185b
serial: <filter> built: 2011 res: 1024x768 hz: 75 dpi: 64 gamma: 1.2
size: 406x229mm (15.98x9.02") diag: 466mm (18.4") ratio: 16:9 modes:
max: 1366x768 min: 720x400
Monitor-2: HDMI-A-1 mapped: HDMI-A-0 pos: right model: Samsung SMB1630N
serial: <filter> built: 2010 res: 1024x768 hz: 75 dpi: 76 gamma: 1.2
size: 344x194mm (13.54x7.64") diag: 395mm (15.5") ratio: 16:9 modes:
max: 1360x768 min: 720x400
API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
device: 1 drv: swrast surfaceless: drv: radeonsi x11: drv: radeonsi
inactive: gbm,wayland
API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 23.2.1-arch1.2
glx-v: 1.4 direct-render: yes renderer: AMD Radeon RX 570 Series (polaris10
LLVM 16.0.6 DRM 3.54 6.6.7-zen1-1-zen) device-ID: 1002:67df
memory: 3.91 GiB unified: no
API: Vulkan v: 1.3.269 layers: 13 device: 0 type: discrete-gpu name: AMD
Radeon RX 570 Series (RADV POLARIS10) driver: mesa radv v: 23.2.1-arch1.2
device-ID: 1002:67df surfaces: xcb,xlib device: 1 type: cpu name: llvmpipe
(LLVM 16.0.6 256 bits) driver: mesa llvmpipe v: 23.2.1-arch1.2 (LLVM
16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Audio:
Device-1: Intel Cannon Lake PCH cAVS vendor: ASUSTeK driver: snd_hda_intel
v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
chip-ID: 8086:a348 class-ID: 0403
Device-2: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
vendor: XFX Pine driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s
lanes: 4 link-max: lanes: 16 bus-ID: 01:00.1 chip-ID: 1002:aaf0
class-ID: 0403
API: ALSA v: k6.6.7-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 1.0.0 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: kernel
port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15bc class-ID: 0200
IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:
Local Storage: total: 1.25 TiB used: 287.21 GiB (22.5%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM035-1RK172
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
tech: HDD rpm: 5400 serial: <filter> fw-rev: SDM2 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 840 EVO 250GB
size: 232.89 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: <filter> fw-rev: BB0Q scheme: GPT
ID-3: /dev/sdc maj-min: 8:32 model: TOP TURBO-120GB size: 111.79 GiB
block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s tech: SSD
serial: <filter> fw-rev: 7B0 scheme: GPT
Partition:
ID-1: / raw-size: 222.38 GiB size: 222.38 GiB (100.00%)
used: 27.33 GiB (12.3%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-2: /boot/efi raw-size: 513 MiB size: 512 MiB (99.80%)
used: 25.9 MiB (5.1%) fs: vfat dev: /dev/sdb3 maj-min: 8:19
ID-3: /home raw-size: 931.51 GiB size: 931.51 GiB (100.00%)
used: 180.99 GiB (19.4%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-4: /var/log raw-size: 222.38 GiB size: 222.38 GiB (100.00%)
used: 27.33 GiB (12.3%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-5: /var/tmp raw-size: 222.38 GiB size: 222.38 GiB (100.00%)
used: 27.33 GiB (12.3%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 15.53 GiB used: 2.8 GiB (18.0%)
priority: 100 comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 4
dev: /dev/zram0
ID-2: swap-2 type: partition size: 10 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/sdb1 maj-min: 8:17
Sensors:
System Temperatures: cpu: 47.0 C mobo: N/A gpu: amdgpu temp: 48.0 C
Fan Speeds (rpm): N/A gpu: amdgpu fan: 1030
Info:
Processes: 294 Uptime: 1h 24m wakeups: 0 Memory: total: 16 GiB
available: 15.53 GiB used: 9.23 GiB (59.4%) Init: systemd v: 255
default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
Packages: 1882 pm: pacman pkgs: 1877 libs: 559 tools: octopi,paru
pm: flatpak pkgs: 5 Shell: fish v: 3.6.4 running-in: konsole inxi: 3.3.31
Garuda (2.6.19-2):
System install date:     2023-12-10
Last full system update: 2023-12-14 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       Probably (Run as root to verify)
Failed units:

please do reboot to your system , and it appears that you have 2 monitors “1366x768” and “1360x768”

so you have to adjust every monitor resolution independently,for the Samsung use → “1360x768”
and for your HP → “1366x768”

already tried this, black bar still appearing =(

Hi @ldvy , i would recommend trying other DE (Gnome , XFCE ,etc…)since there is no clear answer to this .

1 Like

i tried with gnome but still the same problem

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.