Home network loses access to internet on login

$ inxi -Faz
System:    Kernel: 5.14.12-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=94d8548b-09b8-4476-8e48-e75fd81c6487
rw rootflags=subvol=@ quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 resume=UUID=4c0b2c4c-b1cc-4723-bc6a-fbb1edf3ee55 loglevel=3
Desktop: KDE Plasma 5.23.0 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:   Type: Desktop Mobo: ASUSTeK model: H110M-C/BR v: Rev X.0x serial: <filter>
UEFI: American Megatrends v: 0304 date: 01/12/2016
CPU:       Info: Dual Core model: Intel Core i3-6100 bits: 64 type: MT MCP arch: Skylake-S family: 6
model-id: 5E (94) stepping: 3 microcode: EA cache: L2: 3 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 29598
Speed: 3700 MHz min/max: 800/3700 MHz Core speeds (MHz): 1: 3700 2: 3700 3: 3700 4: 3700
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: NVIDIA GP106 [GeForce GTX 1060 3GB] vendor: ZOTAC driver: nvidia v: 470.74
alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1c02 class-ID: 0300
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: nvidia
unloaded: modesetting alternate: fbdev,nouveau,nv,vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 101 s-size: 483x272mm (19.0x10.7") s-diag: 554mm (21.8")
Monitor-1: HDMI-0 res: 1920x1080 hz: 75 dpi: 102 size: 480x270mm (18.9x10.6")
diag: 551mm (21.7")
OpenGL: renderer: NVIDIA GeForce GTX 1060 3GB/PCIe/SSE2 v: 4.6.0 NVIDIA 470.74
direct render: Yes
Audio:     Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: ASUSTeK driver: snd_hda_intel
v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a170 class-ID: 0403
Device-2: NVIDIA GP106 High Definition Audio vendor: ZOTAC driver: snd_hda_intel v: kernel
bus-ID: 01:00.1 chip-ID: 10de:10f1 class-ID: 0403
Sound Server-1: ALSA v: k5.14.12-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.38 running: yes
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK PRIME B450M-A
driver: r8169 v: kernel port: d000 bus-ID: 05:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth: Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB driver: btusb v: 0.8
bus-ID: 1-1:2 chip-ID: 0a12:0001 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:    Local Storage: total: 1.35 TiB used: 31.11 GiB (2.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 model: N/A size: 447.13 GiB block-size: physical: 512 B
logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 8A0 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST1000DM003-1CH162 size: 931.51 GiB
block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200
serial: <filter> rev: CC49 scheme: GPT
Partition: ID-1: / raw-size: 756.25 GiB size: 756.25 GiB (100.00%) used: 31.11 GiB (4.1%) fs: btrfs
dev: /dev/sdb3 maj-min: 8:19
ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%) used: 580 KiB (0.1%) fs: vfat
dev: /dev/sdb1 maj-min: 8:17
ID-3: /home raw-size: 756.25 GiB size: 756.25 GiB (100.00%) used: 31.11 GiB (4.1%) fs: btrfs
dev: /dev/sdb3 maj-min: 8:19
ID-4: /var/log raw-size: 756.25 GiB size: 756.25 GiB (100.00%) used: 31.11 GiB (4.1%) fs: btrfs
dev: /dev/sdb3 maj-min: 8:19
ID-5: /var/tmp raw-size: 756.25 GiB size: 756.25 GiB (100.00%) used: 31.11 GiB (4.1%) fs: btrfs
dev: /dev/sdb3 maj-min: 8:19
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.67 GiB used: 8.5 MiB (0.1%) priority: 100 dev: /dev/zram0
ID-2: swap-2 type: partition size: 9.77 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sdb2
maj-min: 8:18
Sensors:   System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nvidia temp: 41 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 56%
Info:      Processes: 242 Uptime: 23m wakeups: 0 Memory: 7.67 GiB used: 4.86 GiB (63.3%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 Packages: pacman: 1924 lib: 541 Shell: fish
v: 3.3.1 running-in: konsole inxi: 3.3.07

(this is my first time seeking assistance in the forum and my first language isn't English, so please inform me if I've made any mistakes)


I've recently installed Garuda linux dragonized gaming edition (using garuda-dr460nized-gaming-linux-zen-210928.iso) on my desktop, and most things have gone surprisingly smoothly for a rolling release distro.

The only major problem I've had so far is that, whenever I log in to kde plasma, my entire home network loses access to the internet. This includes every PC and smartphone in the house, wired connections and wi-fi.

This is not much of a problem since I only log in about once every day, but it would be nice to have it fixed.

Although being speculation, I suspect this might have something to do with the latte dock, as one time it crashed and the same problem repeated as it started up.

So far I've tried changing the link negotiation in the KDE network connections settings to automatic, but that did not solve the problem.

So far I am loving garuda linux, and I wish to be able to daily drive it for the for the foreseeable future, so I hope you can help me fix this issue.

Hi there, welcome.
This is really strange!
Have you already tried changing the ethernet cable?
Maybe it's faulty and gives wrong signal to the router...

1 Like

Hi, thanks for the quick response.

First, I would like to clarify something I forgot in the original post: the problem is temporary, after a minute or two the connection is restored.

I tried your suggestion, but the problem persisted. I even tried a direct connection to my modem instead of using a network splitter like I was using before, but the problem persisted.

I've tried changing the link negotiation to manual, but that did not fix the problem. I've also noticed that while the problem is active, the "online" indicator light in my modem turns off.

First thing to do if you suspect Latte could be causing issues on login is to introduce a 10 - 15 second Latte startup delay. Watch carefully for if your network connection starts properly while Latte is still dormant.

There are lots of things you can try to narrow the issue down.

The first thing is always cabling when dealing with Ethernet issues. The fact things work properly in Windows is irrelevant. Windows is far more fault tolerant than Linux of a marginal grade of cabling. Try another cable preferably cat7e or better.

Is your router's firmware up to date?

Do you have another router you can switch to temporarily? Any old one would be fine as a diagnostic step.

Do you have a spare Ethernet card you can swap in temporarily? Even a very old one will serve to narrow down if the card is the issue. A non r8168 based adapter would be best.

Try setting a static IP address on your Garuda computer.

Try disabling IPv6.

Try switching to the proprietary r8168 Realtek driver.

Probably a lot of other things to try as well, but I guess that's enough of a list for now.

Please provide feedback for all suggestions given.

Welcome to the forum.


Also download and test different Garuda live versions such as Gnome, Xfce, and LXQt for comparisson.


I've just confirmed the problem is with latte. The problem only occurs when latte is started with autostart. Does not happen if I start it with krunner.

1 Like

For now, I've disabled latte in the autostart and will manually launch it on startup.

I hope you can help me figure out this issue so I can use my desktop like normal.

Ok, I've found somethings out:

  • The problem occurs when latte is started from krunner or autostart.
  • The problem is independent from any widgets (Netspeed widget) or system tray icons (Networks icon).

I thing I will move this thread to the latte bug tracker, as it doesn't seem relevant to garuda linux.

Ok, I was really confident that the problem was with latte, but after uninstalling it and rebooting that proved untrue.

I think installing the proprietary network driver could help, but I do not know how to do that, so if you could guide me that would help.

Edit: Of course you just have to install a package to install the driver. I'm new to linux (lol)

Installing the driver did not fix the issue. I also tried booting with lts kernel instead of zen, but that did not fix it either.

The problem was not happening in the live version before, but now it is. Both the dragonized and dragonized-gaming live ISOs have the problem.

The xfce live ISO does not have the problem.

Probably your next best move would be to test the KDE barebones edition. If it also doesn't work correctly then you'll know this is a KDE issue. If the barebones edition does work correctly then it is likely an issue with the Dragonized version's configuration or package choices.

It's all a process of elimination that can be very time consuming and tedious.

Be sure to test a static IP configuration.

Good luck.

1 Like

The KDE barebones edition does not have this problem.

A static IP seems to solve the issue.

Thank you for your help.


I marked the relevant suggestion post as "Solution".
If something changes (hopefully not), we can remove that flag, of course.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.