Hibernation problems

Hey there,
I'm currently trying to get Hibernation/Hybrid-Sleep to work.
I can confirm, that this is/was working flawlessly, as I've used this for quite a while, but I've made the mistake to edit the service files directly, so when I recently updated, my changes got reverted, and now I can't get it to work anymore.
As for why I am not just using suspend: It recently kinda messed up pipewire and I had to restart my machine - And well that's kinda what suspend should be preventing, isn't it?

 ╰─λ cat /etc/systemd/system/systemd-hibernate.service.d/override.conf
File: /etc/systemd/system/systemd-hibernate.service.d/override.conf
Environment=SYSTEMD_BYPASS_HIBERNATION_MEMORY_CHECK=1
ProtectHome=read-only

 ╰─λ cat /etc/systemd/system/systemd-logind.service.d/override.conf
File: /etc/systemd/system/systemd-logind.service.d/override.conf
Environment=SYSTEMD_BYPASS_HIBERNATION_MEMORY_CHECK=1
ProtectHome=read-only

 ╰─λ cat /etc/systemd/system/systemd-suspend-then-hibernate.service.d/override.conf 
File: /etc/systemd/system/systemd-suspend-then-hibernate.service.d/override.conf
Environment=SYSTEMD_BYPASS_HIBERNATION_MEMORY_CHECK=1
ProtectHome=read-only

What could I be doing wrong?
Thanks!

System:    Kernel: 5.10.70-1-lts x86_64 bits: 64 compiler: gcc v: 11.1.0 
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts root=UUID=2a555427-5d35-463f-8011-b023a855b928 rw 
           [email protected] loglevel=3 quiet splash lsm=lockdown,yama,apparmor,bpf 
           Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 2 dm: Ly 0.5.3.r0.g4094d21 
           Distro: Garuda Linux base: Arch Linux 
Machine:   Type: Desktop System: Gigabyte product: AX370-Gaming 3 v: N/A serial: <filter> 
           Mobo: Gigabyte model: AX370-Gaming 3-CF v: x.x serial: <filter> UEFI-[Legacy]: American Megatrends v: F50a 
           date: 11/27/2019 
CPU:       Info: 6-Core model: AMD Ryzen 5 2600X bits: 64 type: MT MCP arch: Zen+ family: 17 (23) model-id: 8 stepping: 2 
           microcode: 800820D cache: L2: 3 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 86226 
           Speed: 3985 MHz min/max: 2200/3600 MHz boost: enabled Core speeds (MHz): 1: 3985 2: 4171 3: 4141 4: 4143 5: 4125 
           6: 4119 7: 4098 8: 4124 9: 4101 10: 4115 11: 4167 12: 4141 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Baffin [Radeon RX 550 640SP / RX 560/560X] vendor: ASUSTeK 
           driver: amdgpu v: kernel bus-ID: 08:00.0 chip-ID: 1002:67ff class-ID: 0300 
           Device-2: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo bus-ID: 3-4:4 chip-ID: 046d:0825 
           class-ID: 0102 serial: <filter> 
           Display: server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: amdgpu,ati unloaded: modesetting 
           alternate: fbdev,vesa display-ID: :0 screens: 1 
           Screen-1: 0 s-res: 3600x1200 s-dpi: 96 s-size: 952x317mm (37.5x12.5") s-diag: 1003mm (39.5") 
           Monitor-1: HDMI-A-0 res: 1680x1050 hz: 60 dpi: 90 size: 474x296mm (18.7x11.7") diag: 559mm (22") 
           Monitor-2: DVI-D-0 res: 1920x1200 hz: 60 dpi: 99 size: 495x310mm (19.5x12.2") diag: 584mm (23") 
           OpenGL: renderer: Radeon RX 560 Series (POLARIS11 DRM 3.40.0 5.10.70-1-lts LLVM 12.0.1) v: 4.6 Mesa 21.2.3 
           direct render: Yes 
Audio:     Device-1: AMD Baffin HDMI/DP Audio [Radeon RX 550 640SP / RX 560/560X] vendor: ASUSTeK driver: snd_hda_intel 
           v: kernel bus-ID: 08:00.1 chip-ID: 1002:aae0 class-ID: 0403 
           Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Gigabyte driver: snd_hda_intel v: kernel 
           bus-ID: 0a:00.3 chip-ID: 1022:1457 class-ID: 0403 
           Device-3: C-Media USB Microphone type: USB driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-2:3 
           chip-ID: 0d8c:9700 class-ID: 0300 serial: <filter> 
           Device-4: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo bus-ID: 3-4:4 chip-ID: 046d:0825 
           class-ID: 0102 serial: <filter> 
           Sound Server-1: ALSA v: k5.10.70-1-lts running: yes 
           Sound Server-2: sndio v: N/A running: no 
           Sound Server-3: JACK v: 1.9.19 running: no 
           Sound Server-4: PulseAudio v: 15.0 running: no 
           Sound Server-5: PipeWire v: 0.3.38 running: yes 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Gigabyte driver: r8169 v: kernel 
           port: f000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200 
           IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           IF-ID-1: docker0 state: down mac: <filter> 
           IF-ID-2: virbr0 state: down mac: <filter> 
Drives:    Local Storage: total: 2.96 TiB used: 1.46 TiB (49.3%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 1TB size: 931.51 GiB block-size: physical: 512 B 
           logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 4B6Q scheme: GPT 
           ID-2: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 860 EVO 250GB size: 232.89 GiB block-size: physical: 512 B 
           logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 1B6Q scheme: GPT 
           ID-3: /dev/sdc maj-min: 8:32 vendor: Western Digital model: WD20EFRX-68EUZN0 size: 1.82 TiB block-size: 
           physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: 0A82 scheme: GPT 
Partition: ID-1: / raw-size: 195.31 GiB size: 195.31 GiB (100.00%) used: 63.06 GiB (32.3%) fs: btrfs dev: /dev/sda2 
           maj-min: 8:2 
           ID-2: /home raw-size: 736.18 GiB size: 736.18 GiB (100.00%) used: 115.56 GiB (15.7%) fs: btrfs dev: /dev/sda3 
           maj-min: 8:3 
           ID-3: /var/log raw-size: 195.31 GiB size: 195.31 GiB (100.00%) used: 63.06 GiB (32.3%) fs: btrfs dev: /dev/sda2 
           maj-min: 8:2 
           ID-4: /var/tmp raw-size: 195.31 GiB size: 195.31 GiB (100.00%) used: 63.06 GiB (32.3%) fs: btrfs dev: /dev/sda2 
           maj-min: 8:2 
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) 
           ID-1: swap-1 type: zram size: 31.37 GiB used: 2 GiB (6.4%) priority: 100 dev: /dev/zram0 
Sensors:   System Temperatures: cpu: 40.4 C mobo: N/A gpu: amdgpu temp: 35.0 C 
           Fan Speeds (RPM): N/A gpu: amdgpu fan: 1420 
Info:      Processes: 438 Uptime: 8h 8m wakeups: 7 Memory: 31.37 GiB used: 7.61 GiB (24.3%) Init: systemd v: 249 
           tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: 2079 apt: 0 pacman: 2072 lib: 466 snap: 7 
           Shell: fish v: 3.3.1 running-in: yakuake inxi: 3.3.06 

I can't see a swap partition or file listed in your inxi output (and you don't have a RESUME parameter in your boot parameters) - do you have a device for hibernation?

3 Likes

Have you attempted rolling back your system with a snapshot from prior to these problems?

2 Likes

Yeah, but no luck :confused:
It's kinda gone

As I said, it has worked fine before - Even without a swap partition.
ZRam works fine, even though it's purpose is not to do so.

What is the RESUME parameter for?

It tells the kernel which device to look at for the hibernation image. If you've never had a swap partition or swap file, then you've never had hibernation working. Likely you've been suspending to RAM, and that's all.

1 Like

Hibernation on it's own did work properly, but it might be falling back to default suspending when it isn't able to hibernate? :thinking:

Confusing stuff - Maybe this actually could never have worked?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.