Help can't upgrade

Hello.

error: failed to commit transaction (conflicting files)
hwdata: /usr/share/hwdata/pci.ids exists in filesystem (owned by hwids)
hwdata: /usr/share/hwdata/pnp.ids exists in filesystem (owned by hwids)
hwdata: /usr/share/hwdata/usb.ids exists in filesystem (owned by hwids)
Errors occurred, no packages were upgraded.

:: Synchronizing package databases...
core is up to date
extra is up to date
community is up to date
multilib is up to date
chaotic-aur 1713.9 KiB 720 KiB/s 00:02 [------------------------------------] 100%
:: Starting full system upgrade...
:: Replace hwids with core/hwdata? [Y/n]
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing hwids breaks dependency 'hwids' required by corectrl

for replace hwids with hwdata you can remove hwids with sudo sudo pacman -Rdd hwids then update and install hwdata with sudo pacman -Syu hwdata

12 Likes

thanks to you i didn't punch a hole into any walls.

1 Like

solved by this solution, thanks man

thanks for the fix ...

Or just

:: replace hwids with core/hwdata? [Y/n] 

Y or enter.
:slight_smile:

1 Like

For some reason, this breaks the corectrl package because it has hwids as a dependency
but the repo uses the hwdata package
weird
just did a build from source code for now

1 Like

I use KDE and I started the latest upgrade using Konsole. The upgrade is asking:

--> Checking for keyring update before starting full system update..
warning: garuda-hotfixes-1.0.4-1 is up to date -- skipping
warning: archlinux-keyring-20211028-1 is up to date -- skipping
warning: chaotic-keyring-20210617-2 is up to date -- skipping
there is nothing to do
:: Starting full system upgrade...
warning: garuda-settings-manager-git: local (1.0.0.r1.g15c4106-3) is newer than chaotic-aur (1.0.0.r1.g15c4106-1)
warning: garuda-settings-manager-kcm-git: local (1.0.0.r1.g15c4106-3) is newer than chaotic-aur (1.0.0.r1.g15c4106-1)
:: Replace hwids with core/hwdata? [Y/n] Y
resolving dependencies...
:: There are 6 providers available for xdg-desktop-portal-impl:
:: Repository extra
  1) xdg-desktop-portal-gnome  2) xdg-desktop-portal-gtk  3) xdg-desktop-portal-kde                                          
:: Repository community
  4) xdg-desktop-portal-wlr                                                                                                  
:: Repository chaotic-aur
  5) xdg-desktop-portal-kde-git  6) xdg-desktop-portal-wlr-git                                                               

Enter a number (default=1): 5
looking for conflicting packages...
:: kirigami2-git and kirigami2 are in conflict. Remove kirigami2? [y/N]

In the last line, does the capital "N" mean that it is the default choice?

Yes :slight_smile: :slight_smile:

2 Likes

Here is what I got:

: kirigami2-git and kirigami2 are in conflict. Remove kirigami2? [y/N] N
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: kirigami2-git and kirigami2 are in conflict
Press enter to exit

Thanks, this also fixed it for me after a CPU upgrade on the same MoBo.

The default choice for replacements is always N, however, that will abort the update.

You pretty much always need to either select y on a replacement or alter your installed packages before updating.

2 Likes

In the case of the OP that wouldn't work because:

4 Likes

Mucho thanks! This unclogged my shitter ....issue. :wink:

Start eating more roughage for less of these type issues. :stuck_out_tongue_winking_eye:

1 Like

This is the reason why kirigami-git wants to be installed. Select 3 instead :slight_smile:

I'll fix this in about 1.5h, so just wait and try again :slight_smile:

4 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.