Headphone audio line issue

ISO - "GARUDA_DR46NIZEDGAMING_HARPEAG"

System:
Kernel: 5.15.13-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=17bd5743-8197-48ed-b4c0-d114373d7f80 rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1
resume=UUID=6ceb446c-b208-4e4a-b34e-8abea0557014 loglevel=3
Desktop: KDE Plasma 5.23.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: ASRock model: X570M Pro4 serial: <superuser required>
BIOS: American Megatrends v: P3.40 date: 01/27/2021
Battery:
Device-1: hidpp_battery_0 model: Logitech Craft Advanced Keyboard
serial: <filter> charge: 55% (should be ignored) rechargeable: yes
status: Discharging
Device-2: hidpp_battery_1
model: Logitech Wireless Mobile Mouse MX Anywhere 2S serial: <filter>
charge: 55% (should be ignored) rechargeable: yes status: Discharging
CPU:
Info: model: AMD Ryzen 7 3700X bits: 64 type: MT MCP arch: Zen 2
family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701021
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
L3: 32 MiB desc: 2x16 MiB
Speed (MHz): avg: 3626 high: 3980 min/max: 2200/4426 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3588 2: 3596
3: 3586 4: 3594 5: 3588 6: 3601 7: 3593 8: 3596 9: 3582 10: 3980 11: 3776
12: 3588 13: 3589 14: 3590 15: 3584 16: 3592 bogomips: 114977
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA GP107 [GeForce GTX 1050 Ti] vendor: Gigabyte
driver: nvidia v: 495.46 alternate: nouveau,nvidia_drm bus-ID: 09:00.0
chip-ID: 10de:1c82 class-ID: 0300
Display: x11 server: X.Org 1.21.1.3 compositor: kwin_x11 driver:
loaded: nvidia unloaded: modesetting alternate: fbdev,nouveau,nv,vesa
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1440x900 s-dpi: 89 s-size: 411x263mm (16.2x10.4")
s-diag: 488mm (19.2")
Monitor-1: HDMI-0 res: 1440x900 hz: 60 dpi: 90
size: 408x255mm (16.1x10.0") diag: 481mm (18.9")
OpenGL: renderer: NVIDIA GeForce GTX 1050 Ti/PCIe/SSE2
v: 4.6.0 NVIDIA 495.46 direct render: Yes
Audio:
Device-1: NVIDIA GP107GL High Definition Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel bus-ID: 09:00.1 chip-ID: 10de:0fb9
class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: ASRock
driver: snd_hda_intel v: kernel bus-ID: 0b:00.4 chip-ID: 1022:1487
class-ID: 0403
Sound Server-1: ALSA v: k5.15.13-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.43 running: yes
Network:
Device-1: Intel I211 Gigabit Network vendor: ASRock driver: igb v: kernel
port: f000 bus-ID: 05:00.0 chip-ID: 8086:1539 class-ID: 0200
IF: enp5s0 state: up speed: 100 Mbps duplex: full mac: <filter>
IF-ID-1: nordlynx state: unknown speed: N/A duplex: N/A mac: N/A
Drives:
Local Storage: total: 370.5 GiB used: 32.16 GiB (8.7%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Intel model: SSDSC2BW240A4
size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: DC12 scheme: MBR
ID-2: /dev/sdb maj-min: 8:16 type: USB model: USB DISK 3.0
size: 117.64 GiB block-size: physical: 512 B logical: 512 B type: N/A
serial: <filter> rev: PMAP scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
ID-3: /dev/sdc maj-min: 8:32 type: USB model: General size: 29.3 GiB
block-size: physical: 512 B logical: 512 B type: N/A serial: <filter>
rev: 5.00 scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
ID-1: / raw-size: 189.17 GiB size: 189.17 GiB (100.00%)
used: 32.16 GiB (17.0%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-2: /home raw-size: 189.17 GiB size: 189.17 GiB (100.00%)
used: 32.16 GiB (17.0%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-3: /var/log raw-size: 189.17 GiB size: 189.17 GiB (100.00%)
used: 32.16 GiB (17.0%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-4: /var/tmp raw-size: 189.17 GiB size: 189.17 GiB (100.00%)
used: 32.16 GiB (17.0%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.27 GiB used: 2 MiB (0.0%) priority: 100
dev: /dev/zram0
ID-2: swap-2 type: partition size: 34.4 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/sda2 maj-min: 8:2
Sensors:
System Temperatures: cpu: N/A mobo: N/A gpu: nvidia temp: 44 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 38%
Info:
Processes: 353 Uptime: 59m wakeups: 126 Memory: 31.27 GiB
used: 3.72 GiB (11.9%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1881 lib: 537 Shell: fish
v: 3.3.1 default: Bash v: 5.1.12 running-in: konsole inxi: 3.3.11

I recently installed Garuda Linux and ...

When I run my Garuda Linux “audio preferences” set to “line out” for speakers: online streaming videos (like those on YouTube and Amazon Prime) play fine – their audio is heard through my speakers.

However, when I switch over to “headphones” (in audio preferences), both online streaming videos and video files already on my PC (running through my media player) stop playing or continue playing with no sound. When on YouTube I’ll get this error message “Audio renderer error, please restart your computer” I have done that a few times and it doesn’t help.

- I checked the Arch forum and found someone suggesting to downgrade the kernel to fix the problem. I tried instead to upgrade it instead – but that had no effect. Does it mean that I stay stuck at a kernel version forever?

- I hear the audio coming through my headphones for a fraction of a second as I switch from “Line Out” to the “headphones” setting in my system preferences section.

- I’ve tried the system headphone test app and it sends audio to both the right and left channels of my headphones when it’s running that “Right Channel” / “Left Channel” test.

- I’ve set preferences on both my web browsers to accept sound from websites – no improvement

I tried reinstalling the following apps:

- pusleaudio-qt

- port audio

- lib32_portaudio

- lib32-faudio

- webrtc-audio-processing

….No effect on the outcome.

I tried also installing asla-audio and once I selected the right audio card, having a look at its mixer on the terminal – to see if any channels were turned off but only the ones that covered 5.1 & 7.1 Stereo were turned off.

Have you tried making a new user and logging in to see if the issue is related to the user profile?

1 Like

No - I didn't think about that. I'll try and update. Thanks for the suggestion.

That did the trick - but it wasn't smooth. In the other account, I kept switching back and forth between "line out" and "headphones" and after a few times back and forth, it seemed to loosen up somehow and then I got audio in my headphones.

Then I switched back to the original account (where I had been doing the same thing a lot before) and I did it a few times there and then it too sent audio into my headphones.

There was a short moment when the screen turned turning on and off (like slowed down flickering) and then it stopped.
Don't know what to make of it - but the audio is fine now.

Thanks again - at least I got unstuck.

Wow, that is strange. I can't help but be suspicious of that Nvidia audio driver, but the truth is I honestly don't even know what to make of that. Hopefully the fix sticks!

I realized that I was giving some "fuzzy talk" that wasn't going to be helpful to others experiencing a similar problem and looking for help. I think that i figured out what might have helped switch the audio in the headphones on ...even though it still took me switching back and forth between "line out" & "headphones" afterwards a few times to get it  unstuck...


right clicking on the audio icon and choosing "Configure Audio Devices" 

When one does that, one arrives at a simple layout showing just -
- Play back devices
- Inactive cards
- playback streams

It's called the "analog output" selections.

That's the one that I was used to messing with. I was just  randomly clicking around and clicked on the profile tab and switched it to "proaudio" (which I've never had a need to do before). When one does that, more choices are listed.

On the extreme right of each of those choices is a tiny, what I believe is called a "radio button"(which I originally thought it was just a design motif - duhhh!).

I clicked on one next to the "headphones" choice and it lit up green. Then I exited back to the original simple 
- Play back devices
- Inactive cards
- playback streams

"analog output" selections.

And like I said, I still didn't hear anything through my headphones until after a few times of switching back and forth between "line out" & "headphones" in the "port" tab.

And like i also said, while doing this, I had a short period of the screen video signal shutting off and turning back on (slow flickering). That's actually still happening occasionally (especially when I try to view streaming videos - like on YouTube) - but It began when I started messing with the audio settings.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.