Harpy-Eagle 211129 | XFCE4 | Garuda Tools launch incorrectly after reccommended post-install update

Hi, Everybody! Happy belated Ho-Ho.

I've done some searching on the forums, and found nothing related to the problem I encountered. Hopefully this is already on the forum using some terms I missed, or this is an easy fix I'm overlooking. Heck, maybe even a problem isolated to just me, and the current position of the planets, I don't know...

Before going into my problem, I have attached the output of inxi with the appropriate flags, as the automated message requested when I began writing this. I've attached the output below:

System:
  Kernel: 5.10.88-2-lts x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts
    root=UUID=d6730878-9f75-4983-b000-e35a0eb2cb1b rw [email protected]
    quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    systemd.unified_cgroup_hierarchy=1 loglevel=3
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm 4.16.1
    vt: 7 dm: LightDM 1.30.0 Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: Micro-Star model: B450 TOMAHAWK MAX (MS-7C02) v: 1.0
    serial: <superuser required> UEFI: American Megatrends LLC. v: 3.B0
    date: 05/12/2021
CPU:
  Info: model: AMD Ryzen 9 5900X bits: 64 type: MT MCP arch: Zen 3
    family: 0x19 (25) model-id: 0x21 (33) stepping: 0 microcode: 0xA201009
  Topology: cpus: 1x cores: 12 tpc: 2 threads: 24 smt: enabled cache:
    L1: 768 KiB desc: d-12x32 KiB; i-12x32 KiB L2: 6 MiB desc: 12x512 KiB
    L3: 64 MiB desc: 2x32 MiB
  Speed (MHz): avg: 4158 high: 4175 min/max: N/A cores: 1: 4171 2: 4162
    3: 4172 4: 4172 5: 3970 6: 4150 7: 4172 8: 4175 9: 4175 10: 4175 11: 4175
    12: 4173 13: 4175 14: 4172 15: 4164 16: 4158 17: 4174 18: 4175 19: 4172
    20: 4140 21: 4146 22: 4166 23: 4153 24: 4173 bogomips: 200417
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
    IBRS_FW, STIBP: always-on, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: NVIDIA GA106 [GeForce RTX 3060] vendor: ASUSTeK driver: nvidia
    v: 495.46 alternate: nouveau,nvidia_drm bus-ID: 26:00.0
    chip-ID: 10de:2503 class-ID: 0300
  Display: x11 server: X.Org 1.21.1.2 compositor: xfwm4 v: 4.16.1 driver:
    loaded: nvidia unloaded: modesetting alternate: fbdev,nouveau,nv,vesa
    display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 5760x1080 s-dpi: 96 s-size: 1524x286mm (60.0x11.3")
    s-diag: 1551mm (61")
  Monitor-1: DP-0 res: 1920x1080 dpi: 82 size: 597x336mm (23.5x13.2")
    diag: 685mm (27")
  Monitor-2: DP-2 res: 1920x1080 dpi: 82 size: 597x336mm (23.5x13.2")
    diag: 685mm (27")
  Monitor-3: DP-4 res: 1920x1080 dpi: 82 size: 597x336mm (23.5x13.2")
    diag: 685mm (27")
  Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
  Device-1: NVIDIA vendor: ASUSTeK driver: snd_hda_intel v: kernel
    bus-ID: 26:00.1 chip-ID: 10de:228e class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel bus-ID: 28:00.4 chip-ID: 1022:1487
    class-ID: 0403
  Device-3: SteelSeries ApS SteelSeries Arctis 7 type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-3:3 chip-ID: 1038:12ad
    class-ID: 0300
  Sound Server-1: ALSA v: k5.10.88-2-lts running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: JACK v: 1.9.19 running: no
  Sound Server-4: PulseAudio v: 15.0 running: no
  Sound Server-5: PipeWire v: 0.3.42 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Micro-Star MSI driver: r8169 v: kernel port: d000 bus-ID: 22:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: enp34s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
  Local Storage: total: 1.85 TiB used: 17.77 GiB (0.9%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: SNVS2000GB
    size: 1.82 TiB block-size: physical: 512 B logical: 512 B
    speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: S8442101
    temp: 36.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 type: USB vendor: A-Data
    model: USB Flash Drive size: 28.91 GiB block-size: physical: 512 B
    logical: 512 B type: SSD serial: <filter> rev: 1100 scheme: MBR
Partition:
  ID-1: / raw-size: 1.82 TiB size: 1.82 TiB (100.00%)
    used: 17.77 GiB (1.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 1.82 TiB size: 1.82 TiB (100.00%)
    used: 17.77 GiB (1.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 1.82 TiB size: 1.82 TiB (100.00%)
    used: 17.77 GiB (1.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 1.82 TiB size: 1.82 TiB (100.00%)
    used: 17.77 GiB (1.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 62.79 GiB used: 0 KiB (0.0%)
    priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 37.2 C mobo: N/A gpu: nvidia temp: 40 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Info:
  Processes: 455 Uptime: 3h 17m wakeups: 0 Memory: 62.79 GiB
  used: 6.33 GiB (10.1%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1465 lib: 354 Shell: Bash
  v: 5.1.12 running-in: xfce4-terminal inxi: 3.3.11

Hopefully the above formats correctly. I've not had to use this forum before, and I don't get a preview of what it will look like before posting.

I decided a fresh installation was in order, and encountered a problem with the latest XFCE4 version of Garuda. Specifically, the problem is with the custom built tools that come with it, such as garuda-gamer, and garuda-assistant. After performing post-install setup, Any Garuda tool that calls Alacritty to perform its task will silently fail that task with no output to the terminal, and no logs written to dmesg when called. Those tools will continue as if no error occurred.

After multiple attempts, I've managed to reliably reproduce the problem by performing the following steps:

  1. From a live environment, install Garuda Harpy-Eagle 211129, XFCE edition, fresh onto a local disk

  2. After installation, boot into the freshly installed environment. Perform login with your main account, not guest.

  3. After XFCE4 loads, I will be automatically prompted to perform post-install setup using the setup assistant. Alternatively, I will receive a warning in the icon tray instructing them to perform the post-install setup, or else the OS will be unstable/unusable.

  4. When the post-install setup is started, I'm asked if I wish to update the distribution. If I say yes, Alacritty will launch and perform a full system update.

  5. After the full system update, the additional software questions will occur as normal, but when it is time to pull the packages through pacman, Alacritty will not launch, and the Setup Assistant will close as if it had performed the task successfully, even though it clearly didn't.

  6. Any Garuda tool, such as garuda-assistant, or garuda-gamer, which call Alacritty to perform a task will silently fail to launch it, but will continue as if it was successful. Effectively making those tools useless. The only observable output is that the applicable Garuda tool window will sometimes "blink".

For example, let's say, after step 4, I went to remove the guest account using Garuda Assistant. When I uncheck that option in the Settings tab, and hit apply, the Garuda Assistant window will simply blink, rather than launch Alacritty to uninstall the required package to disable Guest User functionality. If I go back to Garuda Assistant, and check, the setting for the guest account will have never changed.

If I say no on step 4, or perform any task with the Garuda tools that launches a terminal on or before step 4, Alacritty will still launch and perform the tasks the Garuda tools have delegated. This will still be the case until after step 4, or an update is performed manually.

I have also tried KDE Dragonized edition, and I can confirm that this does NOT occur on that version.

I have tried the following for troubleshooting, all have had no success:

  • Made an alias between Alacritty, and xfce4-terminal.

  • Installed the git version of all impacted Garuda tools from the Garuda repos

  • Installed a different version of Alacritty

  • Installing Garuda tools from the package cache (I had a hunch that wouldn't work, to be honest)

Since I'm rather new to this distribution (6-ish months of use), I'm not going to opine on what the root cause would be. I'll leave that to the experts out there.

I have managed to reproduce this around 3 times now with 3 fresh installations on the same PC. Since I had to get that computer fully running again, I finished the rest of my setup by hand, rather than through the Garuda issued tools. This machine can still be used for testing, and fixing those tools, but if a fresh install is needed from me, I will have to do it in a VM for you.

While it's more of an inconvenience for me, this will be a major show-stopper for new users. Especially so, since Garuda is advertised as being friendly to new users, and emphasizes heavily that new users must follow the provided instructions. Problem is, in this case, following those instructions breaks the tools Garuda provides to administer key parts of this distribution. What makes this worse is that when following the instructions as provided, basic software such as a package manager will not install, which would leave a new user stuck right after installation.

I have been getting by with a few workarounds, with limited success:

  • Calling some of the Garuda tools with sudo or doas causes Alacritty to launch successfully, and perform the task it was delegated. So installing some pieces of software, or changing system settings is still possible. Not all options and tools work with this workaround. In addition, some of the settings and tools Garuda provides must be run as the user in question, rather than root.

  • If the commands that the Garuda tool was going to execute are already known beforehand, they can simply be called from any terminal instance, and run successfully. This also has limited success because only the developers of that tool, or people with extensive experience with Garuda would know what those commands are that the tools run. This leaves new users hosed, as they'd have no visibility into what those commands are.

Hopefully this is enough information for everybody. Please let me know if you need me to try anything on my end, or need more information.

I can confirm this. :point_up_2:

Calling some of the Garuda tools with sudo or doas causes Alacritty to launch successfully, and perform the task it was delegated. So installing some pieces of software, or changing system settings is still possible. Not all options and tools work with this workaround. In addition, some of the settings and tools Garuda provides must be run as the user in question, rather than root.

That was very helpful but is not really a fix.

I'll take a look at this when I've got some time. Might be a while.

1 Like

Fixed this in garuda-libs 1.0.1

Terminal-based stuff on XFCE should now work as intended again

1 Like

Could this help also for Gnome?
There were a couple of topics regarding setup assistant not working there, and I'm wondering if this was the same problem.
E.g.

1 Like

Not the same problem, no.
I'll have to take a look at that separately, I suppose :eyes:

3 Likes

Mercy me, that was quick.

I saw it in my package manager a few minutes ago, and I performed another update.

I can confirm that the terminal is launching successfully when called through garuda-assistant. garuda-gamer, no so much. Garuda-gamer is showing the same symptoms as it did before.

Maybe somebody else who's having the problem can try? I did some stuff by hand, so perhaps I broke a component. I remember another fellow in this thread saying they had this issue, too.

Let me know if you need me to perform any additional checks.

Garuda gamer works perfectly for me :thinking:

1 Like

Well that answers that, then. I must have broken it doing something else. Thanks for checking!

I don't know about you, but I feel we should keep this open for a day or so to see if any users pipe up about this. If not, I think we can safely say the problem is resolved.

Thanks for fixing that so quickly!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.