Hard Freeze right after Login

Hi. Im new to Garuda Linux and so far i am impressed with it.

I searched on the Forum as well as on duckduckgo to have a fix for my problem and i couldnt solve it.

Problem: I use Garuda Dragonized (Latest ISO with latest updates) and when i log in the entire PC locks/freezes hard right at the moment i arrive at the desktop (after typing in password + enter). keep in mind this doesnt happen everytime i log in, but instead it seems to be random, (especially at a reboot?). once everything freezes my keyboard doesnt register anything like TTY or anything. even pressing NUMLOCK doesnt do anything.

now this wouldnt be so bad but it screws the entire KDE sweetified layout up. after this crash the latte dock didnt show up at all. so i tried BTRFS Snapshot to revert this but it still remained the same:

screenshot: Screenshot-4 — ImgBB
(notice how the buttons that are usually on the left are now suddenly on the right. clicking on design-> "sweetified plasma" does not restore it)

I have taken the freedom to put garuda-inxi output into pastebin: Amogus - Pastebin.com

i have tried the following solutions:

  • reinstall the entire system from scratch:
    while this solution works it only works for a certain time. every reboot is russian roulette so im free of this problem until i have to reboot AND the problems start showing up again.

  • i did some digging with journalctl command

but i couldnt find much except these lines:

i dont have such problems with other distros. i really want to keep using garuda so maybe there is hope someone knows whats up

1 Like



Kernel: 5.16.4-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0

parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen

root=UUID=5a5035ac-36da-4de9-ace7-515ae8191930 rw [email protected]

quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0

resume=UUID=81924da1-1f0a-453b-8c5a-96d094212ce6 loglevel=3

Desktop: KDE Plasma 5.23.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11

vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux


Type: Desktop System: Thomas-Krenn.AG product: All Series v: N/A

serial: <superuser required>

Mobo: ASUSTeK model: H97M-E v: Rev X.0x serial: <superuser required>

UEFI: American Megatrends v: 2205 date: 10/09/2014


Device-1: ps-controller-battery-d0:bc:c1:56:99:04 model: N/A serial: N/A

charge: N/A status: Full


Info: model: Intel Core i5-4570S bits: 64 type: MCP arch: Haswell family: 6

model-id: 0x3C (60) stepping: 3 microcode: 0x28

Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB

desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB

desc: 1x6 MiB

Speed (MHz): avg: 2958 high: 3018 min/max: 800/3600 scaling:

driver: intel_cpufreq governor: performance cores: 1: 3008 2: 3018 3: 2900

4: 2908 bogomips: 23197

Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx


Type: itlb_multihit status: KVM: VMX disabled

Type: l1tf

mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled

Type: mds mitigation: Clear CPU buffers; SMT disabled

Type: meltdown mitigation: PTI

Type: spec_store_bypass

mitigation: Speculative Store Bypass disabled via prctl

Type: spectre_v1

mitigation: usercopy/swapgs barriers and __user pointer sanitization

Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,

IBRS_FW, STIBP: disabled, RSB filling

Type: srbds mitigation: Microcode

Type: tsx_async_abort status: Not affected


Device-1: NVIDIA TU117 [GeForce GTX 1650] vendor: Micro-Star MSI

driver: nvidia v: 495.46 alternate: nouveau,nvidia_drm bus-ID: 01:00.0

chip-ID: 10de:1f82 class-ID: 0300

Device-2: Logitech BRIO 4K Stream Edition type: USB

driver: hid-generic,snd-usb-audio,usbhid,uvcvideo bus-ID: 4-6:2

chip-ID: 046d:086b class-ID: 0300 serial: <filter>

Display: x11 server: X.Org compositor: kwin_x11 driver:

loaded: nvidia unloaded: modesetting alternate: fbdev,nouveau,nv,vesa

display-ID: :0 screens: 1

Screen-1: 0 s-res: 2560x1440 s-dpi: 92 s-size: 707x393mm (27.8x15.5")

s-diag: 809mm (31.8")

Monitor-1: DP-2 res: 2560x1440 hz: 165 dpi: 93

size: 697x392mm (27.4x15.4") diag: 800mm (31.5")

Message: Unable to show advanced data. Required tool glxinfo missing.


Device-1: Intel 9 Series Family HD Audio vendor: ASUSTeK

driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:8ca0

class-ID: 0403

Device-2: NVIDIA vendor: Micro-Star MSI driver: snd_hda_intel v: kernel

bus-ID: 01:00.1 chip-ID: 10de:10fa class-ID: 0403

Device-3: Sony DualSense wireless controller (PS5) type: USB

driver: playstation,snd-usb-audio,usbhid bus-ID: 3-7:5 chip-ID: 054c:0ce6

class-ID: 0300

Device-4: Logitech BRIO 4K Stream Edition type: USB

driver: hid-generic,snd-usb-audio,usbhid,uvcvideo bus-ID: 4-6:2

chip-ID: 046d:086b class-ID: 0300 serial: <filter>

Sound Server-1: ALSA v: k5.16.4-zen1-1-zen running: yes

Sound Server-2: PulseAudio v: 15.0 running: no

Sound Server-3: PipeWire v: 0.3.44 running: yes


Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet

vendor: ASUSTeK AM1I-A driver: r8169 v: kernel port: d000 bus-ID: 03:00.0

chip-ID: 10ec:8168 class-ID: 0200

IF: enp3s0 state: down mac: <filter>

Device-2: ASUSTek 802.11ac NIC type: USB driver: rtl8814au bus-ID: 3-4:2

chip-ID: 0b05:1853 class-ID: 0000 serial: <filter>

IF: wlp0s20u4 state: up mac: <filter>

Device-3: Sony DualSense wireless controller (PS5) type: USB

driver: playstation,snd-usb-audio,usbhid bus-ID: 3-7:5 chip-ID: 054c:0ce6

class-ID: 0300

IF-ID-1: vmnet1 state: unknown speed: N/A duplex: N/A mac: <filter>

IF-ID-2: vmnet8 state: unknown speed: N/A duplex: N/A mac: <filter>


Device-1: Edimax Edimax Bluetooth Adapter type: USB driver: btusb v: 0.8

bus-ID: 3-6:4 chip-ID: 7392:c611 class-ID: e001 serial: <filter>

Report: bt-adapter ID: hci0 rfk-id: 0 state: down

bt-service: enabled,running rfk-block: hardware: no software: yes

address: <filter>


Local Storage: total: 931.51 GiB used: 268.42 GiB (28.8%)

SMART Message: Unable to run smartctl. Root privileges required.

ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 1TB

size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s

type: SSD serial: <filter> rev: 3B6Q scheme: GPT


ID-1: / raw-size: 896.79 GiB size: 896.79 GiB (100.00%)

used: 268.42 GiB (29.9%) fs: btrfs dev: /dev/sda2 maj-min: 8:2

ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)

used: 576 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1

ID-3: /home raw-size: 896.79 GiB size: 896.79 GiB (100.00%)

used: 268.42 GiB (29.9%) fs: btrfs dev: /dev/sda2 maj-min: 8:2

ID-4: /var/log raw-size: 896.79 GiB size: 896.79 GiB (100.00%)

used: 268.42 GiB (29.9%) fs: btrfs dev: /dev/sda2 maj-min: 8:2

ID-5: /var/tmp raw-size: 896.79 GiB size: 896.79 GiB (100.00%)

used: 268.42 GiB (29.9%) fs: btrfs dev: /dev/sda2 maj-min: 8:2


Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)

ID-1: swap-1 type: partition size: 34.43 GiB used: 0 KiB (0.0%)

priority: -2 dev: /dev/sda3 maj-min: 8:3

ID-2: swap-2 type: zram size: 31.29 GiB used: 1.2 MiB (0.0%)

priority: 100 dev: /dev/zram0


System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nvidia temp: 57 C

Fan Speeds (RPM): N/A gpu: nvidia fan: 0%


Processes: 258 Uptime: 4m wakeups: 1 Memory: 31.3 GiB

used: 3.81 GiB (12.2%) Init: systemd v: 250 tool: systemctl Compilers:

gcc: 11.1.0 Packages: pacman: 1340 lib: 335 Shell: fish v: 3.3.1

default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.12

Garuda (2.5.3-1):

System install date: 2022-01-31

Last full system update: 2022-01-31

Is partially upgraded: No

Relevant software: NetworkManager

Windows dual boot: No/Undetected

Snapshots: Snapper

Failed units:

Also we have our own https://bin.garudalinux.org/ on upper right on forum page.


Use garuda-assistant for restore.

Best is you open for every problem one topic, we got confused if there are more than one in a topic :slight_smile:


thanks for the quick answer :+1: i will use the garuda bin for future pastes.

i used the assistant as you said to an earlier snapshot - sadly the design problem remained.

the mentioned design issue aside any suggestions to find out what could cause such a hard freeze/lock?

There has been many bios updates since the date of yours. Most of them are labeled "Improve system stability" . I would suggest updating to the latest bios version https://www.asus.com/us/supportonly/H97M-E/HelpDesk_BIOS/

Also, some hardware plays better with the linux-lts kernel. Some hardware setups have issues running other kernels. Hard lockups that even using REISUB won't let you reboot safetly out of.


With all the problems I almost forgot :wink:



@Kayo good idea, i updated the BIOS and will do a new install to see how things go and switch to lts kernel if necessary

@SGS thanks for the welcome :+1:

1 Like

Do not perform any system modifications other than updating your system after a fresh install to see if this problem is still occurring with a virgin install. If the freezes still occur, then start eliminating variables.

Have you checked your resource usage with htop or similar to see if anything is out of the ordinary. Disable Baloo after a fresh install if it is using a lot of resources.

Test at least three or four alternate kernels.

Install the linux-firmware-git package and then reboot.

Remove all peripheral devices, especially any wireless Bluetooth ones you are using. Try replacing them with old school versions if you have any kicking around.

Try disabling all your network devices in the bios if possible. You could also try blacklisting your network drivers and manually modprobing them when needed after startup.

Try disabling the compositor before you reboot.

Run a check on all your drives health using smartmon.

Run a check on your ram.

Try removing Latte from the autostart and start it manually once successfully in the desktop.

You will find a lot more suggestions if you search for "freeze", "lock up", "hard shut down", "hard lockup" or similar terms on the forum.

Report on every single fix you attempt in detail, otherwise a solution is very unlikely to be found.

Good luck, and welcome to the forum.


Problem solved :+1:

For those who have similar problems as me and just want to see the solution:

Step 1: Update BIOS to the latest, also switch from UEFI to legacy mode

Step 1.5: Make a clean install

Step 2: Install Linux-LTS Kernel

Step 3: (boot in LTS Kernel) Remove Zen Kernel because i didnt know how to tell the OS which Kernel should be the primary one :joy:

Thats it, everything is fine now. thanks @SGS @Kayo @tbg

Edit: i was a bit ambiguous about who exactly delivered the solution. to be more clear, it was @Kayo

Link to his solution: Hard Freeze right after Login - #5 by Kayo

Just for future reference if you wanted to have multiple kernels installed sometime, and wanted to change the default kernel boot option:


Generally on our forum we choose the person who made the suggestion, not the implementation as the marked solution. As @Kayo suggested both updating the bios and installing the LTS kernel, he should rightly be credited with the solve. I will switch the solution to @Kayo 's post in recognition of the fact he indeed pointed you in the right direction.

Nice job everyone in getting things fixed up here.


good thing to point out. in any case yesterday when i found his solution worked i marked @Kayo s post as the solution, maybe it didnt work. to be more clear with i edited my previous post to point out clearly that his solution worked :smiley:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.