[GUIDE] Configuring Garuda Linux for Laptop

Why isn't the Zen kernel suitable for laptop use?


In my experience it tries to push for performance and has caused my laptop to overheat and crash when gaming.

There are no gaming laptops. That's just an unfair selling point.

If you want to gamble properly, you need a desktop.


Can't agree more. Having fancy RGB light does not make laptops "gaming".


Not my concern. The convenience beats all other options for me.

I Agree with laptops not being for gaming. If you wanna game use a desktop machine.
Laptops cannot be cooled properly no matter how many vents there are and significantly reduces the lifespan on the laptop.


Well-cooled devices are quite loud. While the PC is under the desk, the laptop user gets the noise straight into their ears.
But the most important argument against a "gaming laptop" is: It is almost impossible to replace the graphics card and / or mobo when something new is available on the market.


Thats why I game with the volume on high or with headphones on. and yeah you cant replace them without a BGA machine, they're all soldered on the mobo; and the heat causes mobo warping. Macbook Pro 15" (mid 2010 - Mid2015) laptops are not even for gaming but suffers from GPU failure due to warping, even the machines with intergrated intel GPUs. Not a month goes by where I have to write one of these off as not worth repairing.

My desktop has 8 fans built-in, excluding the 3 thats on the GPU.


okay it's fine for humans how have probs with something like that
can you give me a advice for setting up in battery mode
on current my laptop works fine but in battery mode it is to slow to work fine with it

some laptops only turn on the GPU when the charger is plugged in. Garuda uses the GPU to render the desktop and all the effects. (at least thats what I gathered from the KDE GE)

The result of
systemctl status thermald.service
thermald[35727]: Config file /etc/thermald/thermal-conf.xml does not exist

Does a tool to create/ modify thermal-conf.xml exist?
To configure thermal-conf.xml is not simple.

You're checking the status of thermald.service. My instructions say to start the service first.

I humbly and slavishly followed your instructions. It seemed useless to write it.

I had enabled and started the service and after I checked the status.

Thats what happens when you don't specify exactly what you did. It was my fault for assuming instead of asking ngl. Back to the problem at hand. Sounds like you had an issue while installing because normally thermald ships with a default config. Did you check whether the file exists or not?

Maybe this could help?


HI! I follow all the steps listed above but unfortunately didn't work on my device. I just keep looking for a solution on the internet and I discover cpuppower-gui this aplication allows me to specify the governor and the frecuency on my cores, so I think maybe this app will work with anoter users. It worked for me.

Here is the link to check it out: GitHub - vagnum08/cpupower-gui: cpupower-gui is a graphical program that is used to change the scaling frequency limits of the cpu, similar to cpupower.

cpupower is for manual control of your cpu's governors. auto-cpufreq will manage your cpu automatically based on multiple parameters.

I know man, but autocpu-freq makes my laptop burn like hell even though I follow all your steps and even if I plugged out the power cable. Yes, the governor changes to "powersave" and "performance" respectively but nothing else. So, that links is mented to people that have issues whit auto-cpufreq and need to try something different. It's tedious and manul but if aint broke don't fix it

Well I use it in conjunction with thermald in all my setups and haven't had any issues yet.

1 Like

I followed the instructions here and on GitHub - Askannz/optimus-manager: A Linux program to handle GPU switching on Optimus laptops. but it looks like my laptop isn't loading the Nvidia driver, any idea how to fix it?

NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.
optimus-manager --switch nvidia  
WARNING : no power management option is currently enabled (this is the default since v1.2). Switching between GPUs will work but you will likely experience poor battery life.
Follow instructions at https://github.com/Askannz/optimus-manager/wiki/A-guide--to-power-management-options to enable power management.

modinfo: ERROR: Module nvidia not found.
WARNING : the nvidia module does not seem to be available for the current kernel. It is likely the Nvidia driver was not properly installed. GPU switching will probably fail,