GUI for FILES no longer works after update

after the large update this morning, I can no longer use 'FILES' or any option in the ARC Menu to view my fie system in a GUI. It's fine via terminal but this is rather annoying. I've gone back in snapshots trying to figure out what update caused this but I'm at a loss. Has anyone else had this problem and have they managed to fix it? Thanks.



GNOME is special, I have 212 updates today on i3 and all is fine.



Maybe file manager in Gnome is having bugs right now.

You can try dolphin, the file manager from KDE, or nemo, from Cinnamon as a fast fix.

Duckduckgo/ whoogle them to know installation method.


installing Dolphin worked like a charm! I don't know why I didn't think of that earlier, it seems so obvious. Thanks for your help, it's greatly appreciated.



Dolphin will bring in a lot of KDE dependencies. Midnight Commander is a great Terminal User Interface (TUI) alternative.

It has some unbelievably powerful features. You should keep it installed for those times your GUI apps won't respond.

It has single click, and double click suport for the mouse it is almost exactly like a dual paned GUI file manager (only in a terminal window) .

It looks pretty garish in the default color scheme, however there's lots of skins to make it all pretty like. Believe me it will save your bacon when your desktop is on the Fritz.

It has features galore, I can't praise it enough.


Bonus points for that one btw :innocent:


You're right about the KDE dependencies, there were an awful lot. I normally use Ranger as my terminal file browser but I'll definitely check out Midnight Commander, it sounds great. Thanks for the tip.


I somehow feel like these two issues are one and the same:

Please check if those 2 packages exist and remove them,

sudo pacman -R nautilus-mediainfo nautilus-admin

they are broken due to Archs Python 3.9 upgrade currently. Then try to launch Nautilus again, if it doesnt work via command line and post the output here.
Btw, removing Dolphin and all pulled dependencies is easily done by

sudo pacman -Rns dolphin

I tried removing both as you advised. Files (Nautilus) wouldn't launch via desktop icon. Here's the output I got trying to launch it in the terminal.

❯ nautilus
Initializing nautilus-image-converter extension
No module named PyPDF2

I found this in the AUR and installed, it didn't make any difference. This was the response I got.

❯ nautilus
Initializing nautilus-image-converter extension
No module named plumbum

When I check my system I find that I have the latest version installed already python-plumbum 1.6.9-1. So, I'm just as confused as before. :crazy_face:

1 Like
sudo pacman -Rns nautilus-pdf-tools

sudo pacman -Rns nautilus-pdf-tools

Hi, I tried but apparently the pdf-tools are not currently instaled.

❯ sudo pacman -Rns nautilus-pdf-tools
[sudo] password for schlumpf23:
error: target not found: nautilus-pdf-tools

Stranger and stranger but thanks for your suggestion.

Well if you look at the log you pasted above there is clearly a problem with the nautilus-image-converter as well. It seems these are all based on Python :thinking:

sudo pacman -R nautilus-image-converter

Then launch Nautilus again, if it still doesnt work look at the commandline output again and look if there is something like

Initializing nautilus-image-converter extension
No module named X

and remove the faulty extension :slight_smile:
This is how to fix bugs :joy: Its good though, so we can remove the faulty things out of the iso profiles for the next release :slight_smile:


Hi, I removed

sudo pacman -R nautilus-image-converter

but the outcome was

❯ nautilus
No module named 'plumbum'

I verified earlier that I had the latest version of this package installed. Thanks for your help BTW, greatly appreciated.


sudo pacman -Rns nautilus-pdf-tools-git
1 Like

Sorry, I get it now. I'll remove the plumbum' extension and see what happens.

Okay, just tested if Nautilus itself is functioning well. It does. So there has to be another extension installed which needs the module plumbum.
To find out which are installed you can search for them in Pamac by typing "nautilus-" or open the commandline and type "nautilus-" and press tab instead of enter. This will show the packages containing nautilus. :slight_smile:

Ha! Fixed it! The module causing all the problems turned out to be


Once removed, Nautilus functions as it should. Thanks to everyone who helped, it's been greatly appreciated.